Cisco 4402 and LDAP

Answered Question
Oct 1st, 2010

This is my situation:

I am trying to connect a wireless user thru the 4402 using a LDAP server for the SECURE network.  VLAN for secure network is 102. 

Security, LDAP (port 389) is authenticated, not anonymous.

WLANs, (profile name) SECURE, no layer 2 security, layer 3 is none, web policy & authentication are checked. AAA Server tab has LDAP server listed under server 1 and only LDAP is listed under "Order used for authentication".

Access Point has a DHCP address but the wireless connection always comes up as limited connectivity with no IP address.

ProCurve PoE switch connected to the 4402 has 111 (native), 112 (SECURE), and 131 (GUEST) trunked. 112 & 131 don't exist on any other ports.
Any help would be appreciated.
Stu
I have this problem too.
0 votes
Correct Answer by Stephen Rodriguez about 6 years 3 months ago

Stuart,

     This sounds like a DHCP issue.  What VLAN is the WLAN in?  I want to make sure as you say secure is 102, but then talk about 112 and 131 later.  What's providing DHCP for the WLAN?  What do you see when you rung a debug client < client mac addres > ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Stephen Rodriguez Tue, 10/05/2010 - 05:39

Stuart,

     This sounds like a DHCP issue.  What VLAN is the WLAN in?  I want to make sure as you say secure is 102, but then talk about 112 and 131 later.  What's providing DHCP for the WLAN?  What do you see when you rung a debug client < client mac addres > ?

stukatinsky Tue, 10/05/2010 - 15:19

It was a DHCP issue.  I made the 4402 the DHCP & now have an address

but can't authenticate thru LDAP.  Also need it to redirect automatically to the splash screen; in my case 1.1.1.1

Just opened a TAC because I'm running out of time.

Thanks.

Actions

This Discussion