VPN Help!!!

Unanswered Question
Oct 1st, 2010

I have a Cisco ASA 5505 connected to a Cisco 3600 router that does the routing for my home lap network.  I am wanting to setup a VPN so I can access my network while I am at a remote location.  Attached is my network layout to show how I have things setup right now.  Any assistance would be awesome, thanks.

Home_Network.jpg

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Kimberly Adams Fri, 10/01/2010 - 12:47

Jonathan,

What kind of VPN would you like to set up?  Are you looking at a remote access VPN or another kind?

Thanks,

Kimberly

woodjl1650 Fri, 10/01/2010 - 12:59

Just a simple VPN so I can access my home network, not sure what options I have avaible.

woodjl1650 Fri, 10/01/2010 - 13:43

Ok, followed the steps in the link provided....no luck.  Well at least I don't think... I don't know if I can test the VPN connection within the same home network or not.  Just to test an idea I had, I tried to ping my asa via the outside IP address and I did not get a reply.  Any idea on how I can test my VPN connection?  Anyone willing to test it if I provide a temp user name a password?

Thanks.

Kimberly Adams Fri, 10/01/2010 - 13:47

Jonathan,

Typically you cannot test this from the same network as to what you are trying to connect to with VPN.  Windows Firewall will also mess with the connection.  Some of the easiest way to test this connection is from WiFi hot spot or something simular.

If you don't have any other way to test this, please let me know and I could assist you with this.

Thanks,

Kimberly

woodjl1650 Fri, 10/01/2010 - 13:54

I figured I couldn't....yes, if you have any idea on how I can test my connection, I would greatly appreciate it.

Kimberly Adams Fri, 10/01/2010 - 13:58

Did you configure an IPSec VPN or an AnyConnect/SSL VPN?

Please let me know what the group name and password and a username and password.

woodjl1650 Fri, 10/01/2010 - 14:06

IPSec VPN

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} w\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);} /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Host IP: 174.56.139.62

Tunnel Group Name: vpnhome

User Name: homevpn

Password: henry999

Pre-share Key: vpntest

Pool Name: VPNHome

woodjl1650 Fri, 10/01/2010 - 14:24

Thanks, one last question.  With the way I have my network setup, I don't use the ASA as the DHCPserver or router, I have my 3600 for that...since I can connect to the ASA does that mean I can access my entire network via the ASA and VPN?  I main goal is to be able access my server where all my files are located, I use Win 2008 Server with Active Directory....

Thanks,

Jonathan

manish arora Fri, 10/01/2010 - 14:31

Just Make sure that you have route on the cisco 3600 for the vpn pool subnet. also setup reverse route on asa for that pool + there is a NAT exempt for the vpn pool subnet + setup the MTU on the windows server to something around 1280  so that you dont face MTU issues when packet get encrypted with ipsec & iskamp.

Thanks

Manish

woodjl1650 Fri, 10/01/2010 - 14:47

Alright, not too sure exactly how to do that.  Below is a current config of my router:

Current configuration : 1588 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$.7Q9$mJ4Y0sVUoAw8QZ/33g1JD/
enable password henry999
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.7
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp excluded-address 192.168.1.11 192.168.1.19
ip dhcp excluded-address 192.168.1.1 192.168.1.19
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8 8.8.4.4
!
!
!
username woodjl privilege 15 secret 5 $1$w.xT$cFJweRcOx29N9hKafqu4h1
username wooldjl privilege 15 secret 5 $1$4o6/$IO13XCGj9XXjIAGTsN3Yj0
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
router rip
version 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 192.168.1.0
no auto-summary
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
ip nat pool Home 192.168.1.1 192.168.1.24 netmask 255.255.255.0
!
snmp-server community 192.168.1.1 RO
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
password henry
login local
transport input telnet
!
!
end

Kimberly Adams Fri, 10/01/2010 - 14:35

Manish said to setup the routes and that will work, but if you would like to use your Active Directory server to authenticate against, then you will need to configure AAA services on the ASA.  This will allow you access to everything on your LAN and leverage your server for authentication.  The IPSec VPN will allow you to look like a workstation on your local network.

Thanks and I hope this answers your question.  You are welcome for the assistance, this is what this community is for.

Kimberly

manish arora Fri, 10/01/2010 - 15:30

No worries ! you have default pointing to the asa so you dont need any other routes.  This should work fine for you , make sure you dont have any MTU issues now when accessing anything from remote location.

I think you are good to go

Thanks

Manish

woodjl1650 Sun, 10/10/2010 - 09:20

Finally able to test my VPN connection, I am able to connect, but I don't have access to my network.  Does is matter that all I use my ASA for is a firewall?  I have the cable modem going into the ASA and routing the ASA to my Cisco 3660 Router, does that have anything to do with it?  Here is my current running config:

ASA Version 8.2(3) 
!
hostname ciscoasa
domain-name wood.homeesrv.com
enable password DQucN59Njn0OjpJL encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
dns-guard
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp 
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 8.8.8.8
 name-server 8.8.4.4
 domain-name wood.homeesrv.com
access-list inside_nat0_outbound extended permit ip 192.168.2.0 255.255.255.0 192.168.3.0 255.255.255.240 
access-list VPNWoodHome_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0 
access-list WoodVPN_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0 
pager lines 24
logging enable
logging asdm warnings
mtu inside 1500
mtu outside 1500
ip local pool HomeVPN 192.168.3.0-192.168.3.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
!
router rip
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 default-information originate
 version 2
!
route outside 0.0.0.0 0.0.0.0 174.56.139.1 1
route inside 192.168.1.0 255.255.255.0 192.168.2.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server VPN protocol radius
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
client-update enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 8.8.8.8 8.8.4.4 interface inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable inside
 enable outside
group-policy WoodVPN internal
group-policy WoodVPN attributes
 dns-server value 192.168.1.14 8.8.8.8
 vpn-tunnel-protocol IPSec webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value WoodVPN_splitTunnelAcl
 default-domain value wood.homeserv.com
username Jonathan password WsMCHUiqvEuA9Gmb encrypted privilege 15
tunnel-group WoodVPN type remote-access
tunnel-group WoodVPN general-attributes
 address-pool HomeVPN
 default-group-policy WoodVPN
tunnel-group WoodVPN ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:678222d40879101186c4fbb7308df576
: end
no asdm history enable
Rudresh V Sun, 10/10/2010 - 14:11

Hi Jonathan,

From the configuation of the ASA, i see that you are using RIP for routing, and you are advertizing the 192.168.3.0 network (with respect to the vpn pool). Now this should settle the routing requirement for the internal router, to point to the ASA for vpn traffic. The other possible thing that could cause issues with the internal network access would be that, there could be access-lists on the interfaces of the router behind the ASA that could be blocking the vpn traffic. Please check the access-lists on the ASA.

Also u can do a small test by doing a ping from your vpn client to the inside interface of the ASA, and see if packets reach the ASA. Plz paste the output of "sh cry ipsec sa" from the ASA after you connect to the ASA via vpn.

Let me know if this helps,

Cheers,

Rudresh V

Actions

This Discussion