Port Channel config for remote switches

Unanswered Question
Oct 1st, 2010
User Badges:

Hi guys, one last question before my network change this evening. Your input is valued as I'm not 100% comfortable with the change being remote from the site the changes are occuring at.


My scenario is this: I have a 6509 running 12.2(18)SXF10 and a remote 4948 running 12.2(46)SG. I currently have a single uplink between the two switches:


LAX6509#
!
interface GigabitEthernet2/17
description Uplink to LAX4948SW1 port 1/48
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no ip address
end

LAX4948SW1#
!
interface GigabitEthernet1/48
description Uplink to LAX6509 port 2/17
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
media-type rj45
no ethernet cfm enable
end

We are quickly approaching the max limit of that 1gigE uplink and would like to add a second uplink and "bond" them together for a 2gig link. I believe I just have to create a channel-group and place all the interfaces in that channel-group. Having said that, my plan is to bring up the two newest interfaces between the switches under the channel-group and then add the above existing ports to the same channel-group as well. Does the below config look correct? Am I missing anything?


New uplinks config:


LAX6509#
!
interface GigabitEthernet2/21
description Uplink to LAX4948SW1 port 1/46
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no ip address

channel-group 1 mode desirable

end

LAX4948SW1#
!
interface GigabitEthernet1/46
description Uplink to LAX6509 port 2/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

channel-group 1 mode desirable


Add existing interfaces to same channel-group ID



LAX6509#
!
interface GigabitEthernet2/17
description Uplink to LAX4948SW1 port 1/48
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no ip address

channel-group 1 mode desirable

LAX4948SW1#
!
interface GigabitEthernet1/48
description Uplink to LAX6509 port 2/17
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

channel-group 1 mode desirable


end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
danrya Fri, 10/01/2010 - 15:33
User Badges:
  • Bronze, 100 points or more

When configure the new link, I would recommend that you leave it in a "shutdown" state until the portchannel is configured.  When you bring the port up, an STP event will occur.  Then when you add it to the channel, another event will occur.  Then when you add the existing port to the channel, another event will occur.


I would suggest that you do it this way.


1. Shut down the new port on one side.

2. Configure the new port in the port-channel.

3. No shut the new port

4. Check to see what port is "root" and test the connection.

5. shut the old port

5a. make sure it still works!!!!!!

6. add the new port to the port-channel

7. no shut the new port.


Dan

glen.grant Fri, 10/01/2010 - 16:27
User Badges:
  • Purple, 4500 points or more

   The config will work  as you have it .   Shutdown all the ports on both sides , config your portchannel then bring each side up  with a no shut command on the port channel SVI .  This will bring both ports up at the same time and allow the switches to negotiate the channel gracefully .

Mark Walters Sun, 11/04/2012 - 00:43
User Badges:

I just had a similar need -- two switches with a single Gig link between them which i wanted to upgrade to a multi-gig etherchannel.  To make things fun, these switches were in production and remote (i.e. not accessible).  Minimizing the outage was essential, which was somewhat accomplished.  Here were my steps:


1) Had the new cable run between switches.  Kept the new ports shut down.

2) Pre-configured an "interface PortChannelX" on both sides, with identical config to the existing physical ports as well as each other

2) Configured the existing connection port on SwitchA to "channel-group X mode desireable"

     - note that a spannnig-tree topology change did occur, causing an outage of about 30 secs

2) Configured the existing connection port on SwitchB to "channel-group X mode desireable"

     - note that a spannnig-tree topology change did occur, causing an outage of about 30 secs

3) Added the new ports into the port channel.  No outage

4) 'no shut' the new ports.  no outage


cheers

mark

Actions

This Discussion