Xmit-Err Error on Catalyst 4006 please advice ASAP

Unanswered Question
Oct 2nd, 2010

I have a new 2901 router whose which is connected to Catalyst 4006. Speed/duplex are set to auto on both the ends and it's negotiated to 100mbps/full on both the ends. However I see some packet drops and on the switch side I can see Xmit-Err  Error as shown below. Kindly advice.

PCALJP00SW01> (enable) show port 3/31
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
3/31                    connected  20         normal a-full a-100 10/100BaseTX

Port  AuxiliaryVlan AuxVlan-Status     InlinePowered     PowerAllocated
                                   Admin Oper   Detected mWatt mA @51V
----- ------------- -------------- ----- ------ -------- ----- --------
3/31 none          none           -     -      -        -     -


Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
----- -------- --------- ------------- -------- -------- -------- -------
3/31 disabled  shutdown             0        0        1  enabled     105

Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
----- -------- ----------------- -------- ----------------- ------------------
3/31        0                 -        -                 -        -         -

Port  Status     Channel              Admin Ch
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
3/31 connected  auto silent            119     0

Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
----- ---------- ---------- ---------- ---------- ---------
3/31          -          0      23700          0         0

Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
----- ---------- ---------- ---------- ---------- --------- --------- ---------
3/31          0          0          0          0         1         0         0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Frederic Vanderbecq Mon, 10/18/2010 - 04:21

Hello,

an Xmit-err indicates a specific frame could not be forwarded because of an internal MAC sublayer transmit error. For instance, this could be an indication the internal transmit buffer is full.

Could you capture the output of "show counters" for that particular port two or three times in a row at the time the xmit-err is incrementing ?

If you see that "txQueueNotAvailable" counter is increasing at the same rateas that of Xmit-Error, it most probably means the port queues are overrun by traffic leading to packet drops and xmit-err.

Frederic

avilt Mon, 10/18/2010 - 23:08

Thank You. I will be connecting this router again with new LAN cables  to the switch this week end and let  you know the status.

Actions

This Discussion