cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
552
Views
9
Helpful
2
Replies

Two Cisco autonomous APs in bridge mode

tdennehy
Level 1
Level 1

I'm wondering if anyone has every used two

1242s in bridge mode with both the 2.4 and the 5GHz radios as part of the link.  If so, would you mind sharing?

If not, does anyone have any lab configs they would be willing to share?  This isn't for production - simply labbing it up as some training for students.

2 Replies 2

Elliott Shawd
Level 1
Level 1

It won't let you configure both radios for workgroup bridge mode.

Kayle Miller
Level 7
Level 7

If your trying to accomplish a Point to Point Bridging soultion it's fairly easy. although you can only do 1 radio at a time (either 2.4Ghz or 5ghz).

I don't presently have a full config I can post here, but I can give  you the biggest pieces of it.

!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname
!
no logging console
!
clock timezone GMT -5
ip subnet-zero
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
aaa session-id common
no dot11 igmp snooping-helper
dot11 vlan-name Lab vlan
!
dot11 ssid LAB-BRIDGE
   vlan
   authentication open
   infrastructure-ssid
   wpa-psk ascii 0
!
!
!
username cisco privilege 15 password 0 Cisco
!
bridge irb
!
!
interface Dot11Radio0   <--- or interface Dot11Radio1
no ip address
no ip route-cache
!
encryption mode ciphers tkip
!
ssid LAB-BRIDGE
!
speed basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 36.0 48.0 54.0
channel 5805
station-role root bridge       <------ This should be Root Bridge on 1 side and Non-root on the other
rts threshold 4000
concatenation
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1
no ip route-cache
bridge-group 254
bridge-group 254 spanning-disabled
!
interface Dot11Radio0.         <------ This should be the default VLAN if your doing VLANs
encapsulation dot1Q native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.         <------ This should be the same vlan as on the ssid line above.
encapsulation dot1Q
no ip route-cache
bridge-group 255
bridge-group 255 spanning-disabled
!
interface FastEthernet0.1
encapsulation dot1Q 1
no ip route-cache
bridge-group 254
bridge-group 254 spanning-disabled
!
interface FastEthernet0.           <------ This should be the default VLAN if your doing VLANs
encapsulation dot1Q native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface FastEthernet0.            <------ This should be the same vlan as on the ssid line above.
encapsulation dot1Q
no ip route-cache
bridge-group 255
bridge-group 255 spanning-disabled
!
interface BVI1
ip address x.x.x.x x.x.x.x
no ip route-cache
!
ip default-gateway x.x.x.x
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end

Please rate useful posts!!

Hope this helps


Thanks,

Kayle

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card