How VLAN works on this setup?

Answered Question
Oct 2nd, 2010

Hi there,

I have a good working setup and trying to find how basically it works in terms of VLAN processing and routing between source and its GW.

Here are the detail:

Server ip : 10.10.10.5

GW : 10.10.10.1 (Router_X)

a)I have a source server named Tetra in vlan 10 on access switch A

b) Switch A trunks over to distro switch Distro_SW with vlan 10 in allowed list

c) Switch Distro_SW (in vlan 10) connects to Router_X (physical ip address)

d) L2 vlan 10  is configured on SW_A and Distro_SW but no L3 config

I can see the routing table for the IP in Router_X but no info at all about the subnet in Distro_SW

Anyone can brief how exaclty this setup works just fine?

SW_A#sh run int g10/2
interface GigabitEthernet10/2
description Tetra  >>>>>>>>>>>>connected to server
switchport
switchport access vlan 10
switchport mode access
no ip address
spanning-tree portfast

Distro_SW#sh run int g1/7
interface GigabitEthernet1/7
description To SW_A  >>>>Connection to access SW_A
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,10
no ip address
udld port aggressive
mls qos vlan-based
end

Distro_SW#sh run int f9/37
interface FastEthernet9/37
description To Router_X  >>>>Connection to router
switchport
switchport access vlan 10
switchport mode access
no ip address
speed 100
duplex full

Router_X#sh run int g0/3
interface GigabitEthernet0/3
description Connection to Vlan10  >>>>to Distro_SW
ip address 10.10.10.1 255.255.255.0
duplex full
speed 100

Router_X#sh ip route 10.10.10.5
Routing entry for 10.10.10.0/24
  Known via "connected", distance 0, metric 0 (connected, via interface)
  * directly connected, via GigabitEthernet0/3
    
Distro_SW#sh ip ro 10.10.10.5
% Subnet not in table

Maybe its only involving a simple common sense to think, but i have tried my best understand the setup, and hope someone can shed some light on this :-)

regards,

SiraJ

I have this problem too.
0 votes
Correct Answer by milan.kulik about 6 years 2 months ago

Hi,

if the switch has no SVI configured in VLAN10, it still works as an L2 switch in that VLAN.

It means, when a default GW configured on the PCs is the router VLAN10 (sub)interface IP address, everything works fine as described in the original question.

It's possible to configure an L3 to route some VLANs (i.e., subnets) and to switch (L2 only) in other ones.

The LAN admin needs to know what and why is doing then as it can be a little confusing  if somebody new is checking the configs though.

BR,

Milan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Reza Sharifi Sat, 10/02/2010 - 09:21

Hi SiraJ,

The reason that you can not see 10.10.10.5 on your distro_sw is that that switch is only a layer-2 device not layer-3.  The only thing that your disrto_sw knows about is vlan 10 but not the IP address

HTH

Reza

SirajMuneer_2 Sat, 10/02/2010 - 09:35

So basicaly the access switch just sends the traffics via vlan trunks until it reaches GW router?

No routing involved between access swich and router?

I can see distro_sw is configured with bunch of other vlans in L3 SVI excerpt vlan 10.

So this setup doesnt need to involve vlan 10 SVI?

thanks

SiraJ

Reza Sharifi Sat, 10/02/2010 - 09:42

No routing involved between access swich and router?>

That is correct

So this setup doesnt need to involve vlan 10 SVI?>

If the switch has other SVIs with IP addresses, then it is layer-3 capable device and is doing routing.

HTH

Reza

Correct Answer
milan.kulik Sun, 10/03/2010 - 01:54

Hi,

if the switch has no SVI configured in VLAN10, it still works as an L2 switch in that VLAN.

It means, when a default GW configured on the PCs is the router VLAN10 (sub)interface IP address, everything works fine as described in the original question.

It's possible to configure an L3 to route some VLANs (i.e., subnets) and to switch (L2 only) in other ones.

The LAN admin needs to know what and why is doing then as it can be a little confusing  if somebody new is checking the configs though.

BR,

Milan

smartd_03 Sat, 10/02/2010 - 09:45

you dont have a default gateway set on your distro switch and ip routing should also be configured. Then in that cse you will be able to see routes in your network. Without this, switches do Layer 2.

Actions

This Discussion