IP phone registers to wrong CME

Unanswered Question
Oct 2nd, 2010

Our network currently has 2 CME's and because ip phones on different CME's are connected to the same switch we have had to set up each port on our switch's for switchport mode access and encap dot1q so that they can connect to both VLANS, The problem is that the phones often try to register with the wrong CME resulting in error: Registration failed: no config. When this happens we have to change the option 150 on the router the phone is trying to register to to point to the other CME, then when the phone registers we have to change it back.

Is there a way to set up a secondary option 150 so that when the phone fails to register with the CME it looks for its config on its secondary TFTP which would be the other CME.

the only other option i can think of is to go round to every switch in the network and find out which phones are on which VLANS and change the port to that VLAN which is a long process and then people would not be able to just pick up and move their phone to a different desk.

Iv tried to get people to change their numbers but execs are stubborn and wont let me change it.

thanks for any help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sun, 10/03/2010 - 03:58

You must have a problems with switches or other configuration element, because when properly set, a switch would separate traffic correct with only "switchport voice vlan xxx".

Udit Mehrotra Sun, 10/03/2010 - 15:47

From what I understand, you have phones for both CMEs in same VLAN. Generally people would configure two voice VLANs and have the phones for each CME in seperate VLAN and have a DHCP server in the concerned VLAN wih each DHCP server providing option 150 to the phones.

But as you seem to have both the phones in same VLAN (so it seems from your description of the problem) you can configure a secondary TFTP server using option 150 in dhcp pool.

Use the following command to keep A.B.C.D as primary TFTP server and W.X.Y.Z as secondary:

option 150 A.B.C.D W.X.Y.Z

Check the following link if you are stuck.

http://www.cisco.com/en/US/docs/ios/12_0t/12_0t1/feature/guide/Easyip2.html#wp21566

HTH

Udit Mehrotra Sun, 10/03/2010 - 15:48

You can also disable DHCP on the phone once it has the IP and DG and then manually assign TFTP server.

trentosis Tue, 10/05/2010 - 04:42

Both CME's are on seperate VLAN's but because we want people to be able to move desk's we have to set up each port on the switch as switchport mode trunk and not switchport voice vlan xxx.

the secondary tftp doesnt work i guess because their on different subnet's

the only option i can think of is going around to every phone and manually setting their vlan.

Paolo Bevilacqua Tue, 10/05/2010 - 05:04

My understanding is that you cannot statically configure the voice vlan in the phone.

You can manually configure the adminsitrativel VLAN, but that is something else and to be honest with you, I am not even sure what in practice.

trentosis Wed, 10/06/2010 - 23:45

staticly setting tftp on each phone does not work because when you turn dhcp back on it automatically looks for dhcp server and grabs a new option 150 address overwriting the static setting.

Actions

This Discussion