Error registering linksys SIP phones on CME

Answered Question
Oct 4th, 2010

Hello,

I have some Linksys SPA941 and SPA921 SIP phones and I'm trying to setup a CME on a 2811 router with IOS: c2800nm-ipvoicek9-mz.124-24.T2.bin

The problem is the phones won't register on the CME, I also tried using X-lite and no luck either.

I keep getting this error:

VOICE_REG_POOL: Register request for (cisco) from (10.5.0.10)
VOICE_REG_POOL: Invalid destination pattern (cisco)

Here is the relevant part of my running-config:

=====================================

ip dhcp pool VOICE
   network 10.5.0.0 255.255.255.0
   default-router 10.5.0.1
   domain-name voice.ulbsibiu.ro
   dns-server 194.169.191.190
   lease 0 0 30
!
!
voice service voip
allow-connections sip to sip
fax protocol cisco
sip
  registrar server expires max 600 min 60
!
!
!
!
!
voice register global
mode cme
source-address 10.5.0.1 port 5060
max-dn 10
max-pool 10
authenticate register
!
voice register dn  1
number 1111
allow watch
name JAY
label 1111
!
voice register pool  1
id mac 000E.083B.6E9F
number 1 dn 1
dtmf-relay rtp-nte sip-notify
username cisco password cisco
codec g711ulaw
!
dial-peer voice 1 voip
destination-pattern 1111
session protocol sipv2
session target ipv4:10.5.0.1
session transport udp
codec g711ulaw
!

=============================

Can anyone help me out please?

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 6 years 3 months ago

Set authentication username and registration number to be all the same, eg 1111

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (3 ratings)
Loading.
d.draghici Mon, 10/04/2010 - 03:30

it works now!

thanks a lot!!!!!!! i've been searching for a solution for the past 3 days, I never thought it would be that simple

Correct Answer
Paolo Bevilacqua Mon, 10/04/2010 - 03:09

Set authentication username and registration number to be all the same, eg 1111

Actions

This Discussion

Related Content