Resume AC on Power Loss BIOS policy not working

Unanswered Question
Oct 4th, 2010

Hi,

I'm having trouble getting this new BIOS policy feature "Resume AC on Power Loss" to work. I've tried both on v1.3(1c) as well as v1.3(1n) but to no avail.

After creating the BIOS policy with "Resume AC on Power Loss" set to "reset" (I've even tried using "last-state"), and attaching it to the Service Profile to a blade, upon powering off and on the chassis, the blades will still remain powered-off (amber light on the LED status of the blade).To boot up the blade, I would need to manually click "boot server". What I want to achieve is to be able to boot up the server automatically without manual intervention upon power recovery.

I've compared the BIOS default policy and also the BIOS policy (which we can create), the "Resume AC on Power Loss" option is not available on the default policy but it's available if you create a BIOS policy (screen captured attached).

Any suggestions to fix this problem?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
adambaum1 Mon, 10/04/2010 - 15:58

Steve,

Can you please clarify your method for powering off/on?  Are you doing it via UCS Manager or are you pulling the power cables out?  The reason I ask is that the BIOS setting is meant for power outages, not graceful shutdowns.

adam

steven.pw.lau Mon, 10/04/2010 - 17:28

Hi Adam,

Powering off/on is via pulling off power cables and configuration of the option to power up the blades upon power restoration is via Service Profile (BIOS policy) via UCSM.

Thanks.

Robert Elmes Fri, 10/08/2010 - 06:04

We too are finding that this isn't working.

Running:

B200 M1 Blades

BIOS Version S5500.1.3.1c.0.052020101544

CIMC: 1.3(1c)

Interestingly although I can set the "Resume AC On Power Loss" setting in the BIOS Policy and apply this to the service profile, if you look under the BIOS Defaults, this option only shows for the defaults of the B440-M1 under the UCSM, for all others it shows the option briefly but then hides it!

Has anyone had sucess with this?

mihanlin Wed, 10/13/2010 - 16:33

Hi Robert, Steven

I found the same issue here. I've filed a bug (CSCtj48192) to have it investigated. Seems like you can do it in the CLI, so it's only missing in the GUI.

You can set it in the CLI using the following:

apac-dcn-ucs-01-B# scope system
apac-dcn-ucs-01-B /system # scope server-defaults
apac-dcn-ucs-01-B /system/server-defaults # show platform

Platform:
    Product Name Vendor     Model      Revision
    ------------ ---------- ---------- --------
    Cisco B200-M1
                 Cisco Systems, Inc.
                            N20-B6620-1
                                       0
    Cisco B250-M1
                 Cisco Systems, Inc.
                            N20-B6620-2
                                       0
    Cisco B200-M2
                 Cisco Systems, Inc.
                            N20-B6625-1
                                       0
    Cisco B250-M2
                 Cisco Systems, Inc.
                            N20-B6625-2
                                       0
    Cisco B440-M1
                 Cisco Systems, Inc.
                            N20-B6740-2
                                       0
apac-dcn-ucs-01-B /system/server-defaults # scope platf "Cisco Systems, Inc." N20-B6620-2 0
apac-dcn-ucs-01-B /system/server-defaults/platform # scope bios-settings
apac-dcn-ucs-01-B /system/server-defaults/platform/bios-settings* # set
resume-ac-on-power-loss-config resume-action reset

Then, commit-buffer to save the settings.

Cheers,

Michael

mihanlin Wed, 10/13/2010 - 18:26

Ok,

Turns out that this feature is not supported in the BIOS for the models before B440. That is why you're not seeing it in the GUI.

If you try to commit the config in the BIOS defaults CLI settings, it will error out as well.

That would be why when you power back up the chassis it doesn't adhere to the power setting in your BIOS policy.

Thanks,

Michael.

steven.pw.lau Wed, 10/13/2010 - 18:44

Hi Michael,

Thanks.. You mean when in CLI, it gives you an error when you commit the above settings?

I'll try it out here as well.

Jennifer Casella Wed, 10/13/2010 - 19:58

Hey Steven -

Yes, MIchael is referring to an error message you will get if trying to apply this BIOS setting to a platform other than B440:

UCS1-A /system/server-defaults/platform/bios-settings # set resume-ac-on-power-loss-config resume-action reset
UCS1-A /system/server-defaults/platform/bios-settings* # commit-buffer
Error: Update failed: [Cannot create non-creatable object of class:biosVfResumeOnACPowerLoss]

Jen

Actions

This Discussion