IP-TV on 3750. Can't configure MVR

Unanswered Question
Oct 4th, 2010
User Badges:

Hello!


I am trying to configure multicast streaming. I configured successfully streaming, where server and client are in one VLAN, all is ok, but now I'm trying to stream to different VLANS. I have catalyst 3750 switch and two hosts, one streams, second listens. I configured 3750 like in manual, but can't understand why i don't see the image on client, because mvr members are active.


Network scheme: (client-VLAN10)---/gi1/0/2/---(3750)---/gi1/0/4/---(server-VLAN20)


My switch current config is above:



Current configuration : 3714 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cisco3

!

boot-start-marker

boot-end-marker

!

enable secret ***

enable password ***

!

no aaa new-model

switch 1 provision ws-c3750g-24t

system mtu routing 1500

vtp mode transparent

ip subnet-zero

ip routing

!

!

ip igmp snooping querier

ip igmp profile 1

    permit

    range 227.24.1.250 227.24.1.250

!

mvr vlan 20

mvr group 227.24.1.250

mvr

!

crypto pki trustpoint TP-self-signed-1552593280

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1552593280

revocation-check none

rsakeypair TP-self-signed-1552593280

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 10

name IPTV-CLIENTS

!

vlan 20

name IPTV-Server

!

!

!

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

switchport access vlan 10

switchport mode access

mvr type receiver

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

switchport access vlan 20

switchport mode access

mvr type source

!

//nothing configured on interfaces 5 - 24

!

interface GigabitEthernet1/0/24

!

interface Vlan1

ip address 83.241.1.1 255.255.255.0

!

interface Vlan10

description IPTV-clients

ip address 83.241.10.1 255.255.255.0

ip pim dense-mode

!

interface Vlan20

description IPTV-Server

ip address 83.241.20.1 255.255.255.0

ip pim dense-mode

!

ip classless

ip http server

ip http secure-server

!

!

!


=====================

#show mvr

MVR Running: TRUE

MVR multicast VLAN: 20

MVR Max Multicast Groups: 256

MVR Current multicast groups: 1

MVR Global query response time: 5 (tenths of sec)

MVR Mode: compatible

=====================

#show mvr interface

Port      Type       Status           Immediate Leave

----      ----       ------           ---------------

Gi1/0/2   RECEIVER   ACTIVE/UP        DISABLED

Gi1/0/4   SOURCE     ACTIVE/UP        DISABLED

=====================

#show mvr members

MVR Group IP    Status          Members

------------    ------          -------

227.024.001.250 ACTIVE          Gi1/0/2(d), Gi1/0/4(s)

======================


Any suggestions? Thanks a lot for your answers!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
eblazevics Tue, 10/05/2010 - 00:26
User Badges:

Thank you, but I have read it many times and not only this chapter in this manual, but there wasn't working solutions for me.

Actions

This Discussion

Related Content