Failed to Initialize VoiceView - Unable to open port 80

Answered Question
Oct 5th, 2010

When attempting to Cisco "Smart" Call Connector Advanced, under the VoiceView tab, I get the error: Failed to Initialize VoiceView - Unable to open port 80.

I worked with Sonny at CallComm for a hour or two disabling firewalls on the server, the client and changing ports here and trying this and that.

We left off thinking that port 80 on the client must be free and I dont know why it wouldnt be.

Why kind of programmer creates a local webserver, on a static port, without checking to see if its in use - to access info (voicemail) on another server?

--

Frustrated

I have this problem too.
0 votes
Correct Answer by shtalukd about 3 years 6 months ago

Hi Brook,

Skype has an option for not using port 80 for incoming connections. You need to uncheck under Options->Advanced->Connections the following " Use port 80 and 443 as alternatives for incoming connections"

With respect to the grey VoiceView field -- some files appear to be left in Windows System32 after the uninstallation of the previous versions of CallConnectors  including the ccTrog.dll and ccSkinny.dll. These files have caaused issues with the Advanced Client operation as the newer versions in the Common Files folder were not being accessed.

Thanks

CallConnector Team

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.5 (2 ratings)
shtalukd Wed, 10/06/2010 - 11:29

Hi Brook:

We understand the potential issues associated with requiring port 80 to be available on the user's PC. Unfortunately CUE uses this port for authenticating the voice mail service request and it only sends the message to port 80. On the client side there was no flexibility for moving this to other ports or making this dynamic.

Thanks

CallConnector Team

bpowers@tech-se... Wed, 10/06/2010 - 12:00

I have read all the documentation referenced and performed Google searches on the error.

I am attempting to install the SCCA client on a second engineer's pc and am getting the error "Can connect to the SIP service".

We are now preparing a new OS install in order to test the SCCA client there.

I am not hopeful.

On a not altogether unrelated note - I bought a Sonus system and was setting it up while trying to get my Cisco software to work. I launched the app on my iphone, help down two buttons on my Sonus (as instructed pictorially on the iPhone) and I was immediately configured and streaming music wirelessly. I never even cracked the user manual. Cisco could learn a lesson in that.

bpowers@tech-se... Wed, 10/06/2010 - 13:04

On a pc used regularly the install did not prompt for server ip, local ip company, user, support email, etc.

Then errored out with "The username or password you entered is incorrect or the server is down".

On a fresh install we were prompted for the above information, then rebooted and received the same error, "The username or password you entered is incorrect or the server is down".

Other network PC's connect without a problem, using the same credentials.

shtalukd Wed, 10/06/2010 - 13:40

Hi Brook:

A new install presents the dialogs to collect the information on Server IP, Loca IP etc. If the install program is run where the appliction is already installed, then it will go to the update mode -- and not require that information.

It looks like the user account information entered is not matching the information on the SCC Server or it is unable to locate the server. We are connecting with you to look into this.

Thanks

CallConnector Team

bpowers@tech-se... Wed, 10/06/2010 - 14:23

Resolved issue on PC#1 by uninstalling Skype. Apparently skype uses port 80.

I bet there are a few business customers of Cisco who use skype. IMHO, requiring the client to run a webserver to communicate with another server is a dumb idea.

Also, had to alter the CME IP address. Why the Smart Call Connector Server couldn�t reed the CMS IP address and populate the field when it queried the router during setup is beyond me.

Finally, we had to check some MWI fields in the UCC-540 web config pages. My fault RTFM.

Now I am still trying to figure out why the VocieView tab field is blank grey on another client and it wont remember any VoiceView client preferences, no matter how many times we try to save them.

shtalukd Wed, 10/06/2010 - 15:15

Issue on Paul's laptop was caused by skinny.dll in system32 that was not removed after uninstall UCC 1.5 and that skinny.dll was too old that caused VoiveView app failed to load.Remove skinny.dll from system32 resovles the issue. In version 2.0 or later, all the files are moved to Common folder instead of system32.

Thanks,

CallConnector Team

Correct Answer
shtalukd Wed, 10/06/2010 - 15:20

Hi Brook,

Skype has an option for not using port 80 for incoming connections. You need to uncheck under Options->Advanced->Connections the following " Use port 80 and 443 as alternatives for incoming connections"

With respect to the grey VoiceView field -- some files appear to be left in Windows System32 after the uninstallation of the previous versions of CallConnectors  including the ccTrog.dll and ccSkinny.dll. These files have caaused issues with the Advanced Client operation as the newer versions in the Common Files folder were not being accessed.

Thanks

CallConnector Team

Actions

Login or Register to take actions

This Discussion

Posted October 5, 2010 at 8:22 PM
Stats:
Replies:9 Avg. Rating:4.5
Views:1571 Votes:0
Shares:0

Related Content

Discussions Leaderboard