×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

can't connect to pix 506e outside of LAN

Unanswered Question
Oct 6th, 2010
User Badges:

I have a PIX 506e which I wish to use to access our LAN by VPN. I can  make a VPN connection from inside the LAN but I can't from home (eg  outside of our office network). I guess it may be some simple setting I  have over looked to enable WAN VPN access.


I can't even ping the box from home as can be seen below:
megs:~ meghan$ ping pix506e.xyz.co.uk
PING pix506e.xyz.co.uk (83.xyz.abc.14): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
^C
--- pix506e.xyz.co.uk ping statistics ---
6 packets transmitted, 0 packets received, 100.0% packet loss


Any help would be appreciated to solving this small issue.

Cheers, Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 10/06/2010 - 07:49
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Paul


Are you VPNing to the pix 506 from outside or through it ? If through it what VPN type are using eg. IPSEC/PPTP etc.


Jon

dbairdpub Wed, 10/06/2010 - 08:01
User Badges:

Thanks for the response Jon.


VPN'ing from outside to gain access to the LAN, PPTP prootocol. It just seems strange I can't ping it from outside which makes me suspect it is a config issue such as it been in stealth mode.


Cheers, Paul

Jon Marshall Wed, 10/06/2010 - 08:07
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Paul


If you are using PPTP on this pix you will need to allow -


1) TCP port 1723 (PPTP) through from the outside to the inside


2) GRE (note not TCP or UDP). GRE is protocol 47.  You will need to allow this from the outside to the inside as well. You will also need to allow it back from the inside to the outside but unless you have an access-list applied to the inside interface you won't need to do anything for inside -> outside communication.


Jon

dbairdpub Wed, 10/06/2010 - 08:36
User Badges:

I am a bit of the newbie to the pix box. What is the easiest way to set this up? I assume through the command line interface. What commands do I send?


Thanks very much for your help on this.


Cheers, Paul

Jon Marshall Wed, 10/06/2010 - 09:48
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Paul


Can you post your pix config removing any public IP addresses from it.


Jon

dbairdpub Thu, 10/07/2010 - 01:25
User Badges:

Hi Jon


I trust this is it...


Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 3JYr.QRWa1/ICK1s encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix506e
domain-name xyx.co.uk
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 192.168.1.128 255.255.255.128
access-list inside_outbound_nat0_acl permit ip any 10.12.15.128 255.255.255.128
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.128 255.255.255.128
access-list outside_cryptomap_dyn_40 permit ip any 10.12.15.128 255.255.255.128
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 83.abc.def.14 255.255.255.248
ip address inside 10.12.15.5 255.0.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool 10.12.15.x 10.12.15.155-10.12.15.254
pdm location 10.0.0.0 255.0.0.0 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.1.128 255.255.255.128 outside
pdm location 10.12.15.128 255.255.255.128 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.12.15.3 pixbackup
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 10.12.15.3 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local 10.12.15.x
vpdn group PPTP-VPDN-GROUP client configuration dns 10.12.15.1
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username vpnconnect password *********
vpdn enable outside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:11432a2767afe7a88cd56da0be2b53cc
: end
[OK]


Cheers, Paul

mmandeka Wed, 10/06/2010 - 08:04
User Badges:
  • Cisco Employee,

Hi Paul,


It could be possible that pings to the public ip is being blocked.


To verify if packets are hitting your firewall when you access it from outside, here are a few things you can try:


1. Enable SSH  / HTTP access to the outside interface of the pix. Try and SSH / HTTP to the box from home and see if it works. If it does, it means that pings are simply blocked and otherwise communication to the device is working fine.

2. Else, you could apply bi-directional captures on the outside interface of the pix to capture UDP port 500 / 4500 packets. Initiate a tunnel. Check the captures to see if packets reach the firewall and if the firewall responds to the packets.


Also, provide more details on what kind of VPN is being used. Also, it would be helpful if you can put up the VPN config.


Regards,


Manisha Mandekar

dbairdpub Tue, 10/12/2010 - 14:11
User Badges:

Hi Manisha


The following is the config:


Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 3JYr.QRWa1/ICK1s encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix506e
domain-name xyx.co.uk
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 192.168.1.128 255.255.255.128
access-list inside_outbound_nat0_acl permit ip any 10.12.15.128 255.255.255.128
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.128 255.255.255.128
access-list outside_cryptomap_dyn_40 permit ip any 10.12.15.128 255.255.255.128
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 83.abc.def.14 255.255.255.248
ip address inside 10.12.15.5 255.0.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool 10.12.15.x 10.12.15.155-10.12.15.254
pdm location 10.0.0.0 255.0.0.0 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.1.128 255.255.255.128 outside
pdm location 10.12.15.128 255.255.255.128 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.12.15.3 pixbackup
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 10.12.15.3 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local 10.12.15.x
vpdn group PPTP-VPDN-GROUP client configuration dns 10.12.15.1
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username vpnconnect password *********
vpdn enable outside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:11432a2767afe7a88cd56da0be2b53cc
: end
[OK]


Any pointers on how to solve the problem would be very gratly appriciated.


Cheers, Paul

Actions

This Discussion