Why QoS tail drops if CIR is not exceeded?

Answered Question
Oct 7th, 2010

I need your help to know why in this tail I see drops when only I have 163kbps from 512kbps available

RR01TMC#sh policy-map inter Multilink1

Multilink1

  Service-policy output: WAN

    Class-map: Precedencia3 (match-any)

      3893661 packets, 868957186 bytes

      30 second offered rate 163000 bps, drop rate 5000 bps<<<<<<<<<

      Match: ip precedence 3

        3893661 packets, 868957186 bytes

        30 second rate 163000 bps

      police:

          cir 512000 bps, bc 16000 bytes

        conformed 3280533 packets, 783170180 bytes; actions:

          transmit

        exceeded 3338 packets, 4207244 bytes; actions:

          drop

        conformed 163000 bps, exceed 5000 bps<<<<<<<<<

      Queueing

        Strict Priority

        Output Queue: Conversation 264

        Bandwidth 25 (%)

        Bandwidth 992 (kbps) Burst 24800 (Bytes)

        (pkts matched/bytes matched) 315589/74044438

        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)

      8806416 packets, 2809621499 bytes

      30 second offered rate 825000 bps, drop rate 0 bps

      Match: any

      Queueing

        Flow Based Fair Queueing

        Maximum Number of Hashed Queues 256

        (total queued/total drops/no-buffer drops) 10/219/0

RR01TMC#

policy-map WAN

class Precedencia3

   priority percent 25 

   police cir 512000 bc 16000 be 16000

  class class-default

  fair-queue

  queue-limit 96

!

Thanks,

I have this problem too.
0 votes
Correct Answer by Tharak Abraham about 3 years 6 months ago

As per your post,

The policy map LAN is given as input to the interface connecting the local lan.

But if we notice closely your access list CLASE3 contains a lot of lists which i feel is other than VoIP

for eg:

permit ip 172.24.65.0 0.0.0.255 any  <<<<<<<<<< ??

permit ip host 172.30.7.1 host 172.24.80.1

permit ip 172.27.164.0 0.0.0.255 any <<<<<<<< ??

what are these ?

You are marking all the traffic in the CLASE3 access-list with an ip prec of 3 and strictly prioritizing them across the WAN.

I think this is the reason for drops.

To avoid drops you need to tweak or rewrite the class/policy maps again.

I would have added more classes based on the applications.

You need to know what all applications exists and how many VoIP users are there etc.

Would recommend you to give VoIP critical treatment (prec 5) and signalling, prec 3.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
gatlin007 Thu, 10/07/2010 - 17:32

These stats are based on a 30 second average.  30 seconds is a long time.  At some point during a 30 second interval the rate for this particular class exceeded 512K and was dropped.  Over the entire 30 second interval the *average* was 163K.  During the 30 second interval it exceeded 512K.


The priority queue was designed for VoIP.  Are there other traffic types in this queue?  If so, I suggest moving it to another queue as the priority queue was never meant to deal with the burstiness of typical data traffic.


Chris

Tharak Abraham Fri, 10/08/2010 - 00:26

Why do you do a priority percent and police together ?

Priority percent or LLQ would have an inbuilt policer and it looks like your police cir is lower than the 25% of the MLPPP bandwidth.

Would recommend to implement strict priority for the RTP and proper shape average for the other classes.

Try to exclude policing towards the WAN.

Hope to help,

jprodrig01 Fri, 10/08/2010 - 09:19

without police also I have drops

RR01TMC-70008313#sh policy-map inter mul 1
Multilink1

  Service-policy output: WAN

    Class-map: Precedencia3 (match-any)
      3699456 packets, 480498613 bytes
      30 second offered rate 259000 bps, drop rate 8000 bps
      Match: ip precedence 3
        3699456 packets, 480498613 bytes
        30 second rate 259000 bps
      Queueing
        Strict Priority
        Output Queue: Conversation 264
        Bandwidth 25 (%)
        Bandwidth 992 (kbps) Burst 24800 (Bytes)
        (pkts matched/bytes matched) 576176/108489549
        (total drops/bytes drops) 314/448084

    Class-map: class-default (match-any)
      10599189 packets, 3537023189 bytes
      30 second offered rate 1354000 bps, drop rate 0 bps
      Match: any
      Queueing
        Flow Based Fair Queueing
        Maximum Number of Hashed Queues 256
        (total queued/total drops/no-buffer drops) 0/145/0
RR01TMC-70008313#

In this queue only I have VOIP traffic

class-map match-any DATOS-P3
match access-group name CLASE3
class-map match-any Precedencia3
match ip precedence 3
!
!
policy-map LAN
class DATOS-P3
  set ip precedence 3
class class-default
  set ip precedence 1
policy-map WAN
class Precedencia3
  priority percent 25
   police cir 512000 bc 16000 be 16000
     conform-action transmit
     exceed-action drop
class class-default
  fair-queue
  queue-limit 96

ip access-list extended CLASE3
permit ip any any precedence flash
permit tcp any any eq 2000
permit udp any any range 16384 32767
permit tcp any any eq 1720
permit tcp any eq 1720 any
permit tcp any any range 3230 3237
permit udp any any range 3230 3237
permit tcp any range 3230 3237 any
permit udp any range 3230 3237 any
permit udp any range 16384 32767 any
permit tcp any any eq 1719
permit udp any any eq 1719
permit tcp any eq 1719 any
permit udp any eq 1719 any
permit ip 172.24.65.0 0.0.0.255 any
permit ip host 172.30.7.1 host 172.24.80.1
permit ip 172.27.164.0 0.0.0.255 any

THANKS

Correct Answer
Tharak Abraham Fri, 10/08/2010 - 10:34

As per your post,

The policy map LAN is given as input to the interface connecting the local lan.

But if we notice closely your access list CLASE3 contains a lot of lists which i feel is other than VoIP

for eg:

permit ip 172.24.65.0 0.0.0.255 any  <<<<<<<<<< ??

permit ip host 172.30.7.1 host 172.24.80.1

permit ip 172.27.164.0 0.0.0.255 any <<<<<<<< ??

what are these ?

You are marking all the traffic in the CLASE3 access-list with an ip prec of 3 and strictly prioritizing them across the WAN.

I think this is the reason for drops.

To avoid drops you need to tweak or rewrite the class/policy maps again.

I would have added more classes based on the applications.

You need to know what all applications exists and how many VoIP users are there etc.

Would recommend you to give VoIP critical treatment (prec 5) and signalling, prec 3.

jprodrig01 Wed, 10/13/2010 - 08:30

I Changed the Acl CLASE3 and with this I don´t see drops, I had bursty traffic , thanks to all for your help

Mahesh Gohil Sat, 10/09/2010 - 09:50

Hi jprodrig01 ,

It seems your traffic is bursty type and it is not able to take advantage of setting of Cir, bc and be you set.

Think it like you have to chase 50km distance in one hour. If this is your target then it is not necessary that in first 15 mintutes with what speel you will run.

So if you run at speed of 5km in first 15 minutes then I can say your average speed in 5km/hour. Qos is logic is quite similar. if you want more flexibily in terms of variation then you need to expand time frame (like one hour instead of 15 minutes )

I suggest you to change Bc and Be value (like police 512000 64000 64000) and also remove priority percent 25 just to verify the drop rate.

Qos is kind of thing where you need to tune different parameter to meet your requirement.

hope this helps

Regards

Mahesh

jprodrig01 Wed, 10/13/2010 - 08:38

I Changed the Acl CLASE3 and with this I don´t see drops, I had bursty traffic , thanks to all for your help

Actions

Login or Register to take actions

This Discussion

Posted October 7, 2010 at 5:18 PM
Stats:
Replies:7 Avg. Rating:5
Views:1703 Votes:0
Shares:0

Related Content

Discussions Leaderboard