×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

BPDU Issue on 3750 This is not a Question but an Issue I have Run into

Unanswered Question
Oct 10th, 2010
User Badges:

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Hi I thought I share an issue I run into recently.

I upgraded a 3750 switch stack to 12.2.55. Once I had upgraded all the switches I had an issue with Spanning Tree on the voice VLAN; the root bridge was blocking that vlan on the trunk ports

The errors I was seeing was

%SPANTREE-2-BLOCK_PVID_PEER: Blocking GigabitEthernet2/0/26 on VLAN0172. Inconsistent peer vlan

BST: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet2/0/26 on VLAN0182. Inconsistent local vlan

VLAN 172 was the Voice VLAN

VLAN 182 was the RSPAN VLAN


The customer was arunning a RSPAN session to record the voice, I logged this with TAC and we found that when we removed the Monitor session, the spanning tree issue was restored.

TAC stated that the Monitor session was also forwarding the BPDUs into the RSPAN VLAN.

I installed a slightly earlier IOS and the issue was resolved.

As this took around 15 hours of my time on a Saturday, I thought I would share this issue with the support community in case anyone else ran into the same problem.


Regards


Richard

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
blakeaa827 Sat, 11/20/2010 - 13:40
User Badges:

Thanks for the heads up.  I ran into this issue working in the lab and came to the same conclusion.  Nice to know I'm not crazy.

andtoth Sat, 11/20/2010 - 16:40
User Badges:
  • Silver, 250 points or more

Hi Richard,


I did some research and I think you were hitting the following software defect: CSCtj76880

RSPAN causes port to go into BKN state due to PVID inconsistency


Please refer to the Bug Toolkit Page on the following link for more information:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtj76880


Will be fixed in 12.2(58)SE .


Andras

Actions

This Discussion