×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

C2960S Lanbase Routing Crashes

Answered Question
Oct 10th, 2010
User Badges:

Hi,


I have 3 c2960s stack with sdm lanbase routing enabled. I was trying to move routing from a router to this switch stack. I have configured a couple of SVI and 5 static routers, which I believe is far below the docmented limit. It had been working fine for one week before I started to use it as a router.

The switch crashed when traffic was directed to it, ie. when it started routing traffic. In 2 hours time, it had 5 crashes. The error mesage says something about  "address error".

When I stopped using it as a router, it is working fine.


As these switches do not have SMARTNET services, I cannot get support from TAC. I hope someone here can give me some help.


2 crashinfo files are attached for your reference.


IOS version: c2960s-universalk9-mz.122-55.SE


Thanks in advance.

Correct Answer by jonesandrew about 6 years 10 months ago

They have raised a bug (CSCtj37604) and its with the development team to fix.


Will probably have to wait for a new software release.


Cheers,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
andtoth Mon, 10/11/2010 - 06:26
User Badges:
  • Silver, 250 points or more

Hi,

I did some research and it looks like you are not the only one with this issue. I will give you more details later when I have more information.

Andras

Chuan Liu Mon, 02/21/2011 - 15:47
User Badges:

Hi,


Does the release 122-55.SE2 resolve the issue?


Thanks.

andtoth Tue, 02/22/2011 - 02:11
User Badges:
  • Silver, 250 points or more

Unfortunately not. However, will be fixed in 12.2(58)SE which is expected to be available around mid-March.


Andras

Michael Gioia Wed, 03/30/2011 - 07:11
User Badges:

Andras,


I don't think Cisco dev is on track for this release.  It's now the end of March, and the latest is still 12.2(55)SE2 on CCO.

I have a customer affected by this, so need some insight ASAP on how Cisco are tracking with this fix.


Standing by eagerly......

Leo Laohoo Wed, 03/30/2011 - 19:57
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

There's a bunch of new firmwares/IOS scheduled for release before the end of April 2011.  I don't know if 58 is one of them.

jonesandrew Wed, 10/13/2010 - 17:07
User Badges:

I also have a similar issue with 4 x 2960-S in a stack configuration.



it was working fine for a few days in the lab, then started to crash when it was deployed and actually routing some traffic.


i have raised a TAC case for it and they have raised a bug for it.


i will provide more information once its available.


Thanks,

Andrew

Chuan Liu Fri, 10/15/2010 - 18:52
User Badges:

Hi Andrew,


Have you got any response from TAC? I am looking forward to sharing your solution.


Thanks.


Larry

Correct Answer
jonesandrew Fri, 10/15/2010 - 20:55
User Badges:

They have raised a bug (CSCtj37604) and its with the development team to fix.


Will probably have to wait for a new software release.


Cheers,

apexiomsp Fri, 10/29/2010 - 16:23
User Badges:

Hi There

I've just installed a Stack with four 2960S switches which we setup 3 vlans, once the routing mode was turned on we had a crash every 5 to 10 mins.

Turning off routing stopped the crashes. Our solution was sold to the customer on the fact that we would be taking some of his network traffic away from his existing router. Has anyone found a solution yet ? I will be contacting TAC after the weekend


Regards

Richard H

jonesandrew Fri, 10/29/2010 - 16:39
User Badges:

i have been told by our partner SE that we wont get a fix untl feb / march 2011.


personally i think thats unacceptable for such a critical issue.

glen.grant Sat, 10/30/2010 - 05:39
User Badges:
  • Purple, 4500 points or more

Wow thats a major bug!!   How does something like that get thru quality control?

Leo Laohoo Sun, 10/31/2010 - 14:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless


i have been told by our partner SE that we wont get a fix untl feb / march 2011.

Yup.  February is normally the start of IOS releases.

Yeah, that's the curse of low end switches. If something is cheap then you have to live with all these kind of issues. Not like higher end products wouldn't have nice bugs.

I'm hesitating to offer this model for our client, but if it is not resolved asap I need to find another product/vendor.

Actually it is a shame how a software release can be released with such a major bug.

Leo Laohoo Wed, 03/30/2011 - 21:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

There's a new lot of IOS/Firmware releases tentatively scheduled for end of April 2011.  I am suspecting the 12.2(58) is one of them.

andtoth Thu, 03/31/2011 - 01:16
User Badges:
  • Silver, 250 points or more

Hi,


The defect CSCtj37604 is already fixed in 12.2(58)SE which is expected to be released at the beginning of April. Please note that the release dates are just estimated and not guaranteed because it depends on several things.


Best regards,

Andras

jonesandrew Sun, 05/15/2011 - 21:30
User Badges:

Hi All,


The new software has been released, has anyone delpoyed it yet?


Thanks,

Andrew

Leo Laohoo Sun, 05/15/2011 - 21:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I've been using this since Wednesday last week.  But as to whether I'm using the routing feature, I am not.

diogogoncalves Fri, 06/17/2011 - 12:03
User Badges:

Does anyone have any more information about this bug?


I'll get two 2960s and needed simple routing.

I saw the release of IOS 12.2 (58) SE1 but only says this:


CSCtj37604 (Catalyst 2960-S switch)

The switch stack reloads When you enter the ip routing global configuration command.

The workaround is to use the no ip routing global configuration command to disable IP routing.


This is not a solution!

andtoth Fri, 06/17/2011 - 14:35
User Badges:
  • Silver, 250 points or more

Hi Diogo,


CSCtj37604 is fixed in 12.2(58)SE1 and 12.2(55)SE3.


Best regards,

Andras

paolo bevilacqua Sat, 06/18/2011 - 04:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Agree it's not a workaround, on the other hand these are really designed as layer 2 switches, why not keeping routing on a device that is designed for that and known to do it well.

diogogoncalves Sun, 06/19/2011 - 11:06
User Badges:

I know that they are primarily layer 2 switches, but I need simple routing, and the difference to a layer 3 is great.


Andras Toth have you already tested this feature with the new versions of IOS?


Thanks for the reply

andtoth Sun, 06/19/2011 - 13:49
User Badges:
  • Silver, 250 points or more

Hi Diogo,


Yes, I have tested it myself to make sure and I can confirm that in 12.2(58)SE1 and 12.2(55)SE3 it has been fixed and no crashing is observed when enabling ip routing. Also, the bug has been fixed and the developers have tested the fix before the new image has been released.


Best regards,

Andras

diogogoncalves Sun, 06/19/2011 - 14:55
User Badges:

Good news my friend


thanks one more time for your reply


best regards

andtoth Mon, 06/20/2011 - 00:03
User Badges:
  • Silver, 250 points or more

Hi Diogo,


Thanks for your feedback, I hope everything will work fine with your switches.


Please rate the posts which you have found helpful.


Best regards,

Andras

diogogoncalves Mon, 07/11/2011 - 08:36
User Badges:

Hi Andras Toth,


I have the 2960s, but despite my template is "lanbase-routing", I still have 0 routed interfaces, and therefore I can't do inter-vlan routing


best regards

andtoth Tue, 07/12/2011 - 04:02
User Badges:
  • Silver, 250 points or more

Hi Diogo,


Did you reload the switch after changing the SDM template?

When you say you can't do inter-vlan routing, what issues are you observing? Do you receive an error message when trying to convert a switchport to routed port?

Could you please share the output of sh version and sh sdm prefer from the switch?


Best regards,

Andras

diogogoncalves Fri, 01/06/2012 - 08:05
User Badges:

Hi,


Everything is ok with the C2960S, include the inter-vlan routing.


Zero crash’s  since august


Thanks


Paolo your solution is good, but this site is very very small.

Hi Andras,


I have ever met the same issue with Diogo which is:

Despite my template is "lanbase-routing", I still have 0 routed interfaces, and therefore I can't do inter-vlan routing.  So could you give me some suggest about which extra step I need do to see serveral routed interfaces are enabled but not "0".  I saw someone mentioned it will display " ...8 routed interfaces and 255 VLANs." (Reference Link: http://blog.alwaysthenetwork.com/tutorials/2960s-can-route/)


Attached my sh sdm prefer and sh version result as below for your reference:

~#show version


Cisco IOS Software, C2960S Software (C2960S-UNIVERSALK9-M), Version 12.2(55)SE3, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Thu 05-May-11 16:56 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x01B00000



ROM: Bootstrap program is Alpha board boot loader

BOOTLDR: C2960S Boot Loader (C2960S-HBOOT-M) Version 12.2(53r)SE, RELEASE SOFTWARE (fc3)


blr-inips-c2960-1 uptime is 31 minutes

System returned to ROM by power-on

System image file is "flash:/c2960s-universalk9-mz.122-55.SE3/c2960s-universalk9-mz.122-55.SE3.bin"

...

cisco WS-C2960S-48TD-L (PowerPC) processor (revision D0) with 131072K bytes of memory.

Processor board ID FOC1528Y3K2

Last reset from power-on

6 Virtual Ethernet interfaces

1 FastEthernet interface

50 Gigabit Ethernet interfaces

2 Ten Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.



512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : 1C:AA:07:A6:AF:00

Motherboard assembly number     : 73-11905-08

Power supply part number        : 341-0327-03

Motherboard serial number       : FOC15271JPL

Power supply serial number      : DCA1524P2J7

Model revision number           : D0

Motherboard revision number     : A0

Model number                    : WS-C2960S-48TD-L

Daughterboard assembly number   : 73-11933-04

Daughterboard serial number     : FOC1527547P

System serial number            : FOC1528Y3K2

Top Assembly Part Number        : 800-30925-03

Top Assembly Revision Number    : A0

Version ID                      : V03

CLEI Code Number                : COMGD00ARC

Daughterboard revision number   : A0

Hardware Board Revision Number  : 0x01


Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

*    1 52    WS-C2960S-48TD-L   12.2(55)SE3           C2960S-UNIVERSALK9-M    


Configuration register is 0xF


~#sh sdm prefer

The current template is "lanbase-routing" template.

The selected template optimizes the resources in

the switch to support this level of features for

0 routed interfaces and 255 VLANs.     <-------------------"0 routed interfaces" displayed even now is lanbase-routing mode



  number of unicast mac addresses:                  4K

  number of IPv4 IGMP groups + multicast routes:    0.25K

  number of IPv4 unicast routes:                    4.875k

    number of directly-connected IPv4 hosts:        4K

    number of indirect IPv4 routes:                 0.875k

  number of IPv6 multicast groups:                  0.25K

  number of directly-connected IPv6 addresses:      0.25K

  number of indirect IPv6 unicast routes:           0

  number of IPv4 policy based routing aces:         0

  number of IPv4/MAC qos aces:                      0.375k

  number of IPv4/MAC security aces:                 0.375k

  number of IPv6 policy based routing aces:         0

  number of IPv6 qos aces:                          0

  number of IPv6 security aces:                     0.125k



Thanks,

Louisa

andtoth Tue, 05/29/2012 - 02:53
User Badges:
  • Silver, 250 points or more

Hi Louisa,


0 routed interface is normal. The 2960S can route for SVIs, but not for "no switchport" (routed) ports.

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_55_se/configuration/guide/swipstatrout.html


In the blog post you mention, the output is from a 2960 not from a 2960S, and the value of 8 is invalid in that case, caused by a cosmetic software defect.


Best regards,

Andras

Thanks for your reply and clarification.


Then I followed cisco guideline link which you attached to have a try on my 2960s switch, my purpose is wanting to 2 different subnets ip in 2 different vlans can communicate with each other.  What I did is:

======================

1. Enable sdm prefer lanbase-routeing as above mentioned.

2. Add different ip address in 2 different vlans, such as:

interface Vlan4054

ip address 172.20.79.1 255.255.255.0

!

interface Vlan4055

ip address 172.20.95.1 255.255.255.0

!

interface FastEthernet0

ip address 10.112.45.22 255.255.240.0         <---------- This is the management port of my switch

no ip route-cache

!

ip default-gateway 10.112.47.253

...

3. Try to add the "Static Unicast Routes" for above subnets via below way, but since met the invalid next hop error as below:

~(config)# ip route 172.20.95.0 255.255.255.0 172.20.95.1

%Invalid next hop address (it's this router)


4. So ignore the step#3 and directly verify the routing on my hosts which connect with 2960s by adding the corresponding subnet router.  But failed to ping each other with the same subnet ip between 2 hosts.

======================

Could you take a look and help point how can I perform the step#3 correctly and if other extra configurations still need in physical switch?


Thanks,

Louisa

andtoth Wed, 05/30/2012 - 00:48
User Badges:
  • Silver, 250 points or more

Hi Louisa,


There are 2 important things to be done:

- Make sure you reload the switch after changing the SDM template.

- Enable 'ip routing' in global config mode so routing can work.


There's no need to configure static routes on the switch, because it knows about both networks already as they're directly attached.


If this does not help, try pinging the switch int Vlan address (gateway IP) from the connected devices to see if they are reachable.


Best regards,

Andras

- Make sure you reload the switch after changing the SDM template.

Louisa: Yes, I have reloaded the switch.


- Enable 'ip routing' in global config mode so routing can work.

Louisa: Tired to run "ip routing" on switch, but found the switch ssh console disconnected and did not see any response of this command.  Then try to ping management ip, found it pingable, but failed ssh connect.  Do you have any idea about this kind of phenomenon?


BRs,

Louisa

andtoth Wed, 05/30/2012 - 01:48
User Badges:
  • Silver, 250 points or more

Hi Louisa,


Once you enable ip routing, the switch relies on the IP routing table (sh ip route) instead of the ip default-gateway command. This might break your management access if you're accessing the switch from another non directly connected network.


Make sure you configure a default route towards your gateway, which will most likely be the following command for you:

ip route 0.0.0.0 0.0.0.0 10.112.47.253


Best regards,

Andras

Thanks a lot Andras!


After adding the deafult route via "ip route 0.0.0.0 0.0.0.0 10.112.47.253", my external ssh management console can works well.  Then execute "ip routing" works fine also, w/o any ssh disconnection issue.  Tried validate from my hosts, now the different subnets ip in vlan4054&4055 can ping each other.  Many thanks here!


BRs,

Louisa

andtoth Wed, 05/30/2012 - 02:28
User Badges:
  • Silver, 250 points or more

No problem, glad it works now. Please rate helpful posts.


Best regards,

Andras

paolo bevilacqua Tue, 07/12/2011 - 08:18
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Diogo Goncalves wrote:


I know that they are primarily layer 2 switches, but I need simple routing, and the difference to a layer 3 is great.

I think you're taking the wrong path.


If you want to give realiable, strong solutions to your customer or your company, only use proven solutions intead of new stuff in the hope of saving money. For example, you can use samll 8 port 3560 L3 switch for inter-vlan routing.


Otherwise you will be only looking for trouble, as your current situation demonstrates.

Actions

This Discussion

Related Content