Cisco SPA504G freeze

Unanswered Question
Oct 14th, 2010

We have 7 SPA504G phones recently deployed, connected to an ESW 520 24P PoE switch.

At very random times, a phone will "freeze" such that the screensaver is stuck and the time displayed on it stands still.  Pressing keys on the phone including menu button do not show any results on the screen of the phone.

Oddly, I was able to ping the phone when this happened and also load the web interface in my browser.  The web interface shows the current time on the phone being the same time that is "frozen" on the screensaver.

This doesn't seem to be related to a calling or QOS issue as my phone froze at 6:18am before anyone was in the office.

All phones are running the current latest firmware, 7.4.6

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.9 (7 ratings)
David Carr Fri, 10/15/2010 - 07:22

Try re-downloading the 7.4.6 firmware and reflash the firmware.  Give that a shot and if that don't work, give the SBSC a call at 866-606-1866 to get a troubleshooting ticket opened.

JeffBourgeois5333 Fri, 10/15/2010 - 12:41

I have experienced the exact same random lock-ups as described by Mark Price.

I am, and was,using firmware 7.4.6 when the lock-ups occurred.  Hardware version is 1.0.0(0001).

My SPA504G is behind a Linksys WRT54G.

I experienced 3 or 4 random lock-ups during early and mid September.

My last lock-up was on Sept. 19.  The only way to recover from lock-ups was to unplug power and re-connect power to SPA504G.  It has not recurred since Sept. 19th.  I can't recall, if at that time, I re-downloaded firmware version 7.4.6 or not.  But, it has not locked-up again since then for unknown reasons. (perhaps I did re-flash, but can't remember).

When the lock-ups did occur, LCD display showed the time of lock-up.  All LED's displayed normal and indicated all 4-lines were registered.  But, there was no dial-tone on any line, and pressing keys did nothing.  I too was able to connect to the web interface as usual.

I did a screen capture of the Info tab page for reference in case it happens again (before disconnecting and reconnecting power).

One point of interest is that the screen capture indicated that all lines were registered.... But,  "Next Registration In" value for all 4 lines was displaying "0" seconds.

It has been working fine for the past three weeks.  I just wanted to post this info to confirm similar problems submitted by Mark Price.

markprice9 Sun, 10/17/2010 - 13:01

Thanks for the replies.  I have 7 of these phones in our office, and it has happened on at least several of them.  I've opened a case #615746657, waiting to hear what they say.

marxom7713 Mon, 10/25/2010 - 07:57

Have you heard anything back on your case #?

This appears to affect more than just the 504G, we have 15 509G's and are experiencing

the same problem on a daily basis.

Has anyone tried downgrading to a previous version?

markprice9 Mon, 11/01/2010 - 11:40

I didn't hear anything specific back on the case, they just said I could call back in presumably to RMA.

I was troubleshooting NAT issues and had put the phones on the public Internet to bypass NAT.  Now that I've moved them back behind a NAT device, that seems to have cured the random freeze problem.  My guess is that the phones were getting malicious SIP scanning traffic.  When running a packet capture I noticed SIP packets coming in from some IP in China.

I also had a problem with the phones freezing when placing a call, it seems to be related to DNS responses not 100% sure if I've fixed it yet.

marxom7713 Tue, 11/02/2010 - 07:52

I locked down the firewall on our office VOIP vlan, and for the first time in a month I haven't seen the phones

freeze overnight. It's only been a day, but things are looking good.

Thank you for the suggestion.

JeffBourgeois5333 Mon, 11/01/2010 - 12:01

My SPA504G is behind two NATs.  The first NAT is the SPA2102, and the 2nd NAT is the WRT54G.

My SPA504G is behind the WRT54G, and does not seem to have any issues with connections.

I don't seem to have any issues related to NAT for any of my VoIP connections.

My SPA2102 is connected directly to my ISP Modem and never loses connections and never freezes.

Also behind my WRT54G is a PAP2T, two PC's, plus the SPA504G.  The PC's use the 3CXPhone softphones and they all work great.

In my previous post I noted that the SPA504G randomly locked-up too.

I note that when I turned-off its screen saver, I did not have a single lock-up for 3-weeks.

But, last week I turned the screen saver back on just to see if there were any issues with that... Sure enough, a day or two later the SPA504 locked up again.

So, I turned off Screen Saver again.  Now, it has not locked up since then...

So, I'm waiting to see if that is just coincidence, or a related cause...

JeffBourgeois5333 Mon, 11/08/2010 - 09:56

It is now about 2-weeks since I turned-off SPA504 Screen Saver feature.  And, I have not had a single phone lock-up during this time.

To me this is starting to look like a trend:  Screen Saver On.... lock-ups, Screen Saver OFF.... no lock-ups.

Has anyone else made this observation?

l.dickerson Tue, 11/09/2010 - 06:15

I find my SPA504G freezes every few hours for no reason. If I am using the phone to make calls, it usually freezes within 1 minute.

Quite frankly, it's the worst SIP device I have ever used. It came with firmware 7.4.3a, so I upgraded it to 7.4.6 - made absolutely no difference. I've factory reset the thing more times than I've had hot dinners. The only saving grace of this phone is it doesn't drop calls when it freezes - everything continues to work except for the the keys on the phone itself, so once your call is done, powercycle it again.

Tried disabling screen savers, specifying particular codecs (and restricting it to them), tried different SIP providers, separating onto different vlans, I've tried everything - nothing fixes this phone.

Pretty sure I'm just going to pack the thing back up and hock it on E-Bay. Cisco just seem to put their fingers in their ears and go, "la la la! Not happening!". Worst investment ever.

[EDIT]

Downgrading to firmware 7.3.7 has corrected the problem for me, though it still occasionally likes to reboot for no reason. It doesn't freeze anymore, hooray!

samuande Wed, 11/10/2010 - 12:28

Lloyd,

Sorry to hear of the problems you are experiencing with this freezing/reboot issue.  We are aware of certain issues that might be causing this behavior and are working on a fix.

We certainly recognize the investment that you make with Cisco gear and, as always, hope to live up to the exacting standards of all our customers.

Sam

crimsonict Thu, 11/18/2010 - 05:27

i'd also like to know wenn the fix will be avaible.
We have also 7 phones that randomly freeze. We like to enroll them but its not possible with this major problem.

Another question:
Are there good replacement phones that don't have this problem like a 508G or lower then the 504G?

Thanks

JeffBourgeois5333 Wed, 11/10/2010 - 15:54

Well,  I spoke to soon in my last post.  I last said it hadn't locked-up for 2 weeks since In disabled screen saver.

Now, this morning I see that the SPA504 had locked-up once again at approximately 5 AM. 

The phone hadn't made any calls since yesterday.  My lockups don't seem to have anything to do with making or receiving calls.

So, now I guess the screen saver correlation was just coincidence, unless there are multiple causes of lockups...

One consistent observation is that while the phone is locked-up, I can always access the phone via web browser while locked-up.

And, quite curiously, I note that ALL four of my registered lines (with 4 different voip services) still show as registered.

And, I also note that ALL four lines indicate "Next Registration In:   0 s", each.  I expect this is a good clue about.... something; ... what, I'm not sure.

I attached another screen capture of the locked-up state as seen on the Info page.

kustergustavo Thu, 11/11/2010 - 09:07

Same issue here, we have more than 90 SPA 504G on diferent locations, all of them on 7.4.6 many users are reporting lock-up.

They need to power cycle device to get it to work.

kustergustavo Mon, 01/03/2011 - 07:56

I'm happy to report that all the SPA504G that were having lockup's are no longer having this issue after we upgrade firmware to the last vercion available.

Has been 3 weeks now.

stefano.losi@pa... Tue, 11/16/2010 - 00:02

I have the same problem.

Bought 4 SPA504G.

Upgraded to the latest firmware version 7.4.6

2 of these phones freeze in average once a day. The other 2 phones never had this behaviour, although I think to have configured all 4 the same. But I'll give a deeper check on it, of course.

The behaviour is exactly the same as told by previous posts. Ping and Web interface ok, no key press, no line to PBX. Only way to unlock, unplug the POE cable and re-plug it.

In my case, all 4 phones have 2 attendant consoles connected.

With these phones I experience a very long "Verifying DNS" phase at boot (maybe 30 seconds).

I have also many SPA922 and these boot in few seconds.

stefano.losi@pa... Wed, 11/17/2010 - 08:47

If someone solves this issues, plz contact me on skype. My skype id is isolk5

We have 100 phones in production with asterisk in our company.

So we could exchange ideas

Steven DiStefano Thu, 11/18/2010 - 11:09

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

I did some investigation with the Engineering team.

The comments made by Mark Price regarding random freeze due to a hacker sending SIP traffic and phone freezing due to DNS are the ones that we are familiar with and fixing in the 7.4.7 release (the hacker issue and it will also abide by the TTL for DNS issue). 

Right now the TTL is ignored by the 50x, so the 50x constantly hammers away doing DNS resolution seems to be the cause.  This is in test now.  I dont have an ETA and cant commit a date, but I would guess December timeframe.

Thanks for reporting this and sorry for the issue.

Steve

markprice9 Thu, 11/18/2010 - 12:22

Hi Steven,  thanks for the insight.

Do you have any more info on the known problems with regards to DNS?  Even with the phone not honoring TTL and not doing local DNS caching, that shouldn't cause a problem unless DNS lookups aren't 100% reliable from the phone.

JeffBourgeois5333 Thu, 11/18/2010 - 13:54

Perhaps there is something to the DNS suggestion.

About 1 week ago, following my last lock-up, I decided to reconfigure my home network on which the SPA504 operates.  Previously, the SPA504 was behind two NAT's.  First NAT was SPA2102 directly output to 2nd NAT, which was WRT54G.  The SPA504 was connected to WRT54G.

Around the time of last lock-up, I was experiencing unusual significant ping jitter and latencies.  My VoIP connections were becoming choppy and degraded.  So, I decided to try splitting up my network and segregating my SPA2102 and SPA504 from my PC's and WRT54G.

I reconfigured as follows:

Connected EZX55W 5-port switch direct to LAN side of ISP cable modem.

Connected SPA2102 to port-1 of switch, and connected WRT54G to port-2 on switch.

Connected SPA504 to SPA2102 LAN port.

Connected PC's to LAN side of WRT-54G.

So now, SPA504 is only behind one NAT, instead of two.

No devices connected to SPA504 Ethernet port, except for administration, temporarily.

Now, for the past week (with new network configuration), I have not had any lock-ups on SPA504.

The jitter and high latency issues are gone.  Call quality seems better.

Once again, I will have to wait more time to see if improved performance (and no lock-ups) is coincidence, or not.

I'm just wondering if fact that SPA504 was initially behind two NAT's vs one had any relevance to lock-up issues (DNS conflicts between NAT-routers?)....

It'll be interesting to see what Engineering team concludes...

l.dickerson Fri, 12/03/2010 - 10:37

I have now corrected this issue. There were two things that were preventing the SPA504G from behaving itself.

Firstly, I changed :

Resync Random Delay : 2

Resync Error Retry Delay : 0

Resync Periodic : 0

Forced Resync Delay : 0

This improved the performance of the phone immensely, but it would still reboot occasionally. (The freezing however, stopped completely)

The second problem appears to have been a desktop gigabit switch. Removing the switch from the network also corrected an issue we were having with the Cisco VPN Client. It was an unmanaged D-Link DGS-1008D. Funnily enough, it appears the switch only causes problems for the SPA-504G and the Cisco VPN Client - every other application and service worked just fine through it.

Either way, the phone has now been behaving without reboot or freeze for three weeks. We're having some niggling problems with our registration to sip2sip.info, however it looks like that problem has been solved by increasing the subscription expiration to 4800 and the register expiry to 3600.

I hope that helps someone out there, somehow.

Steven DiStefano Fri, 12/03/2010 - 18:03

Darn shame the title of your postings in this thread could not say ' D-LINK switch causing SPA504 Freeze' ???

Now thats funny.

JeffBourgeois5333 Fri, 12/03/2010 - 20:10

As you can see from my multiple previous postings on this issue, I do not use any D-Link switches in my network.... they are all Linksys and Cisco.  I had multiple lock-ups... none due to D-Link here...

l.dickerson Fri, 12/03/2010 - 20:20

That's fine, the D-Link was causing the phone to reboot, not to freeze.

The freezing was corrected by setting resync to 0 in provisioning. Give that a try.

JeffBourgeois5333 Fri, 12/03/2010 - 20:36

I haven't had a lock-up in two weeks, since I reconfigured my network as explained above on Nov. 18.  As well, my SPA504G is not enabled for remote provisioning, just manually provisioned by me.

(If I'm sounding blunt, that not my intention.  I'm just stating my situation in case Cisco support is paying attention to this thread.  It seems clear now that different people with different network configurations are having the same issue with lock-ups - but under different circumstances...) 

christian@ifon.co.uk Fri, 12/03/2010 - 23:01

This is a problem that has been driving me mad, I thought it was just me.

Problem showing on SPA508g and 502g, Random phones on random networks.

I would like to try the 'Rsync' fix, however search as I may, I cant find any reference to these in the web interface, am I missing something? 

JeffInAlberta Wed, 02/08/2012 - 21:35

I upgraded to firmware 7.4.9c a few months ago and have not had any lockups since.

stefano.losi@pa... Sat, 12/11/2010 - 16:17

CISCO technicians sent me a beta version of next firmware, and it seems that my SPA504G don't freeze anymore.

If you are interested in having this, please contact me: stefano dot losi at paolobeltramispa.it.

keith-perry Thu, 12/16/2010 - 08:04

We have over 40 SPA504Gs and they all freeze at the time the screen saver is scheduled to kick in (default is 300 seconds). Disabling the screen saver from the remote software platform stops the freezing. However they now freeze after 25 minutes (1500 seconds). The handset doesn't need to be idle for this to happen, i.e. if you are say scrolling through menu options or making a call it will still freeze. Has anybody else seen this issue? Looking at the other postings I can see that most other people are getting random freezes but our experience is not random.

JeffBourgeois5333 Thu, 12/16/2010 - 09:06

I initially thought my lock-ups were due to screen saver.  They were frequent, but in terms of days, not minutes.  When I turned off screen saver, I went as long as 3 weeks until my next lock-up.  When I turned it back on, lock-ups were with-in days again.  Screen saver, in my case, seemed to only be a contributing factor, but not the sole cause.

Since I reconfigured my network so that my SPA504G is behind SPA2102 NAT-Router ATA , I have not had any further lock-ups.  It has now been ~ 6 weeks since I reconfigured my network.  I even re-enabled screen saver with not problems now.

Previously, I had WRT54G connected to LAN side of SPA2102 and then SPA504G connected to WRT-54G.  For some reason SPA504 didn't like this configuration.

keith-perry Fri, 12/17/2010 - 02:23

The screen saver is definitely one cause of freezing. This can be proved repeatedly, with it switched on the handset will freeze at the time the screen saver is supposed to kick in. However they also freeze at random times. I reset three handsets yesterday at 16:25, one froze at 16:43, one froze at 06:06 today and one froze at 07:07 today. I don't think using SPA2102 devices is going to be practical for us as we have about 50 devices. Another post mentions a beta release of firmware from Cisco which I have now got so I might try that.

Patrick Born Fri, 12/17/2010 - 07:04

Hi Community,

This is not appropriate phone behavior and I will do everything I can to help each of you. I'm also alerting my colleagues to these reports.

Unfortunately I'm out of the office until early January, but in the interim here are some thoughts:

1. The new 7.4.7 firmware should be available on Cisco.com over the next few days
    Here's a link to where it will show up: http://www.cisco.com/cisco/software/navigator.html?mdfid=282733326&i=rm
    Please try it and verify that problem is resolved.

2. I need help replicating your problem. If I can replicate the issue, I will report a bug and get the issue resolved *fast*

    I'm running phones in my lab and am not experiencing the reported issue. Please email me, paborn but make sure that

    you put "Cisco SPA504G freeze" in the subject else I may not see your email. Provide if possible:

    a. Your phone's configuration. Here's what I need: https://supportforums.cisco.com/docs/DOC-9933

    b. Details on how I can replicate the problem. I need *exact* information please. Help me help you.

    c. If you can supply a WireShark trace of the network that would be extremely helpful. This would enable me to determine
        if the phone is doing something on the network.

    d. Turn on debugging, level 3 on the phone. Here's how: https://supportforums.cisco.com/docs/DOC-9934
        If you're running WireShark, there's no need to run the slogsrv.exe because WireShark will provide me the information I need.

    e. I need to know *every* change that you have made to the phone since it was factory reset. This will aide in figuring out the root cause.

3. Lastly, if this is urgent, PLEASE contact Cisco support:

    Here's how to locate support in your geography: http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

Thanks for your patience and continued support. I / we at Cisco will get you through this issue,

Regards,

Patrick

----------

You only need one reference document for all SPA phone firmware, information, and utilities.

keith-perry Fri, 12/17/2010 - 07:37

I have attached the configuration file.

The freezing I am experiencing is when the screen saver is scheduled to start. If the screen saver is disabled the freezing can happen at random intervals from a few minutes to several hours.

The freezing affects all buttons on the handset. If it freezes during a call the call stays active but obviously you can't end the call. You can also browse to the phone and ping it during its frozen state.

The firmware version I am using is 7.4.4. Another post here says that upgrading to a beta version of 7.4.6 cured the problem for him. I have the 7.4.6 beta but I haven't tried it yet and I think I will wait until 7.4.7 is released.

I am sure it is a configuration issue but that is all handled by our SIP provider.

nseto Fri, 12/17/2010 - 14:13

I see that 7.4.7 is posted at http://www.cisco.com/cisco/software/release.html?mdfid=282724650&flowid=5300&softwareid=282463651

I have a question, you mention screen saver but I don't see screen saver settings on the 50x, I only see it on the 525 in the user tab under screen at the bottom.  On the phone UI, under preferences, screen preferences on the 525 but no equivalent seen on the 50x.

keith-perry Fri, 12/17/2010 - 14:30

Thanks for that, it wasn't there six hours ago. I have just downloaded it and will try it next week.

Screen saver is under option 20 if I remember correctly, or use your browser and go to the phone tab.

nseto Fri, 12/17/2010 - 14:40

Thanks, I see the option now.  Can you send the pic that's being used for the screen saver?  My email address is nseto at cisco.com

keith-perry Fri, 12/17/2010 - 14:57

I am not using a pic for the screen saver. There are about four options for the screen saver such as date and time, .bmp, lock and something else (can't remember) but it doesn't matter which it is set to, the device will freeze if screen saver is enabled. As I said in a previous post I am sure it is a config issue because if I set the device to factory default and don't register it witrh our SIP provider it doesn't freeze. You can email me at kperry at tickets.com

keith-perry Mon, 12/20/2010 - 03:09

I have upgraded to 7.4.7 on one device but it is now unable to get an IP address. It is set to DHCP. If I change it to static IP there doesn't seem to be the ability to enter the IP address manually.

nseto Mon, 12/20/2010 - 09:10

Can you get a wireshark so that we can see why it's not getting ip address?  A capture showing the difference between 7.4.6 and 7.4.7 would be great.  Thanks.

keith-perry Tue, 12/21/2010 - 00:26

I will try and get a wireshark done today. For your information I upgraded from 7.4.4. to 7.4.7.

On the freezing issue I have some more information: I have put one of the devices onto an ADSL line and enabled the screen saver. not only did it not freeze when the screen saver kicked in but it hasn't frozen for over 12 hours now. They only appear to freeze when connected to our corporate network. This is via three Cisco 2960 POE switches. When I connect to the ADSL line I'm not using POE but a separate power supply.

nseto Tue, 12/21/2010 - 09:18

I see there are two different phones used for the dhcp testing.

One with mac 0002FDFFD4DA on the 7.4.7 which fails to do DHCP Request while the other unit is mac 0002FDFFC6D2 on the 7.4.4 which does the DHCP Request and receives the DHCP Ack.

Have you confirmed that using just one phone with the same mac works on 7.4.4 fails on 7.4.7?  If so, I'd like that trace so I can escalate to dev (showing them the same phone is acting differently) .  Thanks.

In regards to the lock when using POE, have you put a power supply on the phone that's using the POE switch to see if that stops the lock up?

keith-perry Wed, 12/22/2010 - 04:07

I am not happy about upgrading another device because if the same thing happens I will have two totally unusable devices.

I have tried using a power supply and disabling POE on the switch but the lock up still happens.

nseto Wed, 12/22/2010 - 09:09

It looks like you are still using 7.4.4.

For your phone, you are unable to get it to 7.4.7?

There are some fixes for lock on 7.4.7 for some cases of DNS resolution and bad sip messages.

It looks like you only had syslog server set up on the phone.

It would be good to set up the debug server as well, debug level to 3 and sip debug level to full (in the ext tab).

Also, need to see the unit's config, you can use your browser, login as admin/advanced and save the file as htm.

One more thing, on that phone, just wanted to confirm that when you move to a DSL line, that it's fine but behind the PoE switch, it locks randomly and if screen saver is used, will lock up every time screen saver gets invoked, right?

keith-perry Wed, 12/22/2010 - 13:02

I said in my previous post that I don't want to upgrade another device to 7.4.7 because if that is unable to obtain an IP address after the upgrade we will have two totally unusable units.

I can confirm that if any of the units are moved to a DSL line they work perfectly ok. If they are connected to a Catalyst 2960 POE switch they lock up exactly at the time that the screen saver is invoked and at random times if the screen saver is disabled.

It is unlikely now that we will continue with trying to get the new SIP platform up and running and will go to another SIP provider. If that is the case it is unlikely that we will be using the same devices. Our SIP provider has spent the last three months trying to get their platform working with little or no success, and with the locking up of the SPA504G units we are further away from getting a phone system than we were three months ago.

Thank you very much for your time and effort, but it is too late now.

Keith

lhill@calprores... Mon, 02/14/2011 - 12:00

Thanks for making the 7.4.7 software version available. I asked our VOIP provider to test it and provision our phones with it. The freeze problem has not happened at all since we upgraded. That was well over a week ago. I was having the freeze happen as much as twice a day prior to this version.

Thank you!!!!

Actions

Login or Register to take actions

This Discussion

Posted October 14, 2010 at 3:21 PM
Stats:
Replies:95 Avg. Rating:4.85714
Views:21367 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard