Failure login "IP Phone Agent" service

Unanswered Question
Oct 15th, 2010

Hi! I have an issue. When I try log in the IP Phone Agent service I get an error: "selected service IP Phone Agent isn't active. Select another service IP Phone Agent".

The service URL seems correct: http://ip_address_UCCX_server:6293/ipphone/jsp/sciphonexml/IPAgentInitial.jsp and the Cisco Browser and IP Phone Agent Service is started and has a status "IN_SERVICE".

What is the problem here?

We use UCCX Premium 7.0(1) and CUCM 7.1.5

Thanks in advance!

Ruslan

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
anubhati Fri, 10/15/2010 - 06:42

Hi

Go through the tech tip below and confirm the configuration. If every thing seems to be good then it might be a issue with the CTI manager service on CUCM and you will have to restart that service.

http://www.cisco.com/en/US/partner/products/sw/custcosw/ps1846/products_tech_note09186a008029e6d5.shtml

Following is the order  to follow to restart the CTI service

a) In CUCM cluster first stop CTI service on all subscribers

b) restart the service on publisher

c) Then start it on all subscribers.

After the CUCM CTI service is up on CUCM cluster  restart the IPPA service in UCCX

hope this helps

Anuj
KravetsRuslan Fri, 10/15/2010 - 08:12

I checked everything: service parameters, URL. And I restarted CTI manager service and IPPA service with the algorithm which You had described. I tried to create a new service with these settings but nothing helps. I have the same error. Any ideas else?

Thank You!

Ruslan

KravetsRuslan Sun, 10/17/2010 - 22:34

Yes, that is 7.0(1)SR05_Build504. We recently upgraded UCCX from the 7.0 version and I suspect that the problem occurred after that.

Ruslan

jecody Fri, 10/15/2010 - 13:40

Increase the timeout:

Please perform the following:

1.    Open Regedit on the UCCX server

2.    Navigate to the following string  HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc. \CRS \Properties\application.MIVR.properties

3.    Select “com.cisco.user.io.timeout”

4.    Right-click, choose Modify and then enter 30000.

5.    File, Exit and close Regedit.

Please also ensure that in AppAdmin, under System> Cisco Unified CM Configuration  that the CUCM primary IP is set as the first AXL Service provider. If it is not, you can modify the order, then Update that.

KravetsRuslan Sun, 10/17/2010 - 22:51

Thanks for reply! The value of "com.cisco.user.io.timeout" already is 30000. And CUCM primary IP has already set as the first AXL Service provider

Ruslan

klambrec Tue, 10/19/2010 - 12:10

I'm just going on my experience with IP Phone Agent on Enterprise Contact Centers, but I'm guessing it would work the same on UCCX. Basically IPPA is working in an Active-Standby architecture, so if you have a High Availablity node the service is currently Active on the Standby node.At least on Enterprise, it would give you that message when the other side is Active. The upgrade probably triggered it to fail-over.

Do you have a service configured on your phones pointing to the same URL on the 2nd node ? Give that a try.

To make it go back to your Primary node, you'll want to log on to the Standby node and restart the IP Phone Agent service or possibly the License and Resource Manager to have it fail-over back to the Primary (don't do it during business hours).

acperocho Thu, 10/21/2010 - 09:51

Is the IP Phone Agent now working in active-standby mode in UCCX 7? In lower version, you need to create 2 IP Phone Agent Service in the CallManager, one pointing to the Primary and second to the Secondary. Then you need to add this in the device subscription.

KravetsRuslan Fri, 10/29/2010 - 04:52

Hi, there!

Yes, we use high-availability mode. I tried to change an address in the URL to the address of secondary node and also a tried to restart IPPA service in the both nodes but it didn't help. Then I restarted the secondary server and the service became up. It's strange because the address in the service URL is set to ip of primary server...

Thanks for Your replies!

sasith_90 Thu, 04/10/2014 - 01:45

Hi Ruslan

 

I got the same problem, issue is your pointed UCCX Server is not the master Server. As I know Cisco IP Phone Agent is not supporting automatic fail-over, so Agent need to manually point to Master UCCX server to gain this IP Phone service. I have done some workaround, I created two services pointing to both UCCX servers and Assigned both services with Agent Phone, so if the Agent getting this message, agent can select other service.

 

Regds

Sasith  

Actions

Login or Register to take actions

This Discussion

Posted October 15, 2010 at 4:16 AM
Stats:
Replies:11 Avg. Rating:5
Views:5112 Votes:1
Shares:0
Tags: No tags.

Discussions Leaderboard