uc-560 : Automatic CDR file on FTP

Unanswered Question
Oct 20th, 2010


I have a UC-560 and I want to send automaticaly the CDR for all outgoing call to the FTP server

I it possible to configure this feature on uc-560

If yes how can I configure it ?

sh version
Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 15.0(1)XA,
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Thu 22-Oct-09 06:29

ROM: System Bootstrap, Version 15.0(1r)XA, RELEASE SOFTWARE (fc1)

Please help

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nathan Compton Thu, 10/21/2010 - 05:21

In CCA you can go to the following menu to set this up:

Applications>General Settings>Call Accounting

In there you can setup Call Accounting to a FTP server.


Adam Compton

nicanor00 Mon, 10/25/2010 - 10:27


I generated the file

However when we open it there are no column  headers, just numbers, etc..

How can I reorganise this file in other to analyse and understand it well ?

Is there any free tools to analyse and interprate this file ?

Please help

1232568764,7,0,1,"B151715E E72E11DD 800BB43C  428570BC","","","12:12:42.039 PST Wed Jan 21 2009","","12:12:44.659 PST  Wed Jan 21 2009","12:12:44.659 PST Wed Jan 21  2009","","","answer",0,"",0,0,0,0,"12223334444","12223334444","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","",0,"Tariff:Unknown","","0","","","","","","","","","","","","","0/1:2","","","","","","","","","","","","","","","","","","","","","","","RegularLine","","","","","","TWC","01/21/2009  12:12:42.043","12223334444","",0,7,B151715E E72E11DD 800BB43C  428570BC,7,"","","","","",""
1232568772,9,0,1,"B3B46786 E72E11DD 800FB43C  428570BC","","","12:12:50.953 PST Wed Jan 21 2009","","12:12:52.203 PST  Wed Jan 21 2009","12:12:52.203 PST Wed Jan 21  2009","","","originate",0,"",0,0,0,0,"201","201","812223334444","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","","",0,"Tariff:Unknown","","0","","","","","","","","","","","","","0/1:2","","","","","","","","","","","ton:0,npi:0,pi:0,si:0,#:201","","","","ton:0,npi:0,#:12223334444","ton:0,npi:0,pi:0,si:0,#:201","","","","812223334444","","","RegularLine","","","","","","TWC","01/21/2009  12:12:50.947","201","812223334444",0,9,B3B46786 E72E11DD 800FB43C  428570BC,9,"","","","","",""

Nathan Compton Mon, 10/25/2010 - 10:39

The format of a CDR file is .CSV, with is the data separated by commas.  .CSV files can be opened in Excel and it will be separated into columns.  There are CDR analysis programs out there, but as far as I know, you have to pay for all of those.  This link shows some third party software you can use.


You can also see calls in the CME GUI formatted a little better.


Adam Compton    

nicanor00 Thu, 10/28/2010 - 01:36


I aupgraded my IOS

boot system flash uc500-advipservicesk9-mz.150-1.XA3a

But the file is not send on the FTP server

  • the FTP it is not working, I am using Fizilla server on my computer (FTP server test

000554: Oct 27 14:39:35.307: %VOICE_FILE_ACCT-3-DUMPFAIL: Could not dump to remo

te file - open ftp://cisco:cisco@FTP://

16_39_34.663. Error=516(Unknown error 516)

  • The file are created and stored in the flash

How can the file can be copied automatically on the FTP server and deleted and not stored in the flash

Please help

Darren DeCroock Thu, 10/28/2010 - 14:19

I would check the settings in your running config.  Should contain the following:

gw-accouting file
primary ftp username cisco password cisco

maximum buffer-size 40
maximum cdrflush-timer 15

maximum retry-count 3
maximum fileclose-timer 60
cdr-format compact
acct-template callhistory-detail

Then test with the following command:

file-acct flush with-close

nicanor00 Wed, 11/03/2010 - 07:05


The problem is the same.

Cisco told me that the problem is the UC IOS version

I see some call history in the CME(see file attched)

Is it possible to configure this history in other to have more entry

For exemple

- only outgoing call (to the FXO)

- All call nol for one day

Nathan Compton Thu, 11/04/2010 - 09:43

The problem is probably with this command:

primary ftp username cisco password cisco

it is almost correct, but should be this:

primary ftp username cisco password cisco

I noticed in the debug output you posted that the file name starts with a period.  You have to have the "cdr" after the slash to make the file start with cdr instead of a period.  I had the exact same problem one time before.  Once the file started with cdr it started working.


Adam Compton

diego_ers Fri, 02/21/2014 - 15:06

Thanks Nathan...

I had that same issue and the /cdr did the trick!!

What should is do with the dump files on the flash: ?

Are they going to be deleted automatically?

Thanks for your help

Alexander Maroukian Sun, 02/23/2014 - 13:54

Hello Diego,

You may delete them or copy them if you need them.

They will not gonna be automatically deleted.



*Please rate helpful posts


This Discussion