×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DTMF configration on Cisco IP PH 7965

Unanswered Question
Oct 25th, 2010
User Badges:

DTMF is configured on my gateway router but still i can not call on Extension when i call to my vendor Land Line. How we can enable on

IP PH in Call Manager 7.X.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kusatija Mon, 10/25/2010 - 04:52
User Badges:
  • Silver, 250 points or more

Hello,


Do let us know the following:
exact call manager version.

is the issue only for 7965 phones?

is it an intermittent issue or reproducible?


whats the call flow, what is the gateway config from which the call is going out, is it MGCP/h323/SIP?


If MGCP post the running config, as well as screen shot of the gateway config.


If its an h323/SIP, post the running config and ccapi inout for a bad call.


DTMF is configured at the gateway, and is not configured for specific phones.


HTH
Kunal

jahanzaib.pgis Tue, 10/26/2010 - 01:43
User Badges:

thanks for your suppport!


1. call Manager version 7.x (7.1.5.10000-12).


2. this is SIP Gateway following is the SIP ( DTMF is configured on my Gateway router 2921)

Protocol= SIP

SIP Port = 5060

Transport Protocol=UDP

Voice Codec= G711 A-Law

DTMF = IN-Band DTMF without RFC2833

Signaling IP address = 10.205.20.50

3. I think this is Cisco IP PH setting in Cisco because before it was not working on Linksys SPA 942, 922  but i configured IN-Band in SPA 942,922 and now DTMF is enable and i can Dial landline extensions.

Good Luck,

kusatija Tue, 10/26/2010 - 02:26
User Badges:
  • Silver, 250 points or more

Hello,


Cool, so lets grab the following debugs from the gateway when you call from the 7965

debug voice ccapi inouit

debug ccsip messages


with the calling/called party numbers

Lets see what dial-peer we are hitting.


Also post the running config from the gateway, so we can see whats configured in the dial-peer.


Once i have this information i can suggest further.


Cheers!

Kunal

jahanzaib.pgis Tue, 10/26/2010 - 05:21
User Badges:

router #debug voice ccapi inout
voip ccapi inout debugging is on


Router#debug ccsip messages
SIP Call messages tracing is enabled


i applied these command and above result only.


check attachement!


is there any option in Call manager for DTMF enable ?

Attachment: 
kusatija Wed, 10/27/2010 - 04:56
User Badges:
  • Silver, 250 points or more

Hello!


If you are sure the call was going through the router, then most likely logging was enabled on the router, so u could have done a show log.


If the call is going through the SIP trunk on the call manager, on the SIP trunk config check the parameter:


DTMF Signaling Method:


You could try to set this to RFC2833, which force the call manager to send in band DTMF.


I am assuming that the other end is expecting DTMF inband.


Also i am assuming you are hitting dial-peer 100:


dial-peer voice 100 voip
description
translation-profile outgoing OutCalls
destination-pattern 9.T
session protocol sipv2
session target ipv4:10.205.20.50:5060
incoming called-number 9.T
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte digit-drop h245-signal
codec g711alaw
fax-relay ecm disable
fax-relay sg3-to-g3
fax rate disable
fax protocol pass-through g711alaw
no vad


The above is worth a try and might work, but with out the debugs its hard to say, so if the above does not work, do post the debugs requested.


HTH
Kunal

jahanzaib.pgis Wed, 10/27/2010 - 22:22
User Badges:

how we can set to RFC 2833? yes this is correct that other end is expecting DTMF Inband. i set DTMF INBAND in Linksys IP Ph and then SPA start

working for DTMF.



How we can set RFC2833? see attached log file.

Attachment: 
kusatija Sun, 10/31/2010 - 03:48
User Badges:
  • Silver, 250 points or more

hello,


So the gateway through which the call is going, is it added as a gateway or a trunk(sip) on the call manager?


Please confirm the same, if its a SIP trunk on the call manager, then try and change the following parameter:


DTMF Signaling Method to  RFC2833, see if this resolves the issue.


As then the DTMF will be sent in band, which the other end is expecting.


From the debugs, i realy can not reach a conclusion, we need more information, if the above does not resolve the issue, i suggest you to open a TAC case, so that we can have a look and do some deeper analysis, and troubleshooting.


Cheers!

Kunal

Actions

This Discussion

Related Content