Ciscoview Device Packages

Answered Question
Oct 27th, 2010

I have updated my LMS v3.1 device packages and I still could not able to do Ciscoview on the followings devices:

- Cisco ASR 1004

- Cisco 2911 K9

- Cisco 3945 K9

Does the CiscoView requires other way of devices support packages installation? Does CiscoView support the stated devices?

I have this problem too.
0 votes
Correct Answer by winlau about 3 years 4 months ago

LMS 3.1 unable to view the below devices in CiscoView and device update from cisco.com says no updates available

- Cisco ASR 1004

- Cisco 2911

- Cisco 3945

ASR is not supported in LMS 3.1. Customer is unable to see any updates for CiscoView because he's hitting bug -  CSCtj20850. After applying patch, and upgraded device packages, CV is OK now.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
Gaganjeet Chug Thu, 10/28/2010 - 04:09

Hi Mohd Nzmi,

Kindly post the output of snmwalk for the SysObjectId ( 1.3.6.1.2.1.1.2 ) from Device Centre.

Steps

-----------------

1> Open Device Centre from LMS functional portal

2> open the above device in Device Centre

3> click on snmpwalk and check the box for output numerically

4> paste OID as  - 1.3.6.1.2.1.1.2

5> post the ouptput for all these devices to check if they are actually supported on LMS 3.1

Here is list of all the device supported in LMS 3.1

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_lan_management_solution/3.1/device_support/table/lms31sdt.html

Thanks

Gaganjeet

mohdnazmi Mon, 11/01/2010 - 19:09

Hi,

This is the output from the SNMP Walk:

The following is a SNMP walk of device 10.41.0.6 starting from .1.3.6.1.2.1.1.2

SNMP Walk Output
--------------------------------------------------------------------------------
.1.3.6.1.2.1.1.2

RFC1213-MIB::sysObjectID.0 = OID: CISCO-SMI::ciscoProducts.924


The following is a SNMP walk of device 10.101.3.254 starting from .1.3.6.1.2.1.1.2

SNMP Walk Output
--------------------------------------------------------------------------------
.1.3.6.1.2.1.1.2

RFC1213-MIB::sysObjectID.0 = OID: CISCO-SMI::ciscoProducts.1045


The following is a SNMP walk of device 10.6.0.41 starting from .1.3.6.1.2.1.1.2

SNMP Walk Output
--------------------------------------------------------------------------------
.1.3.6.1.2.1.1.2

RFC1213-MIB::sysObjectID.0 = OID: CISCO-SMI::ciscoProducts.1041

I guess all the devices are supported. But why I could not use CiscoView for the GUI? Does it requires different package?

Gaganjeet Chug Tue, 11/02/2010 - 08:02

Hi,

As per the Device Supported list for LMS 3.1 , only ASR device is not suported rest of the devices are supported.

ciscoProducts.924  (SysObjectID = 1.3.6.1.4.1.9.1.924 ) = Cisco ASR 1000 Series Aggregation Services Routers = Not Supported

ciscoProducts.1045 ( SysObjectID =                          1.3.6.1.4.1.9.1.1045) = Cisco 2911 Integrated Services Router = Supported

ciscoProducts.1041  ( SysObjectID =                          1.3.6.1.4.1.9.1.1041 ) = Cisco 3945 Integrated Services Router = Supported

However, Cisco ASR 1000 Series Aggregation Services Routers is supported in LMS 3.2 ( CiscoView 6.1.9).

Now, you need to check if you are able to filter the OID for 2911 and 3945. Kindly go to Common Services > Software Centre > Device Update. Click on the number of Device packages , for filter SysObjectID and paste the above two OID and see if you are able find the device package.

Also post the screenshot of Common Services > Software Centre > Device Update > Click on Common Services ( It will show the version of MDF )

Thanks

Gaganjeet

mohdnazmi Mon, 11/08/2010 - 18:08

I go to Common Services > Software Center > Device Update, but I am not sure where to go about for the number of devices. Anyway, on this screen I got the listing of LMS Product Name and Device Type Count. I go into CiscoView and click on device type count but I could not find:

1.3.6.1.4.1.9.1.1045

1.3.6.1.4.1.9.1.1041

If these are supported, I thought I should be able to do CiscoView on these devices?

Following is the screenshot on the MDF version.

Attachment: 
Gaganjeet Chug Tue, 11/09/2010 - 02:08

Hi,

Your MDF package is latest. So now you need to update the device packages for CiscoView from Common Services > Device Update > select CiscoView > it will upgrade the device packages from cisco.com.

Note :- while upgrading the device packages, Daemon manager will be restarted automatically so kindly plan for downtime for a while if required.

Kindly show me with screenshot how you are checking that CiscoView dont have device packages for :-

1.3.6.1.4.1.9.1.1045

1.3.6.1.4.1.9.1.1041

Thanks

Gaganjeet

mohdnazmi Tue, 11/09/2010 - 18:43

I have tried update CiscoView package but it says no new updates available.

Please refer to the attachment as how to do the updates as well as how I do the OIDs checking on CiscoView.

Attachment: 
Gaganjeet Chug Wed, 11/10/2010 - 01:50

Hi,

I try to check the device packages on my server for both OID in LMS 3.1 but didnt find it too.

Kindly download the device package for /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;} 1.3.6.1.4.1.9.1.1045 (Rtr2900) from here and then install it from GUI i.e Common Services > Software centre > Device Update >

http://www.cisco.com/cgi-bin/Software/CiscoView/cvresult.cgi?product_class=Routers&product=Router+2900&application=CiscoView+6.1

For OID = /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;} 1.3.6.1.4.1.9.1.1041 (Rtr3900), download the device package from here :-

http://www.cisco.com/cgi-bin/Software/CiscoView/cvresult.cgi?product_class=Routers&product=Router+3900&application=CiscoView+6.1

Kindly go through the readme file as it required some pre-requiste device package too without them it will not install the above device packages and eventually fail to install

.

Thanks,

Gaganjeet

mohdnazmi Wed, 11/10/2010 - 19:09

I have downloaded both packages and tried to install, but it failed. From the activity event log I got the following errors:

Number of Packages Selected for Install : 2

For Product(s) : CiscoView

Install Invoked by user : admin

The Package(s) Selected for Install :

Rtr2900, Rtr3900

WARNING :  Rtr3900(1.1):Consistency check failed for base package NGMARShare


No package(s) to install for : CiscoView

-----------------------

But when I tried to update NGMARShare as requirement stated for the device packages, I notice my current NGMARShare is quite latest. Please refer to attachment for the current NGMARShare version.

Gaganjeet Chug Mon, 11/15/2010 - 06:16

Hi,

This is not psu.log. Kindly cross check it and send the psu.log from CSCOpx\log.

Thanks

Gaganjeet

mohdnazmi Mon, 11/15/2010 - 08:43

Hi,

Did I sent you the wrong one? Kindly refer to the attachment for the psu.log and the screen capture where I got it.

Attachment: 
Gaganjeet Chug Mon, 11/15/2010 - 09:51

Hi,

Thanks for sharing the screenshot. It was indeed the correct psu.log file. I miss some contents from the file while reviewing it.

kindly run the following command from CLI of the LMS server :-

Command 1

---------------------

navigate to  CSCOpxwww\classpath\com\cisco\nm\xms\psu\pkgs\cvw and run command dir > c:\location1.txt

Command 2

----------------------

Navigate to CSCOpx\MDC\tomcat\webapps\CVng\WEB-INF\classes\com\cisco\nm\cvw\devpkgs and dir > c:\location2.txt

Thanks

Gaganjeet

Gaganjeet Chug Thu, 11/18/2010 - 16:25

HI,

Thanks for the two text files. Both the device packages directories are in sync with each other. Now the next step is to recover from the incosistency errors and dependecy issue of the device packages so that all the device packages for RME should be upto date.

I will suggest you to open a TAC case from the Netforum new feature and you can mentioned this thread so that you need to provide all the details again.

The Engineer need to recover the device packages for this version of RME from good known server.

Thanks & Regards

Gaganjeet

mohdnazmi Thu, 11/18/2010 - 20:39

I could not find anywhere from this forum that lead to TAC open case. I can still open TAC case as normal way and relate the discussion on this forum to the case... Am i? 

Gaganjeet Chug Sat, 11/20/2010 - 04:44

Hi,

From the right hand side of this window, under Actions small tab window, you can convert this thread into TAC case.

Thanks,

Gaganjeet

Correct Answer
winlau Tue, 11/30/2010 - 16:38

LMS 3.1 unable to view the below devices in CiscoView and device update from cisco.com says no updates available

- Cisco ASR 1004

- Cisco 2911

- Cisco 3945

ASR is not supported in LMS 3.1. Customer is unable to see any updates for CiscoView because he's hitting bug -  CSCtj20850. After applying patch, and upgraded device packages, CV is OK now.

Actions

Login or Register to take actions

This Discussion

Posted October 27, 2010 at 10:30 PM
Stats:
Replies:19 Avg. Rating:5
Views:2299 Votes:0
Shares:0
Tags: ciscoview
+

Related Content

Discussions Leaderboard

Rank Username Points
1 2,473
2 1,624
3 1,445
4 861
5 578