×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

VDI DHCP problem with Nexus 1000v

Unanswered Question
Nov 2nd, 2010
User Badges:

Hi!


We have an environment consisting of HP Blade and Virtual Connect. The servers used are BL490C G6. Virtual Connect modules are connected to Nexus 5000 switches. Nexus 1000v is used instead of VMware's built-in DV switches.
The environment is running 500 VDI clients that after a period of use (2-4 weeks) stop getting IP addresses from DHCP server. The problems are linked to individual ESX hosts and solved by rebooting the ESX servers.

Anybody seen anything like this?

Versions used:

VMware Vsphere 4.0
Virtual Connect 2.32
Nexus 1000v 4.0(4)SV1(3a)
Nexus 5000 4.1(3)N2(1a)


//HC

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
anmittal Tue, 11/02/2010 - 10:19
User Badges:

HC,


This is the first I've heard of this problem.


Can you share answers to the following questions:

1. Do you have DHCP Snooping enabled?

2. Where is the DHCP server located in your topology?

3. Will you be willing to share a packet capture from the Nexus 1000 while your setup is in this state (via channels other than this forum)?


Thanks,

-AM

hencar Wed, 11/03/2010 - 00:21
User Badges:

Hi AM,


1. DHCP Snooping is not enabled.

2. The DHCP server i virtual but in another cluster than VDI clients (Win 2008 srv).

3. I can post a packet capture next time it happens.

Läs fonetiskt


There is a case registered at VMware who are working on this right now. The customer bought a bundling of VMware and Nexus 1000v licenses so that's why I need to register the case through VMware.


//HC

Rami Bakri Mon, 12/13/2010 - 17:07
User Badges:
  • Cisco Employee,

Hello,


Are these VDI clients using PXE boot? I have seen a similar issue when VDI clients are vMotioned to another host they are pinned incorrectly on the vem.


If you do see the issue again, login into the affected hosts and issue the following commands:


vemcmd show port

vemcmd show pinning


Verify if the ltl for the VDI client is seen in the output of the vemcmd show pinning. Also, can you please share your Uplink port-profile configuration?


Thanks,

Rami

hencar Tue, 12/14/2010 - 04:27
User Badges:

It was a bug in Nexus 1000v NXOS 4.0(4)SV1(3a) with MAC address pinning (bug ID is CSCtg79060).

The problem was solved in NXOS 4.0(4)SV1(3b).

//HC

Actions

This Discussion