×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

route path to as

Answered Question
Nov 6th, 2010
User Badges:

Hi this may be easy, i did configure the default gtwy on r7 and I am able to ping it from the cloud.   I am not able ping from 192.168.3.0  network to 192.168.2.0 or 192.168.1.0 network , I did put in the network statement and neighbor statement on r7. I also tried ip route it seems not to work .


the interfaces on r7 are .1 and the interfaces on r1 and r2 are .2 .. I would like to to be able to reach .2 from the cloud. can you please help.


Thanks


pc to bgp router.jpg

Correct Answer by Reza Sharifi about 6 years 9 months ago

You first need to fix your IGP before worrying about BGP.  That means from the cloud you need to be able to ping the loopback address of router 1 and router 2.  Now, if you are not running any routing protocol then you need static routes from the cloud to both of the r1 and r2 loopback addresses.

Once your IGP if fixed and you can ping from the cloud to r1 and r2 and vice versa, then you can configure your BGP.


HTH

Reza

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (3 ratings)
Loading.
Reza Sharifi Sat, 11/06/2010 - 20:46
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


What routing protocol are you running, OSFP, ISIS, RIP?


Reza

Tharak Abraham Sun, 11/07/2010 - 02:51
User Badges:
  • Bronze, 100 points or more

Hi,


We see that you are trying to reach the networks 192.168.1.0/30 and 192.168.20/30 from the cloud.

Did you advertise these on the networks in BGP with /30 mask ? Can you verify with the sh ip bgp


Moreover did you mean that the cloud has knowledge of these n/w ?

Could you check the BGP table from the cloud ? sh ip route bgp and let us know ?

Lei Tian Sun, 11/07/2010 - 04:41
User Badges:
  • Cisco Employee,

Hi,


Make sure your R1 and R2 have the route for 192.168.3.0/24.


HTH,

Lei Tian

cisco steps Sun, 11/07/2010 - 09:11
User Badges:

I am not planing to run ospf , eigrp or any, just bgp 100 for now that will be connected to an other bgp 200 . the cloud is number of user connected to a switch and the switch is connected to r7 , r7 provided redundant network to bgp 100 that is going to bgp 200 witch is not in the design yet, once I figure out how to communicate w/ r2 and r4 from the cloud I can then move to the next step witch is configuring bgp 200 . here some info ,


R7#sho run | begin router bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
network 10.1.1.0 mask 255.255.255.252
network 10.1.2.0 mask 255.255.255.252
neighbor 192.168.1.2 remote-as 100
neighbor 192.168.2.2 remote-as 100
no auto-summary



R7#sho ip route
Gateway of last resort is not set

     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback0
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Ethernet1/0
     192.168.2.0/30 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet0/1



R7#sho ip bgp


R7#sho ip bgp summary
BGP router identifier 7.7.7.7, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.1.2     4   100      12      12        1    0    0 00:09:41        0
192.168.2.2     4   100      12      12        1    0    0 00:09:36        0

======================================================================================================




R1#sho run | begin router bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 200
neighbor 10.1.5.2 remote-as 200
neighbor 192.168.1.1 remote-as 100
no auto-summary


R1#sho ip bgp summary
BGP router identifier 192.168.1.2, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.1.2        4   200       0       0        0    0    0 never    Active
10.1.5.2        4   200       0       0        0    0    0 never    Active
192.168.1.1     4   100      15      15        1    0    0 00:12:49        0



R1#sho ip bgp



R1#sho ip route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
C       10.1.5.0 is directly connected, FastEthernet0/1
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Ethernet1/0


======================================================================



R2#sho run | begin router bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.1.2.2 remote-as 200
neighbor 10.1.6.2 remote-as 200
neighbor 192.168.2.1 remote-as 100
no auto-summary



R2#sho ip route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.2.0 is directly connected, FastEthernet0/0
C       10.1.6.0 is directly connected, FastEthernet0/1
     192.168.2.0/30 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Ethernet1/0



R2#sho ip bgp




R2#sho ip bgp summary


BGP router identifier 2.2.2.2, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.2.2        4   200       0       0        0    0    0 never    Active
10.1.6.2        4   200       0       0        0    0    0 never    Active
192.168.2.1     4   100      19      19        1    0    0 00:16:08        0



Thank you all for your help ,

cisco steps Sun, 11/07/2010 - 10:12
User Badges:

I did manage to ping 192.168.1.1 witch was not the case before..but still no route to 192.168.2.1.. the 7 network is a loopback on r7 ..


R7#sho cdp n

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R2               Fas 0/1            151        R S I      3660      Eth 1/0
R1               Eth 1/0            146        R S I      3660      Eth 1/0


R7#sho run | begin router bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
network 10.1.1.0 mask 255.255.255.252
network 10.1.2.0 mask 255.255.255.252
network 192.168.1.0 mask 255.255.255.252
network 192.168.2.0 mask 255.255.255.252
neighbor 192.168.1.2 remote-as 100
neighbor 192.168.2.2 remote-as 100
no auto-summary


R1#sho run | begin router bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 100
neighbor 10.1.1.2 remote-as 200
neighbor 10.1.5.2 remote-as 200
neighbor 192.168.1.1 remote-as 100
no auto-summary



R2#sho run | begin router bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 100
neighbor 10.1.2.2 remote-as 200
neighbor 10.1.6.2 remote-as 200
neighbor 192.168.2.1 remote-as 100
no auto-summary



C:\>ping 192.168.1.1 -t

Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.1: bytes=32 time=3ms TTL=255
Reply from 192.168.1.1: bytes=32 time=3ms TTL=255
Reply from 192.168.1.1: bytes=32 time=3ms TTL=255
Reply from 192.168.1.1: bytes=32 time=5ms TTL=255
Reply from 192.168.1.1: bytes=32 time=2ms TTL=255


C:\>ping 192.168.2.1 -t

Pinging 192.168.2.1 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.

lgijssel Sun, 11/07/2010 - 11:19
User Badges:
  • Red, 2250 points or more

There might be more problems but that will be hard to say without the output of "sh ip bgp" which was already requested.

It looks as if the neighbor relations R1-R7 and R2-R7 are not properly established.


From your last post, at least the following line is required on R7:

router bgp 100

network 192.168.3.0 mask 255.255.255.0


regards,

Leo

cisco steps Sun, 11/07/2010 - 14:37
User Badges:

leo ,


here is the sho ip bgp




R7#sho ip bgp

BGP table version is 3, local router ID is 7.7.7.7

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete


   Network          Next Hop            Metric LocPrf Weight Path

*> 192.168.1.0/30   0.0.0.0                  0         32768 i

*> 192.168.2.0/30   0.0.0.0                  0         32768 i

it does show 2 valid best routes to network .1 and .2 , now I can still ping 192.168.1.1 from the cloud but not 192.168.1.2 and 192.168.2.1.
Thanks
Tharak Abraham Sun, 11/07/2010 - 18:38
User Badges:
  • Bronze, 100 points or more

That seems to be a rather not so good design and use of BGP

An IGP like Ospf would be scale much better in your scenario.


1. Are you able to ping from R7 to all the other routers ?


2. Why have you advertised the connected networks in BGP ? i.e 192.168.1.0 and 192.168.2.0

The only network that upstream neighbor wants is the 192.168.3.0 network which has to be originated in R7.


3. How are the other routers getting to know about the 192.168.3.0 network ?

Correct Answer
Reza Sharifi Sun, 11/07/2010 - 14:40
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

You first need to fix your IGP before worrying about BGP.  That means from the cloud you need to be able to ping the loopback address of router 1 and router 2.  Now, if you are not running any routing protocol then you need static routes from the cloud to both of the r1 and r2 loopback addresses.

Once your IGP if fixed and you can ping from the cloud to r1 and r2 and vice versa, then you can configure your BGP.


HTH

Reza

cisco steps Tue, 11/09/2010 - 12:08
User Badges:

Thank yo reza,


I deleted the whole config. created ip route to reach other router then I configured BGP . that cleared my problem. I now I can use ospf or eigrp to advertise the route then aggregate the network , but that was not my Plan , I only wants BGP ,


Thank you all

Reza Sharifi Tue, 11/09/2010 - 12:18
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

You can not have connectivity/peering without some sort of IGP. That means, at minimum, you have to configure static routes to have readability first before you can bring up your BGP peers. You can of course use OSPF, ISIS, etc... to make life easier.



HTH

Reza

Actions

This Discussion