WLC 5508 - WebAuth Bundle tar error 256

Unanswered Question
Nov 9th, 2010

Hi all,

I have a new fresh 5508 release 7.0.98.0

When I try to download (I mean upload to the controller) a customized Webauth bundle in .tar format I have the following message error in the syslog :

*TransferTask: Oct 29 12:56:08.894: %UPDATE-3-UNTAR_CMD_FAIL: updcode.c:2832 Error during untar of webauth bundle. Tar returned 256.

If someon could help me...

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
surbg Tue, 11/09/2010 - 01:31

Hi Karl,

The WLC software that you are using is hitting the bug.. i really sorry to let you know that the Bug is still internal to Cisco (Confidential). I request you to open up a TAC case to get the resolution.

Regards

Surendra

karloulmi Tue, 11/09/2010 - 03:01

Hi,

Ok, thanks...

The funniest thing is that it seems to work fine on the same controller running with the 6.x OS

surbg Tue, 11/09/2010 - 06:39

I agree with you.. but the bug is affected from the latest onwards..

Regards
Surendra

Tiago Antunes Wed, 11/10/2010 - 06:05

Hi,

This is bug CSCth51156 - Extracting Custom Web Authentication Tar Package May Fail on 5500 WLC.

When running 7.0.98.0 WLC code on a 5508 WLC, the tar extraction process may fail generating the following error: Error extracting webauth files.

This condition only occurs on a 5508 running the 7.0.98.0 code.  The same package can be loaded on a 4404 running 7.0.98.0 successfully, and also to a 5508 running 6.0.196.0.

Workaround:
Create .tar package using the following command on UNIX or Windows (via http://gnuwin32.sourceforge.net/packages/gtar.htm):
tar -cvf login.tar ...

HTH,
Tiago

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Tiago Antunes Thu, 11/11/2010 - 00:20

Well,

I can assure that is the workaround, and we have had many SRs were customers applyed the workaround and it worked...

If you are having trouble, feel free to open a SR with TAC and the engineer will eventually compile the tar file for you.

HTH,
Tiago

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

karloulmi Mon, 12/06/2010 - 00:42

Hi Tiago

After many hours to understand whats wrong with your workaround, I finally got the answer.

ALL files in the tar file of the webauthbundle you want to upload into the WLC MUST BE created on a linux box with the root acount, that mean ALL files and folders MUST have UID root and GID root.

That's why It doesn't work if you create your tar file on a Windows Box, nor on FreeBSD Box (that was my case - gid root doesn't exists on FreeBSD!).

I presume the OS used on the WLC should be a Linux like, and It needs to have root:root owned files !

It's crazy, isn't it ?

Regards,

Karl.

davy.timmermans Mon, 12/06/2010 - 02:29

I recently had also problems to upload a webauth bundle to a 5508 controller with the latest software.

I don't remember the error anymore, but finally I was able to upload the tar file if it was tar'ed with picozip and not for example winrar...

petnugen Wed, 12/22/2010 - 03:09

Tiago

Basically I have this issue and I am unfamiliar with GNU or UNix so simply saying it works is no help.

Do you have detailed instructions.

For example even getting GNU to work is an issue as the is no recognised command in GNU win TAR.

Also will it work if you down grade the controller to 6.x, load the webauth, then upgrade to 7.x

rsreeves1 Tue, 02/15/2011 - 09:51

Excellent find, Karl!

I'd just to clarify a bit for those who might not have completely understood this.  Note that Karl said all files and folders must have UID root and GID root.  Running chown root only changes the UID.  To change the GID, you must also run chgrp root .  The easiest way to go about this is to create a new directory, copy your current tar file to it and extract, chown and chgrp against ./*, then tar it back up.

su root     # alternatively, you can use sudo for chown and chgrp

mkdir weblogintmp

cp weblogin.tar weblogintmp/

cd weblogintmp

tar -xvf weblogin.tar

rm weblogin.tar

chown -R root ./*

chgrp -R root ./*

tar -cvf weblogin-new.tar ./*

## the tar file itself doesn't need to have UID and GID root, only the contents of it does.

Karl also pointed out that this must be done from a Unix/Linux-based operating system that a GID (group ID) literally named root.  In BSD-based systems (at least the ones I've worked with, including Mac OSX), the root-equivalent GID is named wheel.  The 5508 WLC with 7.0.98.0 will not accept this.

If you do all of this and it still gets rejected by the WLC, consider that there might actually be something else wrong with it.  There's a fantastic article in the Documents section of the Security and Network Management group which helped me figure out a couple issues I had in the past:

https://supportforums.cisco.com/docs/DOC-13954

Here's a snippet that pertains to not being able to transfer your webauth bundle to a WLC:

"There are some limitations with custom webauth that varies with versions  and bugs. The things to watch for are .tar file size (used to be 1Meg  maximum), also the number of files in the .tar as well as the filename  length of the files in there (something like 30 characters max for a  file)."

andreaslidberg Wed, 01/12/2011 - 02:53

Hi all!

I ran into the same problem and tried the fix creating (or rather chowning) the bundle-files on a linux box, then creating the tar file on the same box, all with root privileges. Still get the same error extracting.

WLC is 5508 and version is 7.0.98.0

Do I have to set permissions on the files to something specail also? (rwx)

/Andreas

socket2000 Wed, 02/09/2011 - 07:18

Hi All

I got fed up with asking my unix friend to tar up files for me. I found that iZarc for Windows has a tar option and works and also using a ubuntu boot disk and right clicking on the files and selecting 'compress' and choosing tar format worked too. 7-Zip didn't work.

I also had this message for another reason and found that you must have a login.html file in your tar package. I had renamed mine because I had multiple webauth pages with different names and it came up with the same message about failing to extract.

Hope that helps.

regards

Steve

sbeauton Thu, 06/09/2011 - 11:44

Thanks Scoket2000 for your help.  I used iZarc and it worked perfect for me.  Thanks again. 

CCATTEAU_2 Thu, 03/10/2011 - 02:34

I run into same issue.

In my case, problem was files rights.They are like this when you download it:

-rw-r--r--  1 278783   25  4967 aoû 24  2005 chassis4402.gif

-rw-r--r--  1 278783   25  3656 déc  9  2005 login.html

Notice owner "278783" and group "25". It should be like this when you upload it.

Tar software I tried under Windows modified it to

-rwxrwxrwx  1 root root  4967 aoû 24  2005 chassis4402.gif
-rwxrwxrwx  1 root root  3656 déc  9  2005 login.html

and transert gives an INVALID_TAR_FILE answer.

I finaly made it work by modifying it under Linux.

Regards

Christophe

superjay007 Tue, 03/12/2013 - 08:56

Still appears to be a problem on version 7.0.230.0 of the WCS. I used 7zip to open the file, overwritten the login.html file with the one I doctored and added in a picture of a different file name and the upload was sucessful. I'm not sure whether it is hit and miss because the first time I tried this, I received an error message stating that the tar was in an invalid format.

leoorcocisco Fri, 03/15/2013 - 05:18

Hi everyone,

I have used 7zip and work but you must enter the following parameters: tar -cvf login.tar ... as advice Tiago Antunes in a earlier answer.

For example, if you want dowload login.html file, for create the package you will enter: tar -cvf login.tar

Regards

Actions

Login or Register to take actions

This Discussion

Posted November 9, 2010 at 1:26 AM
Stats:
Replies:17 Avg. Rating:5
Views:7560 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard