HELP. Voice mail is not working

Answered Question
Nov 9th, 2010
User Badges:

Hi,


I'm having problems with a voicemail.


Scenario:


CME configure with a Unity Express for voice mail. When i call from the PSTN the Auto-Attendat picks up the call,

the call is transfer to an extension.  I let the extension ring until forward the call to the voicemail.


Once i hear the message "leave your message for xxxx", i leave the message but the mailbox doesn't receive any message. The phone doesn't turn on

the light indicating a new message has arrived.  I have configure MWI  on the CME. I also have configure the voice mail in the unity:


CME:

===

ephone-dn  61
number A61.... no-reg primary
description FOR MWI-ON
mwi on 


ephone-dn  62
number A62.... no-reg primary
description FOR MWI-OFF
mwi off


dial-peer voice 5000 voip
description *** FOR VOICE MAIL ****
destination-pattern 5000
session protocol sipv2
session target ipv4:10.234.144.254
dtmf-relay sip-notify rtp-nte
codec g711ulaw
no vad



UNITY VOICEMAIL CONFIG:

====================

voicemail mailbox owner "Rigsanchez" size 5400
description "Rigoberto Sanchez mailbox"
end mailbox


Other thing i noticed is that when i'm leaving the message and press #, for more option,  the system tells me that the message is too short.


Can somebody help me?


Thansk for your response

Correct Answer by dksingh about 6 years 7 months ago

Can u try adding this while trying g729r8 (default) codec ?


sip-ua
g729-annexb override  <--- add this (hidden so pl. just type)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Tue, 11/09/2010 - 08:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Is this the same problem you described in another thread? If so, please do not open duplicates.

Dfulgencio Tue, 11/09/2010 - 08:47
User Badges:

Hi,


Not this issue is different.  In the other case when a forwarded the call from the extension to the voicemail, the call didn't connect.

Now i have connection to the voicemail.  But when i leave the message it doesn't leave anything.


I solved the other problem forcing the codec in the incoming dial-peer. I was using a codec list.


thanks..

paolo bevilacqua Tue, 11/09/2010 - 09:01
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Does it work when calling from a local ip phone ?

Dfulgencio Tue, 11/09/2010 - 09:05
User Badges:

Hi,


Not.  It doesn't work if i call from an internal phone.


When i'm leaving the message the system tells me that the message is too short, when i selec the # key  for more options. If i close after leaving the message and i check, there is nothing in the mailbox.


I configure the message size to 120 secs the default was 240.  but it  doesn't work with either of them.


thanks...

paolo bevilacqua Tue, 11/09/2010 - 09:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Is this calling AA, or the phone with VM directly ?

Dfulgencio Tue, 11/09/2010 - 09:41
User Badges:

Hi,


I'am calling from the extension to the VM...


When i make an internal call test.

dksingh Tue, 11/09/2010 - 09:23
User Badges:
  • Cisco Employee,

Its probably one way audio issue CME-->CUE

So nothing gets recorded.

When the call to CUE/VM is up, can u capture:


sh sip call

sh call act voice brief (3 times)

sh voip rtp connect


Also make sure you do not have  ip verify unicast reverse-path  CLI

on any of the interface...there is a known issue with that.

Dfulgencio Tue, 11/09/2010 - 09:40
User Badges:

Hi Dilip,


I made the capture. I added to the post.


I'm no too expert in this.  I have little time working with VoIP.


Can you, please, give it a check for me.


Thaks,,

dksingh Tue, 11/09/2010 - 10:05
User Badges:
  • Cisco Employee,

Can u share ur config so that I can make some sense out of

these IP ?

I also see that in the capture there is only one g711 call and

the Tx/Rx count is very low...

It also appears that this was for a call from external and not

from a local IP phone?

Is transcoding in use as there are lots of calls with g729br8

codec; g729br8 has builtin-vad and CUE requires no vad on

the sip dialpeer.

If u can, capture a sniffer off the CUE interface. I can send u

the procedure for using internal packet capture on IOS.

dksingh Tue, 11/09/2010 - 10:39
User Badges:
  • Cisco Employee,

Hello,


The captures you gave are for a call over SIP trunk with xcoding invoked

for g711u<->g729br8

To simplify, can u recreate the issue with on a local IP phone (on vlan 20) and capture those?

Wondering why u r using g729br8 (dialpeer 1100) instead of g729r8 ?


DK

Dfulgencio Tue, 11/09/2010 - 10:58
User Badges:

Hi,


Here is the capture making a call from an internal phone.


The TAC configure this codec I opened a case with them because when the call was transfer from the ext to the VM the VM didn't pick up the call.

dksingh Tue, 11/09/2010 - 11:14
User Badges:
  • Cisco Employee,

Thanks...this looks good...I see Tx counts going up so packets

are being sent to CUE.


Let's see if we can see the same in the sniffer....u can use following

procedure to do a packet capture on the CUE interface.......


First configure following (config t mode)....


ip traffic-export profile DKS mode capture
  bidirectional
  length 512


interface ISM0/0

  ip traffic-export apply DKS size 2000000


Then from enable mode........


pueblo_central#trafffic-export  interface ISM0/0 clear

pueblo_central#trafffic-export  interface ISM0/0 start

---place your test call----

pueblo_central#trafffic-export  interface ISM0/0 stop

pueblo_central#trafffic-export  interface ISM0/0 copy tftp://


pueblo_central#trafffic-export  interface ISM0/0 clear


Upload CUE.cap

Dfulgencio Tue, 11/09/2010 - 12:45
User Badges:

Hi Dilip,


I changed the condec on dial-peer 1100 and it is working.  I put the g711ulaw codec.


How can i make it work using the g729r8 codec?   Because i tried using g729r8 but it didn't work either.


Thanks.

Correct Answer
dksingh Tue, 11/09/2010 - 13:05
User Badges:
  • Cisco Employee,

Can u try adding this while trying g729r8 (default) codec ?


sip-ua
g729-annexb override  <--- add this (hidden so pl. just type)

Dfulgencio Tue, 11/09/2010 - 17:26
User Badges:

Hi Dilip,


I tried the last command you told me and now is working fine.


Thanks a lot for your help.

dksingh Tue, 11/09/2010 - 18:45
User Badges:
  • Cisco Employee,

Hi there,


Great! I am glad that it worked out....

That command causes IOS to interop with systems
not compliant with rfc 3555.

Pl. mark this thread as answered and

rate as appropriate..


Thx,

DK

Actions

This Discussion