VG224 error ACTIVE_IN_PROGRESS - Cause Code: CCM_REGISTER_FAILED

Unanswered Question
Nov 12th, 2010

I have CUCM 6.1(4a)SU2 on production.

There are 20 number of VG224, None of the VG224 are getting registerd with CallManager.

Day before CUCM version was 6.1(2) some Analog Phones are not getting registered and sometime few VG224 was not getting registered

We upgraded the CUCM to 6.1(4a)SU, after upgrade none of the VG224 are getting registered.

Tried, restarting VG224 and tried no sccp and sccp, also tried restarting CUCM, but no use.


VG224 Version 124-2.T6
CallManager Version - 6.1(4a)SU2


SCCP Admin State: UP
Gateway IP Address: 10.200.0.124, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 10.207.0.6, Port Number: 2000
                Priority: N/A, Version: 3.1, Identifier: 10
Call Manager: 10.207.0.5, Port Number: 2000
                Priority: N/A, Version: 3.1, Identifier: 12

Alg_Phone Oper State: ACTIVE_IN_PROGRESS - Cause Code: CCM_REGISTER_FAILED
Active Call Manager: 10.207.0.6, Port Number: 2000
TCP Link Status: NOT_CONNECTED, Device Name: AN1C58C9804D400
Reported Max Streams: 1, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 20
Supported Codec: g711alaw, Maximum Packetization Period: 20
Supported Codec: g729ar8, Maximum Packetization Period: 220
Supported Codec: g729br8, Maximum Packetization Period: 220
Supported Codec: g729r8, Maximum Packetization Period: 220
Supported Codec: NSE VBD, Maximum Packetization Period: 20
-----------------------------------------------------------

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Steven Holl Fri, 11/12/2010 - 08:25

Check the version specified in the 'sccp ccm' line.  That needs to match the version of CM which you are running.  You have it defined for 3.1, and you're running CM 7.  Change that and bounce sccp.

You're going to need to run at least 12.4(22)T to get v7 support, though.  Might as well just upgrade to 15.0(1)M4 in that case.

rajesh.kumar Fri, 11/12/2010 - 08:47

Hi,

Thanks, we are running CM6.1(4) not CM7

in SCCP CM version is available only till 4.1

identifier 1 version --> here max 4.1 is avialable.

pls. suggest.

rajesh.kumar Fri, 11/12/2010 - 09:08

Hi

I have upgraded to 124-25d

v6 is not availalbe, is it available ononly T version?

Upgrading to 15.0(1)M4---> is it license based ? Does it cost or shall I download with CCO account ?

Rgds

Rajesh

Steven Holl Fri, 11/12/2010 - 09:11

You went to 12.4(25d) which is mainline.  That's the same exact code as 12.4(1) other than it having bug fixes.  No new features, no new CLI commands are added between these releases.  All of that is done in subsequent T throttles.  That's why I asked you go to at least 12.4(20)T, and recommended 15.x.

15.x code only enforces feature licenses on the ISR G2 devices.  You will be able to run 15.0(1)M4 for this platform (vg224) without any issues, and without any further cost.

rajesh.kumar Fri, 11/12/2010 - 09:56

Hi

After upgrading torequired version problem is same.

Pls. suggest.

Version : vg224-i6s-mz.124-24.T4.bin

------

!
sccp local FastEthernet0/0
sccp ccm 10.207.0.5 identifier 12 version 6.0
sccp ccm 10.207.0.6 identifier 10 version 6.0
sccp
!
sccp ccm group 1
associate ccm 10 priority 1
associate ccm 12 priority 2
registration timeout 3
keepalive retries 1
keepalive timeout 3
!
---------

SCCP Admin State: UP
Gateway Local Interface: FastEthernet0/0
        IPv4 Address: 10.200.0.142
        Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 10.207.0.6, Port Number: 2000
                Priority: N/A, Version: 6.0, Identifier: 10
                Trustpoint: N/A
Call Manager: 10.207.0.5, Port Number: 2000
                Priority: N/A, Version: 6.0, Identifier: 12
                Trustpoint: N/A

Alg_Phone Oper State: ACTIVE_IN_PROGRESS - Cause Code: CCM_REGISTER_FAILED
Active Call Manager: 10.207.0.6, Port Number: 2000
TCP Link Status: NOT_CONNECTED, Device Name: AN1F9E074F07400
Reported Max Streams: 1, Reported Max OOS Streams: 0
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30
Supported Codec: g711ulaw, Maximum Packetization Period: 20
Supported Codec: g711alaw, Maximum Packetization Period: 20
Supported Codec: g729r8, Maximum Packetization Period: 220
Supported Codec: g729ar8, Maximum Packetization Period: 220
Supported Codec: g729br8, Maximum Packetization Period: 220
Supported Codec: g729r8, Maximum Packetization Period: 220
Supported Codec: ilbc, Maximum Packetization Period: 120

Steven Holl Fri, 11/12/2010 - 10:14

Please post the whole config, then.

Make sure that the CM group for this gateway contains the nodes 10.207.0.5 and 10.207.0.6, and that the gateway is added with the IP address that you have defined in 'sccp local'.

If the issue persists, collect the following during a no sccp/sccp:

debug ip tcp trans

debug sccp all

Collect via:

Router(config)# service sequence
Router(config)# service timestamps debug datetime msec
Router(config)# logging buffered 10000000 7
Router(config)# no logging con
Router(config)# no logging mon
Router(config)# voice iec syslog

Router# term len 0

Router# sh logg

There aren't any NAT devices between this gateway and CM, right?

Steven Holl Fri, 11/12/2010 - 11:45

L4 connectivity looks good.  CM is rejecting the registration due to a DB issue:

*Mar  1 00:05:05.043: SCCP(AN1C58C9804D404)rcvd RegisterRejectMessage
*Mar  1 00:05:05.043: sccp_appl_service_stop_timer: Stop 64D32720 timer
*Mar  1 00:05:05.043: sccp_parse_control_msg_v1: rcvd register rej, reason: Erro
r: DB Config

So it's an issue on the CM side.  Detailed CM traces may shed a little more light.

Can you verify that you have AN1C58C9804D404 defined as the endpoint in CM?  Have you tried resetting this endpoint in CM to see if that makes a difference?  You can also try pointing directly to the pub, in case you have a DB replication issue.

Barring that, I'd try deleting and re-adding the gateway in CM to see if that allows for the DB to be re-populated with the entry to get this device to register.

An CM engineer may be able to chime in with a SQL query to probe the database for if this endpoint exists in the current state, but datababase troubleshooting isn't really where my expertise lies.

rajesh.kumar Sat, 11/13/2010 - 06:27

Hi

Delete and adding VG224 resolved the issue.

sccp ccm identifier 1version 6.0

Version 6.0 in this above command is must? If I dont configure version 6.0 will there be any interoeprability problem with CUCM6 ?

Was it causing my Analog phones to go offiline/unregistered randomly?

Pls. suggest

Rgds

Rajesh

Steven Holl Sat, 11/13/2010 - 06:53

Version mismatch shouldn't cause intermittent unregistration of the endpoionts (that sounds like a QoS issue on TCP/2000 to CM, perhaps), but it is required to get that version to match the CM verison.  Otherwise, the endpoint may not register at all, or you may encounter no audio.

rawatsatish Sun, 05/06/2012 - 16:07

Hi All, I encountered exactly this issue while i was adding VG224 as SCCP, what was stragne is that i was able to add same VG as MGCP...

well after lot of research and digging deep into debug logs i figured that i was getting below event when doing "debug sccp all"

sccp_parse_control_msg_v1: rcvd register rej, reason: Secu

rity Error

Mar 4 03:20:36.401: sccpapp_process_socket_events: TCP_SOCKET_READ: appl_type

4, eve 4, state 5

*Mar 4 03:20:36.401: sccp_get_control_message: bytes_to_read 8, bytes_read 8, a

ppl_total_bytes 8, appl_bytes_read 8, soc_read_mode 0, soc 0

*Mar 4 03:20:36.401: sccp_get_control_message: bytes_to_read 36, bytes_read 36,

appl_total_bytes 36, appl_bytes_read 36, soc_read_mode 1, soc 0

*Mar 4 03:20:36.401: sccp_get_control_message: sccp cntl msg rcvd, prof_id 0, a

ppl_type 4, msg_len 36

*Mar 4 03:20:36.401: sccp_parse_control_msg: msg_ptr 639644B0, msg_len 36, msg_

id 157

*Mar 4 03:20:36.401: sccp_parse_control_msg: glob_ccm->version 9

*Mar 4 03:20:36.401: SCCP(AND0FD482192412)rcvd RegisterRejectMessage

*Mar 4 03:20:36.401: sccp_appl_service_stop_timer: Stop 65543584 timer

*Mar 4 03:20:36.401: sccp_parse_control_msg_v1: rcvd register rej, reason: Secu

rity Error

*Mar 4 03:20:36.405: sccp_initiate_ccm_connect_interval_timer: Start CCM connec

t interval timer for prof_id 0, appl_type 4, interval 55

*Mar 4 03:20:37.329: sccp_connect_to_ccm_on_priority_basis: Trying connecting t

o CCM on priority basis prof_id 0, appl_type 4

*Mar 4 03:20:37.329: sccp_connect_to_ccm_on_priority_basis: Trying CCM with ipa

ddr 10.86.75.10, priority 2, port 2000

*Mar 4 03:20:37.329: sccp_tcp_socket_connect: Trying tcp soc connect for appl_t

ype 4, prof_id 0, to ipaddr 10.86.75.10

*Mar 4 03:20:37.329: sccp_tcp_open_and_set_option: Socket 0 opened and binded t

o addr 10.86.75.10 - for appl_type 4, prof_id 0

*Mar 4 03:20:37.329: sccp_socket_connect_to_ccm :: connecting to port 2000 scc

p_socket_connect_to_ccm: soc conn to 10.86.75.10 port 2000 in progressfor appl_t

ype 4, state 1, soc_fd 0 appl 655CC1F4

*Mar 4 03:20:37.337: sccpapp_process_socket_events: appl_type 4, soc_fd 0, soc

0, swb_soc -1

*Mar 4 03:20:37.337: sccpapp_process_socket_events: TCP_SOCKET_READ: appl_type

4, eve 4, state 1

*Mar 4 03:20:37.337: sccp_appl_service_stop_timer: Stop 655CC24C timer

*Mar 4 03:20:37.337: sccp_process_socket_connect_result: appl_type 4, eve 3, so

c_id 0, state 1

*Mar 4 03:20:37.337: sccp_setup_appl_to_tcp_conn_state: soc connected to 10.86.

75.10, for prof_id 0, appl_type 4

*Mar 4 03:20:37.337: sccp_register_with_connected_ccm:

*Mar 4 03:20:37.337: sccp_register_with_connected_ccm: Sending regis msg for ap

pl_type 4, state 5

*Mar 4 03:20:37.337: sccp_send_register_msg: Send register msg for appl_type 4,

swb_soc 0, device_name AND0FD482192403, ip_addr 10.86.76.6, ipv4_scope 2, ipv6

_addr ::, ipv6_scope 0, device_type 30027,

sccp_parse_control_msg_v1: rcvd register rej, reason: Secu
rity Error

I thought about it and checked almost everything, followed all the blogs on fourms and then realised that it was due to incorrect MAC address in CM, read carefully when you add VG 224 as SCCP gw in CM, it says last 10 digit of MAC address and i found that i had first 10 digit instead.

Once i changed that all the ports registered sweetly...below are debug logs that i observed while the issue was going on

Mar 4 03:20:36.401: sccpapp_process_socket_events: TCP_SOCKET_READ: appl_type
4, eve 4, state 5
*Mar 4 03:20:36.401: sccp_get_control_message: bytes_to_read 8, bytes_read 8, a
ppl_total_bytes 8, appl_bytes_read 8, soc_read_mode 0, soc 0
*Mar 4 03:20:36.401: sccp_get_control_message: bytes_to_read 36, bytes_read 36,
appl_total_bytes 36, appl_bytes_read 36, soc_read_mode 1, soc 0
*Mar 4 03:20:36.401: sccp_get_control_message: sccp cntl msg rcvd, prof_id 0, a
ppl_type 4, msg_len 36
*Mar 4 03:20:36.401: sccp_parse_control_msg: msg_ptr 639644B0, msg_len 36, msg_
id 157
*Mar 4 03:20:36.401: sccp_parse_control_msg: glob_ccm->version 9
*Mar 4 03:20:36.401: SCCP(AND0FD482192412)rcvd RegisterRejectMessage
*Mar 4 03:20:36.401: sccp_appl_service_stop_timer: Stop 65543584 timer
*Mar 4 03:20:36.401: sccp_parse_control_msg_v1: rcvd register rej, reason: Secu
rity Error
*Mar 4 03:20:36.405: sccp_initiate_ccm_connect_interval_timer: Start CCM connec
t interval timer for prof_id 0, appl_type 4, interval 55
*Mar 4 03:20:37.329: sccp_connect_to_ccm_on_priority_basis: Trying connecting t
o CCM on priority basis prof_id 0, appl_type 4
*Mar 4 03:20:37.329: sccp_connect_to_ccm_on_priority_basis: Trying CCM with ipa
ddr 10.86.75.10, priority 2, port 2000
*Mar 4 03:20:37.329: sccp_tcp_socket_connect: Trying tcp soc connect for appl_t
ype 4, prof_id 0, to ipaddr 10.86.75.10
*Mar 4 03:20:37.329: sccp_tcp_open_and_set_option: Socket 0 opened and binded t
o addr 10.86.75.10 - for appl_type 4, prof_id 0
*Mar 4 03:20:37.329: sccp_socket_connect_to_ccm :: connecting to port 2000 scc
p_socket_connect_to_ccm: soc conn to 10.86.75.10 port 2000 in progressfor appl_t
ype 4, state 1, soc_fd 0 appl 655CC1F4
*Mar 4 03:20:37.337: sccpapp_process_socket_events: appl_type 4, soc_fd 0, soc
0, swb_soc -1
*Mar 4 03:20:37.337: sccpapp_process_socket_events: TCP_SOCKET_READ: appl_type
4, eve 4, state 1
*Mar 4 03:20:37.337: sccp_appl_service_stop_timer: Stop 655CC24C timer
*Mar 4 03:20:37.337: sccp_process_socket_connect_result: appl_type 4, eve 3, so
c_id 0, state 1
*Mar 4 03:20:37.337: sccp_setup_appl_to_tcp_conn_state: soc connected to 10.86.
75.10, for prof_id 0, appl_type 4
*Mar 4 03:20:37.337: sccp_register_with_connected_ccm:
*Mar 4 03:20:37.337: sccp_register_with_connected_ccm: Sending regis msg for ap
pl_type 4, state 5
*Mar 4 03:20:37.337: sccp_send_register_msg: Send register msg for appl_type 4,
swb_soc 0, device_name AND0FD482192403, ip_addr 10.86.76.6, ipv4_scope 2, ipv6
_addr ::, ipv6_scope 0, device_type 30027,

IHTH

Thanks

Actions

Login or Register to take actions

This Discussion

Posted November 12, 2010 at 7:55 AM
Stats:
Replies:12 Avg. Rating:
Views:4620 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
154
95
75
66
55