×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

I cannot Click on "Additiinal Task" tab on SDM, to add DNS entries ?

Unanswered Question
Nov 17th, 2010
User Badges:

I have 1841 router, SDM is installed but FA 0/0 is connected to ISP modem, and FA 0/1 is connected to intern/w through a linksys switch, given ip address as per the interfaces


Interface                        IP-Address      OK? Method           Status                                Protocol
FastEthernet0/0            113.X.X.X          YES NVRAM            up                                    up 
FastEthernet0/1            192.168.10.2    YES NVRAM             up                                    up 
Serial0/0/0                    unassigned      YES NVRAM             administratively down         down
NVI0                             unassigned      NO  unset                 up                                      up 
Loopback0                    unassigned      YES NVRAM             up                                     up


################################################################################################################

Building configuration...


Current configuration : 1383 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname //Hidden
!
boot-start-marker
boot-end-marker
!
l
!
!
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
description $ETH-WAN$
ip address 113.X.X.X //Hidden 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.10.2 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
router rip
version 2
network 113.0.0.0
network 192.168.10.0
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.10.0 0.0.0.255
!
!
!
!
control-plane
!
!
!
line con 0
password 7 //Hidden

login
line aux 0
password 7  //Hidden

login
line vty 0 4
privilege level 15
password 7 //Hidden

login local
transport input telnet
!
scheduler allocate 20000 1000
end

################################################################################################################


from my pc which is 192.168.10.44 i can ping 192.168.10.2 (fa 0/1 interface of router ) but cannot ping 4.2.2.2 or any internet, hence i wanted to add static DNS entries but i don't know the commands on cli, hence tried to add through SDM but "additional task" tab is disabled ...



Any ideas what to do next...


Thanks in advance.

vikram

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
kyukim Wed, 11/17/2010 - 14:00
User Badges:
  • Cisco Employee,

  hi,

If you want to make your router to use internet dns server or make it as DNS forwarder, you do it by "ip dns server" "ip name-server xxxx".

Then, you can add A record to IOS dns server with "ip host test x.x.x.x"


Your NAT config looks good so your PC should ping 4.2.2.2 fine.

would you try "ping 4.2.2.2 source f0/1" and type "sh ip nat trans" from router CLI?


KK

cadet alain Thu, 11/18/2010 - 02:50
User Badges:
  • Purple, 4500 points or more

On your pc have you put the correct gateway or mask in your ip config ?

If you can't ping  L3 addresses, dns won't help you much.

For your additional task issue this is a problem with Java ( which version of jre have you got? try to downgrade to 1.6.0.3).

xabrouck Thu, 11/18/2010 - 03:26
User Badges:
  • Cisco Employee,

To see 'additional task' in SDM, you need to downgrade your JVM.


According to http://www.cisco.com/en/US/docs/routers/access/cisco_router_and_security_de​vice_manager/software/release/notes/SDMr25.html#wp35379​

The following versions are supported:

*JRE 1.5_09
*JRE1.4.2_08
*JRE 1.5.0_06
*JRE 1.5.0_07
*JRE 1.6.0_02
*JRE 1.6.0_03

SDM is deprecated now, it's better to use CCP http://www.cisco.com/go/ccp

Xavier

Actions

This Discussion