Accessing both private and public IP address on DMZ

Unanswered Question
Nov 18th, 2010

I imagine this solution is out there but after browsing posts for an hour I can't come up with it.

Below is my network and were using an ASA 5550 8.2.3.




static (dmz,outside)

What I need to be able to do is from the inside access a server on the DMZ via both the address as well as the IP. I can get either or to work but cannot get them both to function at the same time. Ideally it would be even better if when you connected to the ip address it returned the, but that's not a 100% necessary.

This scenerio works like a champ on the PIX and 6.3.5 code via the static (dmz,inside) dns command.

Any help would greatly be appreciated.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
apothula Fri, 11/19/2010 - 00:36

Hi John,

Is your DNS server external ?

Please confirm.



jlizzio Fri, 11/19/2010 - 07:07

I wish we had a single DNS. Unfortunately I inherted quite a mess.

We have internal and external DNS both serving our FQDN (* For the life of me I cannot come up with one good reason why someone would do this but it's here and it's not going away.

I though I came up with a work around but the 3750's that act as the L3 on the inside do not support NAT so now I'm really in a bind.


praprama Fri, 11/19/2010 - 20:55

Hi John,

I am not sure if you got an answer to this one. But in 8.2.x and earlier releases of ASA its not possible. But in 8.3.x and later releases it is possible or at least i have seen it work. Please refer the below link for more information on that:

let me know if this helps!!



Poonguzhali Sankar Sat, 11/20/2010 - 09:26

static (dmz,outside)

What  I need to be able to do is from the inside access a server on the DMZ  via both the address as well as the IP.

Like Prapanch says that is not possible and will give you an error when you try to configure in the form of two statics

and if you do nat 0 with acl and destination static combination then you will end up with nat RPF check failing message.

The best thing to do is to fix the dns servers and make sure they only hand out the internal address for the inside users.

As far as using external dns and it resolving to make sure to add the "dns" keywork to the static

static (dmz,outside) dns

DNS inspection should be enabled so, when the dns response comes back as it will be changed to


jlizzio Sat, 11/20/2010 - 23:38

Thanks for the replies.

Actual it will work in 8.2 but it's much easier in 8.3.

Here is what I did in 8.2.

Create and acl for the servers dmz ip and the internal network - access-list dmz_nat extended permit ip host

Now you tie the two ip addresses (real and public) to the static

     static (dmz,inside) access-list dmz_nat

     static (dmz,inside) access-list dmz_nat

I was able to connect to either IP address from the internal networks to the dmz without issue. It's a little messy but atleast it's a solution as eliminating a internal name server from a billion dollar a year company isn't. I didn't create the mess I just inherated it


praprama Sun, 11/21/2010 - 03:53

Hi John,

Glad to know you managed to get it working and thanks for posting the configuration as well.




This Discussion

Related Content