Corporate Directory getting Host not found.

Unanswered Question
Nov 23rd, 2010
User Badges:

Some 7941 phones can't find the corporate directory since upgrading to CUCM 8.0.3.10000-8.  Phone load is SCCP41.9-0-3S.  Forum is loaded with similar problems.  I've tried some of the solutions suggested none of which have corrected the problem.  It seems that the phones in question are being seen as 'secure' phones because they are picking up the Secure Phone URL's from Enterprise params.  I can't see why this is happening all phones are set to use the Standard SCCP non-secure profile.  The only difference I can find between 7941 that were working and ones that weren't is the URL pointers.    I tried changing the secure Enterprise params to the same as the non secure Enterprise params.  The phones picked up the new URL but still couldn't find the corporate directory (host  not found).  Guess I could try deleting the phone and recreating it but that would leave me not knowing what caused it if it's resolved by this action.  Other than that I'm running short on ideas.


I've attached the latest phone log from one of the lost 7941.  Seems it's not finding the proper .CTL file?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.9 (9 ratings)
Loading.
mmendonca Wed, 11/24/2010 - 12:20
User Badges:

Tried Disassociating the DN, deleting the phone, copied a phone that doesn't have the problem, added the line back in; Same problem 'Host not found'.  Then I tried disassociating the DN same problem; 'Host not found'.


HAPPY THANKSGIVING.

Jonathan Joson Fri, 12/03/2010 - 18:20
User Badges:

Any luck on this one? I've upgraded to CUCM 8.0(3) as well and am getting "Host Not Found" when attempting to access the Corporate Directory. I use IP Addresses instead of Hostnames on the Enterprise Parameter URLs.

lusandi Fri, 12/03/2010 - 22:16
User Badges:
  • Bronze, 100 points or more

Hello mmendonca,


I hope you are doing great,


Would you mind confirming me the following information:


Is the TVS service running on the node to which the phone is registered to?
Are you getting a “Node not trusted” alarm?

Is the phone having a valid ITL file?


The TVS service it is a network service on CUCM 8


Cisco Trust Verification Service


To verify that you need to go to:


Settings

Security configuration

Trust List

ITL File


In the ITL file you will find the

TVS with the FQDN of your cucm.

and also the TFTP server with the FQDN.

if you do not find this, delete the ITL file and restart the IP phone.


Regards,


Luis Sandi

Joseph Martini Sat, 12/04/2010 - 03:51
User Badges:
  • Cisco Employee,

From my experience the problem is usually the TVS entry in the TFTP file the phone gets.  On CUCM 8.x the services provisioning method is set to internal not external so newer phones like the 7941 won't look at the service URL so having an IP there vs a hostname doesn't do anything for those phones.  You can check that you have a hostname in the TVS entry by downloading a phone's config using "tftp x.x.x.x get SEP0123456789AB.cnf.xml" view it in note pad and search for "TVS", you'll likely see a hostname, which is why you're getting the host not found if your phone isn't configured for DNS or cannot resolve that name.  The fix is to change under System > Server, the hostname to an IP address there, save it, then restart th Trust Verification Service (TVS), possibly TFTP (I don't remember if this is necessary but won't hurt).  Then if you download the phone's configuration file again it should have an IP address instead of hostname in the TVS section and your phone should be able to access your directory.

mmendonca Sat, 12/04/2010 - 08:06
User Badges:

Gentlemen thank you for your responses. 


At the time I originally posted the problem it was only a handful of phones that were experiencing this issue.  Since that time it became 2 fold;  It is all relative bear with me and read on.  I was getting new reports of some phones also having an issue with the message button (voice mail) resulting in a 'no service configured' response when pressing it.  Initially one of the Admins reported it when they created a new phone.  All of this of course was occuring since the upgrade.  It all quickly escalated once one of the sites had a power outage (over 200 7941) causing all phones to reload.  At that point we had resolved the issue of the corporate directory getting the message 'host not found' but the messages key 'no service config'd remained.  Several things were done that may have resolved the 'host not found' problem;  The Enterprise Services param was changed from 'interna' to ''external'; The TSV was also restarted and in some instances factory defaulting the phone causing them to reload their images.


I had never changed or set these params prior to the upgrade nor the Enterprise URL service params which pointers were set to IP not DNS. The Messages URL of the same params was blank keep this in mind.   (I'm assuming they were set by default somehow) .  Confused? Sorry read on...


Now we had these 200 phones with no functioning message key.  They could dial the voice pilot directly to retrieve their voice mails as a bandaid while we scrambled to figure out what was going on.  I didn't wait long before calling TAC again.  TAC now reset the Enterprise Service Provisioning param to 'both' this gave the message button it's normal function back.


I definitely need to do more research on all of this functionality but as a result I have gained a better understanding of it all. 


Remember the Enterprise URL param for messages was blank at the start of all this and still is;  Consider these notes in the case from Engineer I worked with on the second ticket I opened. He was inquiring to his team of this functionality.   Remember there were 2 tickets the first for the 'host not found' error on the corporate directory the second on the message button getting 'no service configured';  The first ticket we reset the Services provision from 'internal to 'external' the second ticket it was set to 'both' but never back to 'internal' as the Engineer eludes to:


My Customer has the "Services Provisioning" parameter set on his phone
as External URL. This result that the Messeges button to responds with
"no services configured" when pressed.
When the "Services Provisioning" parameter is set to Internal or Both,
the Messeges button calls the VM Pilot as expected.

My Question is: Is this working as designed?


The response he got back:


think it probably works as designed, please check the help content in CUCM of ��Service
Provisioning��.

If you do not configure the external url of ��Message��, and configure ��Service
Provisioning�� as External, it will show ��no services configured��.

Please check it



The Enterprise messages was blank and still is!!! 


Geez!!!


Hope I'm not confusing anyone with all this;  I just thought it may help someone sort all of this out in the future.  The response that were posted here were close to the mark I thank you for them.


Mark

Steve Burdick Thu, 12/08/2011 - 20:56
User Badges:

Switching Enterprise Parameter -> Services Provisioning to "Both" solved the problem for me too. Ironically, I'm using "Internal" with nearly identical settings in other clusters, and this is the first occurance of the problem.

robloeber Mon, 12/27/2010 - 14:11
User Badges:

Any update on this?  I just discovered that I have the same issue going on.  Only thing is, our system is completely independant of DNS.  Running version 8.0.2.

dijohn Mon, 12/27/2010 - 16:27
User Badges:
  • Cisco Employee,

With Services Provisioning set to Internal, the  phone will receive its subscribed phone services from the phone's  configuration file and store these (and their corresponding service  URLs) in flash. This allows the phone to access the service URLs  directly on a web server without first querying the Cisco CallManager IP  Phone Service. With Services Provisioning set to Internal, the  Corporate and Personal Directories default services also have an extra  level of redundancy built into the phones. When these services are  selected, the phone will attempt to send an HTTP message with the proper  URL string to the Unified CM with which it is currently registered.  Therefore, the Unified CM Group configuration of the phone's device pool  provides redundancy for these services.


With Services Provisioning set to External URL when a user presses the Services button, an HTTP GET message is sent  from the IP Phone to the Unified CM getservicesmenu.jsp script by  default (step 1). You can specify a different script by changing the  Phone URL enterprise parameter. The getservicesmenu.jsp script returns  the list of phone service URL locations to which the individual user has  subscribed (step 2). The HTTP response returns this list to the IP  Phone (step 3). Any further phone service menu options chosen by the  user continue the HTTP messaging between the user and the web server  containing the selected phone service application (step 4).


This is from the SRND http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/8x/cmapps.html#wp1184498


Let me know if this answers your question.


HTH


PS: Rate the post if it helps

robloeber Mon, 12/27/2010 - 16:38
User Badges:

It certainly helps having that information but I think I should have clarified my issue.  It was brought to my attention today that the corporate directory wasnt working.  The first thing I did was check the directory on my phone (9971) and it came up fine.  Next I checked on my 6941 and it came up fine. Then I checked on multiple 7941's and they are getting "host not found".  The only thing we changed in the week was adding third part certificates to our CUCM cluster for tomcat.  The directory and service URLs in Enterprise Services are all correct.


I guess I am searching for why this just started happening out of the blue and what else there is to check?  Seems like the concept is simple enough...

dijohn Mon, 12/27/2010 - 16:59
User Badges:
  • Cisco Employee,

Can you collect the console logs from a non-working 7941.


Just to be sure, you are not using DNS right?. Can you also collect a wireshark packet capture from the 7941. SPAN or SPAN to PC ==> YES on CUCM.


Follow the procedure from this post


https://supportforums.cisco.com/docs/DOC-14178


HTH


PS:Rate the post if it helps.

Joseph Martini Tue, 12/28/2010 - 03:28
User Badges:
  • Cisco Employee,

Going back to my earlier post, since the tomcat certificates have been changes the Trust Verification Service (TVS) in 8.x will come into play as with any phone service in CUCM 8.x using HTTPS to validate the certificates.  The certificates are not stored on the phone so when the phone makes an HTTPS request, and it's presented with a certificate the phone queries TVS to see if it can trust the certificate based on what call manager trusts.  The call manager will reply with an accept or deny for the certificate, if it's an accept the phone will connect using HTTPS.  The host not found many times is the TVS entry in the config file.  If you download the config file for the non working phone and look for the TVS entry you'll either see a hostname or IP address.  Host not found usually indicates that the TVS entry is a hostname.  This is populated from System > Server.

robloeber Tue, 12/28/2010 - 06:46
User Badges:

I will check that out this AM and post back.  Thanks for the comments everyone!

robloeber Tue, 12/28/2010 - 06:58
User Badges:

EDIT:  Restarting the Cisco Tomcat service corrected the issue.


Thanks again for everyones input.  It is most valuable to me!

douglasparsons Wed, 06/22/2011 - 16:00
User Badges:

There is one more item to look at that can cause the "Host not found" as well as a loss of ring tones on version 8.6 and later. I am not sure which version this started in but I believe it is with 8.5 that the phones started using the configuration file for the URLs to look up services. It also used the locale file to confirm the certificates. If there is "ANYTHING" that is out of place with the certificates on the servers it can cause this process to fail and the error to occur. In my case during a rehost of my servers I was forced to reload the subscriber to get the cluster working and the database to sync. In the process the servers had created some self signed certificates. My servers originally had third party certs from our internal CA server. When I finally found this thread it got me looking at the phone logs and I could see the cert validation failures. Looking at the certificates there were several for tomcat-trust issued to the server name. The self signed cert was there along with the third party cert. To fix my system it was a matter of deleting the self signed certificates for the services that I had issued third party certificates for. After a reboot all was well (at least so far). The directory now works as well as the custom ring tones have returned.

chingkiatlee Sat, 04/14/2012 - 03:27
User Badges:

If running on the CUCM 8.x version, because on the "Prepare Cluster for Rollback to pre 8.0 Required Field".

Need to set false, else the Https request wont work

thierry.berwart_2 Tue, 06/26/2012 - 02:06
User Badges:

Hi,


Do you know if this new mecanism "Services Provisioning" (set to internal) is phone depending ?

We have a lot of 7940G here and I wanted to know if it should work with this type of phone ? (firmware P0030801SR01)


Thanks you in advance,

Thierry

chingkiatlee Sun, 04/15/2012 - 19:21
User Badges:

Hi ma75,


Ya, by default i have use the IP Address instead of the DNS.

But the problem still same.

Ayodeji Okanlawon Tue, 10/09/2012 - 04:28
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

CK,


Your best bet is to use a tftp to download the phone configuration file. You can attach it here and we can look at it for you.

Use the command below:


tftp -i 10.1.1.1 get SEP0000DEADBEEF.cnf.xml


where 10.1.1.1 will be changed to your cucm tftp server and the sep0000XXX wil be your phone mac

Please rate all useful posts


"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

rifthy822 Thu, 03/20/2014 - 13:43
User Badges:

I have the same problem but I am using CCM 8.5, but my problem appeared all of a sudden. It was working fine till yesterday. Now I get host not found when I select corporate directory on my cisco 7942. 

 

Any body has any idea? 

Sean_edwards Wed, 08/17/2016 - 06:35
User Badges:

Deleting ITL and CTL files from  phone and resetting fixed issue for me

Actions

This Discussion