n00b-How to config multilink to single link on 2801 router

Unanswered Question
Nov 23rd, 2010
User Badges:
Hello everyone,


disclaimer...n00b


One of our remote offices is going from a multilink (3xT1s) to a single link T1 configuration. The router was originally setup by our network ops guy (who's no longer with us, nor reachable) and we have no idea how to change the configuration. The router is a 2801 running version 12.4(1c)


Dont know of this additional information matters, but this child domain is part of an mpls network.


I am pasting the running config in hopes that someone can help me or guide me in the right direction.  Let me know if you need additional info.


Thanks again.


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 2801ROUTER
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret
enable password
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
!
!
!
!
interface Multilink1
description internet via PROVIDER
ip address OUR.EXTERNAL.IP.ADDRESS 255.255.255.252
no cdp enable
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.201.12.1 255.255.252.0
speed auto
half-duplex
no mop enabled
!
interface Serial0/1/0
description MLPPP
bandwidth 1536
no ip address
no ip redirects
no ip proxy-arp
encapsulation ppp
tx-ring-limit 26
tx-queue-limit 26
no fair-queue
no cdp enable
ppp multilink
ppp multilink group 1
!
interface Serial0/2/0
description MLPPP
bandwidth 1536
no ip address
no ip redirects
no ip proxy-arp
encapsulation ppp
tx-ring-limit 26
tx-queue-limit 26
no cdp enable
ppp multilink
ppp multilink group 1
!
interface Serial0/3/0
description MLPPP
bandwidth 1536
no ip address
no ip redirects
no ip proxy-arp
encapsulation ppp
tx-ring-limit 26
tx-queue-limit 26
no cdp enable
ppp multilink
ppp multilink group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
!
ip http server
!
dialer-list 1 protocol ip permit
!
control-plane
!
banner login ^C ^C
banner motd ^C
***************************************************************
NOTICE: This system is the property of the company,
and is for authorized use only. Unauthorized access is
a VIOLATION of FEDERAL LAW. All software, data transactions,
and electronic communication are subject to monitoring.
***************************************************************
^C
!
line con 0
password
login
line aux 0
line vty 0 4
password
login
!
end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gatlin007 Tue, 11/23/2010 - 16:59
User Badges:
  • Silver, 250 points or more

This should work out for you:


default interface ser0/2/0


default interface ser0/3/0


default interface ser0/1/0


no int mul 1


### If using ser 0/1/0 as surviving T1


int ser 0/1/0
description internet via PROVIDER
ip address OUR.EXTERNAL.IP.ADDRESS 255.255.255.252
no cdp enable
no ip address
no ip redirects
no ip proxy-arp
encapsulation ppp
tx-ring-limit 26
tx-queue-limit 26
no fair-queue
exit

ceezr1997 Tue, 11/23/2010 - 20:11
User Badges:

Thank you for the reply Christopher.


Now for cli command questions.


I am assuming I go to config t and then config int serial 0/#/0


then under each serial I type the commands you replied with:


default interface ser0/#/0


after they are all set to default I go back to serial0/1/0


and type all the commands provided:


description internet via PROVIDER
ip address OUR.EXTERNAL.IP.ADDRESS 255.255.255.252
no cdp enable
no ip address
no ip redirects
no ip proxy-arp
encapsulation ppp
tx-ring-limit 26
tx-queue-limit 26
no fair-queue
exit


This is a remote site, can we do this remotely via terminal services/telnet or do we need to be on-site to perform this operation?  Will setting the serial connections to default kick us off?  Internet connectivity lost?


One more thing, why are the interfaces listed like this:  #/#/# instead of just 0/1, 0/2 or 0/3


Thank you for your help

Richard Burts Tue, 11/23/2010 - 21:28
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cesar


Yes you start with config t and then enter the commands.

The command default interface serial 0/#/0 is entered in global config mode and not necessarily in interface config mode.

One correction - do not put this command into the config of the serial interface no ip address

That command would mess things up - especially if you input it after you input the command to assign an IP address to the interface.

These commands are not needed on a serial interface, but they do no harm if you decide to leave them

no ip redirects
no ip proxy-arp


With a remote site you are able to change many things in the config while in a telnet session to the remote site. But when you are changing the interface which provides remote connectivity it is safer to be on site for that.


Interface numbering like 0/1 0/2 0/3 works fine if all you need to identify is the card and the slot in the chassis where the card is inserted. But on your serial cards you need to specify the card, and the slot, and the port on the card. This is why they are numbered like 0/1/0


HTH


Rick

ceezr1997 Wed, 11/24/2010 - 09:37
User Badges:

ok, all points taken.  seems easy enough to do.


sorry but I have a follow up, can we do this before our ISP does the change or can we have this already prepared so when we go to a single T1 the router is already up and running?


and what would happen if we left the multilink?  I would assume that only the 1wic with the active t1 would work and provide net services, am I assuming wrong?


thanks.         

Richard Burts Wed, 11/24/2010 - 12:01
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cesar


You probably could make the changes on your end before the ISP makes their changes. And you certainly could have this prepared ahead of time so that applying the changes to your router would be easy and quick.



Before I go further into explanations there is one thing that needs to be clarified. You currently have 3 T1s in a multilink, and the result after changes is to have a single T1. But please explain to us how the changes will take place. Is the final single T1 going to be one of the existing T1s (just take it out of the multilnk) or is the final T1 to be a different/new T1 (provision a new T1 from the same provider or provision a new T1 from a different provider)?


Right now you have 3 serial interfaces which are logically bundled together into the multilink. One of the things that you are doing as you make your changes is to take at least one of the serial interfaces out of the multilink. Once the serial interface is no longer in the multilink you can configure it to operate independently of the multilink.


There are a couple of variables about whether you can leave the multilink after the change. If the new serial link is to use the same IP addressing as the multilink (which was the assumption in the configuration being suggested) then you would have to remove the IP address from the multilink so that it does not duplicate the address used on the new serial lnk (single T1). Other than that I see no reason you could not leave the multilink if you want.


HTH


Rick

ceezr1997 Mon, 11/29/2010 - 11:02
User Badges:

Rick, thank you for the detailed reply, to answer the Q's; yes, we are

keeping the same ISP, they are just removing two of the T1's and leaving us

with a single T1 using the same IP address.

Now for an additional questions that I dont know if the ISP answers this,

but how would we know which serial interface is the one that's going to stay

functioning with the T1? Do we just leave for example serial0 plugged in and

assume that 0 is the one that the live T1 is going to feed through?



On Wed, Nov 24, 2010 at 3:01 PM, rburts <

Richard Burts Mon, 11/29/2010 - 12:53
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cesar


While it would be possible to have most of the changes made remotely and ahead of time (taking one serial out of the multilink bundle, configuring appropriate parameters on that serial, etc) and to make the last change (moving the IP address from the multilink interface to the serial interface) just as the ISP is ready to make changes, I believe that the optimum and safest approach is to have someone on site to make changes coordinated with the ISP while they make changes. The first approach assumes that all changes made are made correctly and leaves no good way to recover from an error (or misunderstanding) in the configuration changes.


Note that if the new single T1 connection is to use the same IP addressing as the multilink then the address can not be moved to the T1 till the ISP is really ready to make their changes.


It is an interesting question about which T1 will be the one that remains active. It could be any one of the 3. You should ask the ISP about this. They may give you a choice and let you choose which one. Or they may have decided which one and should be able to tell you if you ask.


If you decide to try making the changes ahead of time I do have one suggestion to make. Before you start making changes be sure that there is a fresh copy of the config stored in startup config (and it might be beneficial to make a copy of the config on the hard dive of your PC as well). And then before you start making changes schedule a reload for after the change is scheduled. You can use the command: reload in or the command reload at to schedule the reload. Schedule the reload for a comfortable time after the ISP changes are scheduled to be complete. And be careful that you do not save the changes after you update the config. If something goes wrong and the remote site loses connectivity then the reload will discard all changes and will return the router to a state that was working. If you reload and if the ISP undoes their changes then the remote should have connectivity again - and you can try the changes again, after you have figured out what went wrong.


HTH


Rick

Actions

This Discussion

Related Content