Outbound call doesn't disconnect after call end

Unanswered Question
Nov 25th, 2010
User Badges:

Have you ever seen something like it:

I make a call from my ip phone (3911 or 6921) to an external phone (ex: cell phone: 084645727) and the call works fine, but when cell phone turned off the call, on my ip phone the call still connected,  ip phone  show me on display that the call still active, the call is just disconnect when I put the phone onhook.

I use CUCMBE: 7.1.3(SU2)

Cisco 2821 : c2800nm-spservicesk9-mz.124-20.T4.bin

debug vpm signal

BHEGV1#R2 Got Event R2_ALERTING

*Nov 25 07:42:36: show voice call status

CallID     CID  ccVdb      Port             DSP/Ch  Called #   Codec    Dial-peers

0xD8803    20E8 0x48177B78 0/1/0:0.3        0/1:1  *2125463737 g711ulaw  7500/40

0xD8847    1C9D 0x48177B78 0/1/0:0.1        0/1:3   7434       g711ulaw  1/7500

0xD88B2    26E8 0x48177B78 0/1/0:0.28       0/1:5  *087068998  g711ulaw  7500/30

0xD88B6    27E8 0x48177B78 0/1/0:0.27       0/1:2  *084645727  g711ulaw  7500/30 (it is my call)

0xD88BD    1D22 0x48177B78 0/1/0:0.2        0/1:4   7491       None      1/7500

0xD88C0    28E8 0x48177B78 0/1/0:0.22       0/1:6  *084743874  g711ulaw  7500/30

After cell phone turned off the call, the debug vpm signal just show me it:

*Nov 25 07:42:50: htsp_process_event: [0/1/0:0(27), R2_Q421_OG_ANSWER, E_DSP_SIG_1100]

Does anybody could help me !

Regards.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
gogasca Mon, 11/29/2010 - 11:37
User Badges:
  • Green, 3000 points or more

Ola Evandro


Who is your Service provider?

Please try this config I have for Embratel


controller E1 0/1/0
framing NO-CRC4
line-termination 75-ohm
ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

  metering     
  country brazil
  double-answer
  disconnect-tone
  category 2
  answer-signal group-b 1
  dnis-digits min 4 max 16
  ani-digits min 4 max 16
  dnis-complete
  trunk-group outgoing
description PSTN-Embratel


If Not Embratel I may be able to find something in particular for your Provider in Brazil


Muito obrigado

evandro.nunes Tue, 11/30/2010 - 07:36
User Badges:

Hi Gogasca


My service provider is Oi (Telemar).


An interesting thing is that this issue just happen when i place a call from my ip phone to PSTN, when i receive a call from cell phone and cell phone disconnect the call, it works fine.


Are you from Brazil ?

giliardy01 Thu, 06/22/2017 - 13:25
User Badges:

Olá pessoal !

Estou com este mesmo problema de não desconectar a chamada. (EMBRATEL e OI ).

Meus roteadores já estão na Versão 15.0

Alguém conseguiu uma solução ?


Agradeço !

Rafael A Souza Thu, 12/06/2012 - 04:35
User Badges:

Hi, I´m facing the same problem with the service provider Oi, could you help me with this case.


Thanks.

paolo bevilacqua Thu, 12/06/2012 - 05:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Are you using FXO or E1 R2 ?

Rafael A Souza Thu, 12/06/2012 - 05:35
User Badges:

I´m using E1 R2


Follow my controller configuration:


controller E1 1/1

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country brazil

  metering

  release-ack

  category 2

  answer-signal group-b 1

description OI (OUTGOING&INCOMING)

paolo bevilacqua Thu, 12/06/2012 - 05:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try the following and confirm if it happens:


Test 1: Outside phone calls CM phone. Answer, talk, then outside phone hangs up. CM phone also disconnects.


Test 2: CM phone calls the outside phone, Answer, talk then outside phone hangs up. CM phone still show conneected.


This happens because some telco only allows the calling party to disconnect, and CM cannot do anything about.


The solution is that when conversation endse, user manually hangs up CM phone.

paolo bevilacqua Thu, 12/06/2012 - 05:46
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

bruno rangel wrote:


Hi All

I had this issue with Oi and EBT, not sure if this is the same, but i had an issue where the Voice channel in clearfwd - I was facing the Bug CSCtd74470">CSCtd7447, there a workaround but the upgrade of the GW to Version

That is not a valid bug ID.

Bruno rangel Thu, 12/06/2012 - 05:49
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Hi Paolo did you mean not valid for this case right?



Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

paolo bevilacqua Thu, 12/06/2012 - 05:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Found it, it's CSCtd74470">CSCtd74470


However it doen 't seem to match the case, for which I've indicated the most likely cause above.

Bruno rangel Thu, 12/06/2012 - 06:21
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Thanks, I just edit my post (+5)



Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

Rafael A Souza Thu, 12/06/2012 - 05:47
User Badges:

Hi Bruno, I think it´s not my case because I´m using the version 15.1(4)M.


But I ´will try to use the command you suggested.


Thank you.

Bruno rangel Thu, 12/06/2012 - 05:39
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Hi All

I had this issue with Oi and EBT, not sure if this is the same, but i had an issue where the Voice channel in clearfwd - I was facing the Bug CSCtd74470, there a workaround but the upgrade of the GW to Version 15 works properly, the output of the "sh vo po sum | include clearfwd" will confirm if this is your case.


Also in others situations I solved my issue applying the command timeouts call-disconect 3, under E1 Port


Please rate this post


Cheers
Bruno Rangel

"Se você quiser alguém em quem confiar, confie em si mesmo. Quem acredita sempre alcança"
Renato Russo

Actions

This Discussion