CP-7942G displaying wrong time, CME 8.1

Answered Question
Dec 10th, 2010

CME 8.1  - IOS ver 15.1(2)T1 - All IP phones (type 6921, 7962) are showing the correct time (according to the time zone) except the  7942G (it shows the GMT time without the zone from the router or from the telephony service applied). On the 'Device Information' the phone does not shows any time zone although the time-zone command under telephony-service is there.

cnf-file location flash:
cnf-file perphone
load 7942 SCCP42.8-4-4S

load 6921 SCCP69xx.8-5-3-0
time-zone 30
time-format 24
date-format dd-mm-yy

MAC Address18EF639E4723
Host NameSEP18EF639E4723
App Load IDjar42sccp.8-5-4TH1-6.sbn
Boot Load IDtnp42.8-3-1-21a.bin
Hardware Revision11.0
Model NumberCP-7942G
Cisco Unified IP Phone 7942G, Global
Time Zone
I have this problem too.
0 votes
Correct Answer by Ayodeji oladipo... about 4 years 11 months ago


Do you have the type command set under the ephone for the 7942..??

eg..ephone 1

mac xxx.xxx.xxx.xx

type 7942...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
rob.huffman Fri, 12/10/2010 - 05:52

Hi kholevas,

This is not an uncommon issue that should be quite fixable

Troubleshooting Incorrect Time Stamp on IP Phones in Cisco Unified CME


After changing the time-zone setting you could follow these steps.

Usage Guidelines

This command works with the vendorConfig section of the Sep*.conf.xml configuration file, which is read by the phone firmware when the Cisco IP Phone is booted up. Certain phones, such as the Cisco Unified IP Phone 7906 , 7911, 7931, 7941, 7942, 7945, 7961, 7962, 7965, 7970 , 7971, and 7975, obtain Coordinated Universal Time (UTC) from the clock of the Cisco router. To display the correct local time, the time display on these phones must be offset by using this command.

This command is not required for Cisco Unified IP Phone 7902G, 7905G, 7912G, 7920, 7921, 7935, 7936, 7940, 7960, or 7985G.

For changes to the time-zone settings take effect, the Sep*.conf.xml file must be updated by using the create cnf-files command and the Cisco IP phones must rebooted by using the reset command.


under the telephony-service -

no create cnf-files

create cnf-files

Then reboot the individual phones



kholevas Fri, 12/10/2010 - 06:04

Hi Rob,

Thanks for your answer. I've been working with the problem for hours and i think i went through all of the steps but the 'wrong time' is still there. Any idea what to check?

rob.huffman Fri, 12/10/2010 - 07:32

Hi kholevas,


Have you tried reloading the router?



Correct Answer
Ayodeji oladipo... Fri, 12/10/2010 - 07:58


Do you have the type command set under the ephone for the 7942..??

eg..ephone 1

mac xxx.xxx.xxx.xx

type 7942...

kholevas Sun, 12/12/2010 - 23:10


After all those changes, restarts, removes etc the phone type were not on the ephone config !!!!

Thank you very much.

Ayodeji oladipo... Tue, 07/12/2011 - 07:09

You need the "type 79XX" where XX=the phone model. You need to configure thi son the ephone configuation in CCME

ephone 1

mac xxx.xxx.xxx.xx

type 7942

saadiqbal Mon, 04/28/2014 - 04:18

the command type 7942 worked for me!!! hurrah!!!!!! thanks!!!

Marcos Eusebio ... Fri, 07/25/2014 - 08:08

I had a similar issue; in a CME version 7 I did the follow:


1.- configure time-zone GMT -6 an "sumertime recurring" on global configuration

2.- Configure time-zone at "telephony service" proccess

3.- save configuration

4.- erase cnf-files

5.- create cnf-files again

6.- restart phone

At this, issue still occur; but -after all- with a factory resset the telephone has the correct time on it's display


Pavel Rostovcev Thu, 04/23/2015 - 01:19

Hello. I have CME 8.6 and was problem with phone 7942 7961:


1. cnf-file location flash:

2. time-zone change

3. cnf-file perphone

4. no create cnf-file

5. create cnf-file

6. restart phone.



This Discussion

Related Content