Error: Failed to load script file; java.lang.ArrayIndexOutOfBound.Exception: 3184

Unanswered Question
Dec 14th, 2010

Script editor was working find when I last used it last week.  Tried to open a script today to make some changes and now I'm getting this error message.  I have uninstalled and re-installed editor, checked the compatibility mode and it wont open the script.  any ideas out there what the problem could be? need some trouble shooting help.

Error:

failed to load script file: java.lang.ArrayIndexOutOfBound.Expception: 3184

Thanks

Lora

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
cmcglamry Tue, 12/14/2010 - 19:11

This is usually caused by a JRE mismatch.

Open the windows control panel and find the Java icon.  Select the Java tab, and then hit the view button. This will let you see what version you're running.

In the event of an issue like this, it's a good idea to roll back to a known working version.  Version 6.0.12 is a pretty safe bet.

Check this and let us know.

Cliff    

lmrscheff Wed, 12/15/2010 - 08:20

Hey Cliff,

No go, I have uninstalled and re-installed Java 4 times with the version you suggested still getting the same error message. Any other trouble shooting ideas??

Thanks

cmcglamry Wed, 12/15/2010 - 09:11

Couple of questions:

1.  Do all scripts through this error, or just one script?

2.  Is this happening on your workstation where you have the CRS editor installed AND on the server console?

lmrscheff Wed, 12/15/2010 - 09:22

I am on a VPN to client site, When I try to open script from server I get this error message on all of the scripts.  Script Editor opens but script never opens.

So happening on Workstation wher CRS is loaded

Happening from the Script Application

I'm unable to RDP to this server it is Linux based

cmcglamry Wed, 12/15/2010 - 09:36

The script opens with no problem for me.  I'm using editor version 8.0(1.1).  You could be experiencing something where the VPN SA may be blocking some port you need.

I have noticed that the version 8 editor is much "clunkier" than previous versions.

Can you get the editor to start in stand alone mode on your PC?  If so, can you create a basic script in it?

If you can get it open and running in stand alone mode, you can (with it running that way) try opening the script from the server via the appadmin interface.  You won't be able to save it back via the editor, but could save it to your desktop and upload it back via the appadmin interface.

Give it a shot and let me know.

Cliff    

lmrscheff Wed, 12/15/2010 - 11:41

Hey Cliff,

Ok I tried opening in Stand Alone mode.....Editor opened tried to create a new script and got this Error:

Java.lang.ExceptionInInitializerError

Ok I know this means Java is all screwed up but dont know how to fix it.  Have you seen this one before??

cmcglamry Wed, 12/15/2010 - 11:48

Hmmm....   I haven't seen that, but I can tell you what I would do if I were you.  This is kind of drastic, but the alternative may be a workstation reimage.

Open the windows control panel, and open the add/remove programs snap in.

Uninstall the CRS editor.

Uninstall all the JRE instances you have.  They may be listed as something like Java (TM) update....   or they may appear as J2SE Runtime....   Check in the J's (it's alphabetical) and uninstall all of them.

Reboot the machine.

Download and reinstall Java 1.6.0.17   (This is what's running on my workstation right now, and it works with the editor).

Reinstall the CRS editor

Reboot the machine

Try it and see if it behaves.  If it doesn't, you may need to rebuild the whole thing.

Actions

Login or Register to take actions

This Discussion

Posted December 14, 2010 at 12:32 PM
Stats:
Replies:9 Avg. Rating:
Views:1089 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard