stcapp application state is inactive HELP!

Answered Question
Dec 15th, 2010

Hi All,

Trying to setup FXS port for an analouge phone.

Can call out from the phone, but get a 'busy' tone when calling in from anywhere.

Show stcapp device summary shows;

stcapp application state is inactive.

I cannot find a reference to this error anywhere on google, and have followed the cisco docs to set the STCAPP voice-port/ephone/ephone-dn/stcapp config up.

I have checked my config againt countless other configs and see no difference.

I cannot find any cisco docs relating to having to 'install' stcapp, nor anywhere i can 'start' the service.

Platform is UC560 running the following revisions;

#show telephony-service
CONFIG (Version=8.0)
=====================
Version 8.0

#show hardware
Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 15.0(1)XA2, RELEASE SOFTWARE (fc2)

Any help at this point woud be much appriciated!

I have this problem too.
0 votes
Correct Answer by mikewyzo about 3 years 4 months ago

I have seen that before.  What worked for me was while in config mode, type in stcapp and hit enter.  Seems to start a service or something.  Hope it helps.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
mikewyzo Thu, 12/16/2010 - 11:24

I have seen that before.  What worked for me was while in config mode, type in stcapp and hit enter.  Seems to start a service or something.  Hope it helps.

Steven DiStefano Thu, 12/16/2010 - 12:21

Cue in sound of horses trampling in (like in Brave Heart) to save the day?

The SCCP Analog Phone window appears when you choose Troubleshoot >  Telephony Diagnostics > SCCP Analog Phones.

Feature access codes enable users of SCCP-controlled analog phones to be  able  to access certain phone features by dialing codes (for example, **1 to  set Call  Forward All on the phone).

When the UC500 device is in factory default configuration, the voice  initialization  process removes the stcapp feature access-code command.

From this window you can enable or disable stcapp feature-access  codes.

  • When Enable  stcapp feature access codes is unchecked, feature access  codes are configured through the fac commands  under telephony- service only. This is the recommended setting.
  • When Enable  stcapp feature access codes is checked, the stcapp feature access-codes command is configured in addition to the fac commands under telephony-service. However, enabling this setting results   in conflicts among feature codes, since codes 5, 6, 7, and 8 are  configured  differently by these commands. The output of the following show  commands illustrates the conflict.
mcasimirc63 Fri, 12/17/2010 - 07:18

Did you use CCA or CLI to enable STCAPP?  If you did it through CLI you would need to configure a SCCP CCM group and add the UC500 as one of the available gateways.

To configure it through CLI do the following

sccp local FastEthernet0/1
sccp ccm 192.168.1.1 identifier 10
sccp

sccp ccm group 1
associate ccm 10 priority 1
switchback method graceful
stcapp ccm-group 1
stcapp

dial-peer voice 30 pots
service stcapp
port 0/1/0

voice-port 0/1/0
caller-id enable

OR if you use CCA you could just set the FXS port to a User Mode Phone. Ports\Analog Ports.

mattkjohnson Mon, 01/10/2011 - 07:12

Thanks guys,

It was a CLI configured system and for some reason I had 'lost' 'stcapp' on it's own line which disabled the service.

Marcus, I already had all the rest of the stcapp grouping and attachments, but thanks for the detailed post!

Looking through a diff of a previous config highlighted my mistake.

Thanks again.

Matt

Actions

Login or Register to take actions

This Discussion

Posted December 15, 2010 at 8:28 AM
Stats:
Replies:4 Avg. Rating:5
Views:2455 Votes:0
Shares:0
Tags: stcapp
+

Related Content

Discussions Leaderboard