Help configuring LACP on the 6509

Answered Question
Dec 22nd, 2010

Hi,

I am currently setting up a LACP port-channel on the Cisco 6509 (SUP720-3BXL with the following modules:

NAME: "6", DESCR: "WS-X6348-RJ-45 48 port 10/100 mb RJ45 Rev. 6.1"
PID: WS-X6348-RJ-45    , VID:    , SN: XXXXXXXXXXX

NAME: "7", DESCR: "WS-X6548-RJ-45 SFM-capable 48-port 10/100 Mbps RJ45 Rev. 6.1"
PID: WS-X6548-RJ-45    , VID:    , SN: XXXXXXXXXXX

The config:

Building configuration...

Current configuration : 242 bytes
!
interface FastEthernet6/20
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 42,100,101
switchport mode trunk
no ip address
speed 100
duplex full
channel-protocol lacp
channel-group 20 mode passive
end

c6509_testlab#sh run int fa7/20
Building configuration...

Current configuration : 242 bytes
!
interface FastEthernet7/20
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 42,100,101
switchport mode trunk
no ip address
speed 100
duplex full
channel-protocol lacp
channel-group 20 mode passive
end

The switch immediately gives a error message:

2d02h: %EC-SP-5-CANNOT_BUNDLE_LACP: Fa7/20 is not compatible with aggregators in channel 20 and cannot attach to them (qos-disallowed card type combination: Fa7/20 and Fa6/20)
2d02h: %EC-SP-5-CANNOT_BUNDLE_LACP: Fa6/20 is not compatible with aggregators in channel 20 and cannot attach to them (qos-disallowed card type combination: Fa6/20 and Fa7/20)

However, the port-channel comes up but also spawns a secondary interface Port-channel20A.

What I'll like to know is, what does the error message (underlined in red) mean? And is there a way to get rid of the secondary port-channel?

If all it takes is for both cards to be the same model, that would be easy, but if it's configuration related, what should I look out for?

If more information is needed I'll be happy to provide. Thanks in advance.

I have this problem too.
0 votes
Correct Answer by Lei Tian about 3 years 4 months ago

Hi,

Add 'no mls qos channel-consistency' under port-channel; that will ignore the qos capability check across different module.


HTH,

Lei Tian

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
Lei Tian Wed, 12/22/2010 - 03:11

Hi,

Add 'no mls qos channel-consistency' under port-channel; that will ignore the qos capability check across different module.


HTH,

Lei Tian

Actions

Login or Register to take actions

This Discussion

Posted December 22, 2010 at 2:19 AM
Stats:
Replies:1 Avg. Rating:5
Views:1612 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,155
3 7,730
4 7,083
5 6,742
Rank Username Points
140
72
69
65
45