Cisco wireless and Apple Mac woes

Unanswered Question
Dec 23rd, 2010

Hello all,

I've been working with Cisco wireless and WLC's for a couple of years now but the recent onslaught of Apple Mac's is giving me heart burn.  I've seen this at numerous sites now and need to throw it to eht community for guidance.

Basically we have had a number of instances where the Macs just fall off the wifi.  Sometimes it's when they wake from sleep and other times when roaming between AP's (1131s with same SSID's).  Our standard install is WPA2 and per ap local authentication.  PC's work fine and never an issue.

We have completed a survey with a spectrum analyser and no RF interefence is present nor errors on the radio interface.

Questions:

- Is there a preferred Cisco config/setup for Mac's to work reliably?  I've heard loads of rumors but nothing concrete and nor can I find anything specific.

- Should I be setting up WDS in case there is an authenticating issue.

- For those who are Mac gurus and happen to be reading. What Mac options we should look at?

This has all come to a head because the clients IT company who recommended the Macs (different from us doing the network infrastructure) are insisting that the problem is Cisco incompatibility and that we should rip out the Cisco kit and install airports (what tha!!!).

Thanks in advance for any pointers.

For those who like a config here it is .... Vanilla stuff really

Building configuration...

Current configuration : 2236 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AP4

!
no logging console
enable secret xxxxxxxxxxxxxxxxx

!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid Home
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   mbssid guest-mode
   wpa-psk ascii xxxxxxxxxxxx

!
dot11 ssid avnet
   vlan 2
   authentication open
   authentication key-management wpa
   mbssid guest-mode
   wpa-psk ascii xxxxxxxxxxxxxxxx

!
!
!
username abcd password 1234

!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 1 mode ciphers tkip
!
encryption vlan 2 mode ciphers tkip
!
ssid Home
!
mbssid
speed  basic-1.0 basic-2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2412
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
bridge-group 2 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
hold-queue 80 in
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
no bridge-group 2 source-learning
bridge-group 2 spanning-disabled
!
interface BVI1
ip address 192.168.10.54 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.10.1
no ip http server
no ip http secure-server
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4 (2 ratings)
surbg Thu, 12/23/2010 - 05:58

Yeah!! even i have come across multiple issue with MAC and Cisco.. these are the below settings which i normally do on the cisco gears and most of the times this solved the issue..

on the IOS AP disable Aironet Extentions and set the poer local and ofdm to max

no dot11 extension aironet

power local cck max

power local ofdm max

end

On the WLC, disable Aironet IE..

lemme know if this answered your question..

Regards
Surendra
====
Please dont forget to rate the posts which answered your question and mark it as answered or was helpfull

davidfield Thu, 12/23/2010 - 06:21

Thanks Surendra,  I shall set and see what feedback I get.  Did this solve the problem for you?

surbg Thu, 12/23/2010 - 06:37

Yes most of the time this resolved the issue.. You can check it out..

lemme know if this answered your question..

Regards
Surendra
====
Please dont forget to rate the posts which answered your question and mark it as answered or was helpfull

Actions

Login or Register to take actions

This Discussion

Posted December 23, 2010 at 5:38 AM
Stats:
Replies:5 Avg. Rating:4
Views:3176 Votes:0
Shares:0

Related Content

Discussions Leaderboard