Unable to connect from Putty to Cisco Switch

Unanswered Question
Jan 9th, 2011

Greetings, I'm trying to connect via serial to rj-45 to a Cisco Switch.  I'm using the following:

-Windows 7 Professional computer that has a serial port

-Putty software

-serial to rj-45 cable

-Cisco Catalyst 2900 series XL switch

My Putty settings are the following:

serial line com3

speed 9600

data bits8

stop bits 1

parity none

flow control none

I've tried to connect the RJ-45 to both the console connect and a port on the front and still not able to get a CLI.

I did find this example on youtube


He is using com3, where as Windows 7 Pro defaults to com1 and I'm not sure why he is using com1 or how to change it on the Windows side to com3.


I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
cadet alain Sun, 01/09/2011 - 12:28


Are you using console cable(rollover cable)?

if so then you must connect to console port, it won't work on switch port.

You can try COM3,COM1, and so on by changing in Putty.



anthonyg2879 Tue, 02/03/2015 - 10:16

During the present time, many laptops no longer have serial ports on them so the USB to Serial adapters are needed. Someone told me one time that they were able to telnet into the LAN port of the router to get in and make minor changes on the WAN interface. Has anyone tried and knows the steps to that?

Ex, lets say you have a simple Cisco 1921 router with two physical ports, ge0/0 and ge0/1.

ge0/0 is connected to the ISP dmarc and ge0/1 will be the LAN port.

If you know the address of the ge0/1,, can u launch PUTTY and telnet to that IP to get into the router and make a speed and duplex change to ge0/0 or see the status of the port?

You would also set the IP of your laptop to

I heard this could be a work around for those not having console <rollover> cable or proper USB to serial adapter.

Has anyone tried this method and have the proper steps?

hobbe Mon, 01/10/2011 - 00:50

You have windows 7.

Go to

Control panel -> system  to check what serial ports you have (com) and that it is enabled.

if you have usb <-> serial port

Then it can set basically any serial port for the one you are using.

Mine normally starts around 20 something nowdays.


Good luck

tonyspcrepairs Mon, 01/24/2011 - 09:03

I use putty too but my flow control is set to XonXoff and it works. I have Win7 64bit and a serial port connection. Com3 doesn't sound right. If you have a real serial port it's usually com 1. There's always the slight possibility the cable is faulty (?) have you tried the cable on a different computer/router?

Leo Laohoo Mon, 01/24/2011 - 12:51

If you are using a USB to Serial port adapter, check your Device Properties.  The USB moves the COM port around.

microfeel Thu, 03/15/2012 - 06:49

1. Find out port com number in device meneger. There must'n be conflicting devices by IRQ. Use some port in putty.

2. Hit enter key twice. You will see promt.

3. Check your config. This port don't have to be disable. Enable by default.

sdiegel1974 Thu, 04/23/2015 - 08:01

Hitting the enter key twice did it, something so simple.



Oleksandr Nesterov Thu, 03/22/2012 - 08:11

What is the current purpose?

To get serial adapter working on win7 or to access to the switch?

If you need to access the switch:

1.  try to search for another pc (would be great if it will have built-in  serial port) either linux (there you'll be able to run minicom) or  windows xp (try first hyper-terminal instead of putty just to see  whether it will work).

2. if you'll use adapter -

  a) check the drivers for it - and install correct ones

  b) every time you connect  it - check device manager for com port number - it changes.

3.  is the switch new - out of the box or was preconfigured - sometimes  people who started to read CCNA course likes to change terminal speed -  in such cases try different speeds for example 11500

4. do you hear how switch is working when you power it on - may be it's not functional.

5. try to replace your console cable - maybe it's broken

6. do you see anything in your terminal software when you connect to the console port of the switch?



zoltanszasz Mon, 03/26/2012 - 15:54

Did anybody think that the switch console settings are messed up? Try different speeds on your emulator and see if you get any output. , 2400 , 4800,9600,19200, etc Also try first steps of password reset procedure to try to get to ROMMON.

Ravi Singh Sun, 06/02/2013 - 20:42

I think you are using USB to serial convertor and if it is so please check which com port it is using. To do this follow the below stapes

1. Press window+R key

2. Type devmgmt.msc

3. Go to Ports

Now check which port is assigned to USE to serial convertor and use the same in putty.

And if it still not work please reinstall your driver software.

david_morganl Sat, 10/12/2013 - 12:41

Hey there,

I have this same issue (I think)!

I have 3 2950 switches, just updated them all to the new IOS to support ssh, just for practice lab stuff and general day to day messing with.

I have 1 console cable which works perfectly fine (tested to work on all three switches and uses COM port 3 (mabye because its a laptop))

2 out of 3 switches work perfectly

The one that does not work, here is what has happened;

I was creating seperate Vlans for seperate ports using a serial connection through Putty, I assigned the only port in use onto Vlan 2 then there was nothing....

just stopped displaying output.

I have tried changing console cables for the sake of it but its not that, Ive swapped out the power cables but still no avail.

When I use the serial port to connect to the other 2/3 switches it works fine and Putty works as expected

When trying to connect through serial, telnet, ssh into this third switch there is absolutly no output, just the flashing green cursor.

There are also no abnormal lights on the unit, the syst light and stat light are solid green!

Any help please!!



This Discussion

Related Content