AbbrDial CME 7 and 7937 Phone

Unanswered Question
Jan 12th, 2011

When we try and use the abbreviated dial feature on the 7937 conference

phone we are getting strange results as far as what the phone is dialing.  For example

under telephoney service we have directory entries for the end users to dial.

directory entry 49 817805551234 name John Doe

directory entry 50 815085559876 name Jane Doe

directory entry 51 84035558765 name Sam Doe

directory entry 52 817805557654 name Dave Doe

When we press 49 and then hit AbbrDial on the 7937 phone the phone tries to dial

84197805551234

When we press 52 and then hit AbbrDial on the 7937 phone the phone tries to dial

85127804378354

For some reason the 7937 phone is injecting the entry number in the dialed digits.

From the 7942 and 7962 phone we are able to successfully use the AbbrDial softkey.

I have tried different firmware on the 7937 phones thinking this might be related to that but i get the same results.

I have also read through the administration guide for CME and I did see the following but I find it hard to believe that AbbrDial is only supported on the models listed.  Also it works on my other phones which are not listed 7941, 7942, 7961, 7962.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmespeed.html#wp1010702

On-hook abbreviated dialing using the Abbr soft key is supported only on the following
phones:

–Cisco Unified IP Phone 7905G
–Cisco Unified IP Phone 7912G
–Cisco Unified IP Phone 7920G
–Cisco Unified IP Phone 7970G
–Cisco Unified IP Phone 7971G-GE

Has anyone else run into this issue with CME and the 7937?  I can post the config of my CME if that would help.

thanks,

cj

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
gmgarrian Wed, 02/08/2012 - 08:52

I have this same issue on a 7937 on a UC540.  I have 11 directory entries (numbered 1 though 11) and 1 through 8 work fine.  9 dials a different number as you describe.  10 and 11 give a fast busy.

I've upgraded the firmware to the latest, 1.4(4) with no change. 

I'll probably open a case on this after I take care of some other things.  I'll post my findings.

Did you ever find a solution?

cjoseph23 Wed, 02/08/2012 - 10:51

Hello,

I actually created a TAC case about this issue a while back and they informed me that abbreviate dial is not supported on the 7937.

I thought that was kinda of ridiculous but that is what they said.  I never did find a solutions for this.

Sorry about that.

Regards,

Cyril

kennyhon99 Sun, 10/07/2012 - 19:31

Dear All,

After enable directory entry into my CME 7.01, when i dial 11 and then abbrdial button, Our 7937 cisco phone also got the same error cannot dial correct no. The 11 will be put it in my preset dial.

Is it true that abbrdial don't support Cisco phone 7937? Is there any walkaround solution?

Thanks

Kenny

cjoseph23 Mon, 10/08/2012 - 11:47

Kenny,

I checked the notes from my previous TAC case.  According to the TAC engineer I worked with abbrdial is not a function which is supported on the 7937 phones.  I didn't spend much time after that trying to get it to work.

It has been a while since i have been to this client - but If i remember correctly we created 4 digits num-exp on the CME router which would translate the digits to the numbers we wanted.  For instance

num-exp 4444 918005532447

so that if someone dialed 4444 the router would translate the number and that matches a dial-peer which sends the call out the PSTN.  This worked for what they were trying to accomplish.

Also this client ended up migrating from CME to business edition CUCM so we started using 4 digits translation patterns.

HTH,

CJ

Paolo Bevilacqua Mon, 10/08/2012 - 13:46

From dialing using short codes there is no need to use num-exp.

Check "bulk speed-dial" in CME documentation. These are saved on a file that can be kept on a server for ease of maintenance, and some more advantages.

Actions

Login or Register to take actions

This Discussion

Posted January 12, 2011 at 3:25 PM
Stats:
Replies:7 Avg. Rating:
Views:1022 Votes:0
Shares:0

Related Content

Discussions Leaderboard