Cisco SIP IP Phone are unable to load Config from TFTP (unprovisioned)

Unanswered Question
Jan 12th, 2011

Hi All Friends,

We have CISCO IP phone 7941 for using VOIP from SIP provider, IINET is providing to us,  It has default SIP Image, it is New SIP phone, I configured below attached code in Xml file(SEP001B2AC76B9A.cnf.xml) & keep on TFTP Server but I saw on TFTP Server phone got config from TFTP, but phone saying error unprovisioned,

I think my config is correct, but please anyone help me

Kindly Help me

Vikrant 

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
vikrant0012007@... Tue, 01/18/2011 - 20:05

Hello Dear,

Thanks for your reply, I am unable to understand below line

http://192.200.200.251/asterisk/phonedirectory.php

http://192.200.200.251/asterisk/index_cisco.php

My VoIP SIP domain is  iinetphone.iinet.net.au & VoIP SIP server is  sip.vic.iinet.net.au    203.55.229.193

Can you suggest me for above both thing  also at the moment  IP Phone saying  registereign is going on but TFTP Server is demanding CTL---.tlv file .

Can you please look attached Snap Short

Regards

Vikrant

hermanh Wed, 01/19/2011 - 11:00

Hi Vikrant,

The .tlv error can be ignored (it's to do with using certificates for secure sip) and has no effect, unless your using secure sip which I doubt.

Also these entries can also be ignored, they our specific to my company:

http://192.200.200.251/asterisk/phonedirectory.php

http://192.200.200.251/asterisk/index_cisco.php

They are basically menus that appear on the phones.

Just try putting the ip address\hostname where I told you and see.

vikrant0012007@... Wed, 01/19/2011 - 19:34

Hello Bro,

Thanks for helping me

After some changes in cnf file IP phone got config from TFTP, IP Phone saying  registereign is going on, & I saw on TFTP IP phone required ctl file..


Now I have below files on TFTP Server
apps41.8-3-0-50.sbn
cnu41.8-3-0-50.sbn
cvm41sip.8-3-0-50.sbn
dialplan.xml
dsp41.8-3-0-50.sbn
jar41sip.8-3-0-50.sbn
OS79XX.TXT
P0S3-08-4-00.loads
P0S3-08-4-00.sb2
P003-08-4-00.bin
P003-08-4-00.sbn
SEP001B2AC76B9A.cnf.xml
SIP41.8-3-1S.loads
SIPDefault.cnf
term41.default.loads
XmlDefault.cnf.xml

Can you please look on my Attached Config file & please guide me if I am wrong

I remove Username & Password from attached config

XXXX = Voip user name

YYYY = Voip Password

hermanh Thu, 01/20/2011 - 01:49

Hi Vikrant,

The ctl file can also be ignored as it's also to do with security certificates.

I've uploaded a changed file for you to test.

Are you behind a router, which I assume you are, I'v changedhis:

<natenabled>falsenatenabled>

To

<natenabled>truenatenabled>

Change back if required

Change XXXXXXXX to your phone number if you want.

Also the file contains stuff that's wrong. The is specified in numerous locations. These are shown below so I've removed them all:

                  202.81.208.160name>
                

               sip.vic.iinet.au
               

           XXXXXXXX
           

          sip.vic.iinet.au
           

            XXXXXXXX

            iinet


            XXXXXXXX


            YYYYYY

hermanh Thu, 01/20/2011 - 01:53

I see you also posted on 'experts-exchange'. I'm actually a member

there

vikrant0012007@... Thu, 01/20/2011 - 02:15

Thanks Bro,

I am Qualified Expert there, Bro i have done this B4 one year on 7940 but now  I am very tired from this phone i did lot's of changes but still don't have any Luck

I am checking your config & Let you know,

one more question does I need any more file like XMLDefault.cnf.xml & dialplan.xml,

You can Post on EE also

hermanh Thu, 01/20/2011 - 07:26

Both files are needed. The xmldefault for global settings on all phones and the dialplan for the dialplan specific to your needs\country

This is my xmldefault (bold is important):


  
   
      
       
         
             2002
             2001
             2000
            
                2427
                2428
            
         
                 192.200.200.250
           
         
      
   
  SIP11.8-5-4S
  SIP42.8-5-4S
  SIP75.8-5-4S
  http://192.200.200.3/asterisk/index.php
  
  
  
  

This is my dialplan.xml:









hermanh Thu, 01/20/2011 - 07:35

Note:

This is a crucial part of the config. If this is missing, your phone will complain about being "Unprovisioned" so take care with what you edit in here. While the phone is in the "Unprovisioned" state it will repeatedly download it's config file via TFTP every minute or two, so changes you make should be picked up fairly quickly. I am aware of the multiple uses of your SIP username - quite possibly some are redundant.

    
       
         button="1">
           9
           extension number
           SIP proxy
           5060

amohod Fri, 01/21/2011 - 04:40

Have you configured the extension number for phone. This message normally comes when add phone in CUCM without extension number.

hermanh Fri, 01/21/2011 - 21:58

Hi Vikrant,

Did you place your phone number under ?

Also try connecting with a sip client like x-lite to confirm things are actually working on the providers side.

vikrant0012007@... Fri, 01/21/2011 - 23:24

Dear Rermanh,

As per your Suggestion I Installed X-lite 4.0, Everything is fine on that, I can Make Call from Softphone also can receive call,

Bro I am very tired from 7941G, Not sure why it's not working, pls help me, can u give me ur Skype or Gtlak ID if Possible

hermanh Sat, 01/22/2011 - 03:36

Hi,

Don't use skype or other.

post your latest config.

Paolo Bevilacqua Sat, 01/22/2011 - 07:51

Bro I am very tired from 7941G, Not sure why it's not working, pls help me, can u give me ur Skype or Gtlak ID if Possible

In another thread, you had been warned that using 79xx for ITSP is NOT recommended.

But you tough you know better.

hermanh Sat, 01/22/2011 - 12:12

Ok,

I've edited as I think it should be. Add your settings as appropiate on these lines:

XXXX 
   XXXX
   XXXX
  XXXX

Also note that you had the worng proxy set under

You had this 203.2.134.1 and I've set to this 203.55.229.194 (assuming it's your provider sip.vic.iinet.net.au)

Also ensure your provider allows G729a codec as this is what is specified in the file.

You also had this ip 203.0.178.91 specified as your 203.0.178.91 in the xmldefault.cnf.xml which should be 203.55.229.194 (assuming once again that your provider is sip.vic.iinet.net.au)

I also changed the load information to this SIP41.8-3-1S

Your ntp server is pointing to this and I'm not sure if that was intended and whether they offer ntp services which I havent checked. Although this shouldn't affect registration:

vhosts.iinet.net.au
203.0.178.91

Apart from this I'm afraid I cannot offer any more help.

Read the link I sent which is pretty informative

http://www.voip-info.org/wiki/view/Asterisk+phone+cisco+79x1+xml+configuration+files+for+SIP

Both files attached

joro Fri, 08/30/2013 - 16:55
I've seen the unprovisioned message with SIP phones that were in Call
Manager but had no DN configured on the phone.

Actions

Login or Register to take actions

This Discussion

Posted January 12, 2011 at 8:22 PM
Stats:
Replies:20 Avg. Rating:
Views:7408 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard