SPA 303 - freezing/unresponsive

Unanswered Question
Feb 6th, 2011

Hi,

There's been a few occasions that SPA303 would freeze and become unresponsive.

Unsure how to troubleshoot, ran syslog for the past few days to hopefully tell me something, but it didnt go to that state.

I guess the reason for this post, is to ask if anyone happened to experiece this issue as well ?

Thanks,
jowan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
jowan.mcruz Mon, 02/07/2011 - 23:02

Thanks for that.

It seems some were able to find resolution by updgrading to 7.4.7, however my test unit already runs 7.4.7.

Usually have to power off the device and works again, tho given the device is a bit slower than say 9x2 or 500 series, it can be really annoying.

Hard part is, it seems random and been unable to replicate that state again.

Will keep watch for now

JeffBourgeois5333 Tue, 02/08/2011 - 06:22

I was among those who were having hang problems in the thread.  However, not for some time now since I split my network configuration.

One concensus was that DNS resolution may be an issue.  Some people got around the issue by inputing proxy IP address rather than proxy name (if you know fixed IP of proxy). 

Some people resolved issue by upgrading to the now latest firmware version.

In my case, my SPA504G was initially behind two NAT's.  When I split my network (using 5-port switch) such that my SPA2102 and SPA504 were on separate WAN IP from my WRT54G and PC, then I did't have any more lock-ups (my ISP allows me 2 WAN dynamic IP addresses). 

So, there seems to be various reasons contributing to the lockups, depending on ones network configuration, firmware, etc.

davehocking Thu, 05/05/2011 - 04:06

I've been able to replicate this issue. When transferring a call (made internally) to another internal extension, the phone freezes before it ever dials the new party. This ONLY happens when using the LDAP directory to find the user's extension. Dialling the number by hand works as expected.

Trixbox 2.8.0.4

SPA 303, fw 7.4.8.a

Server 2008 R2 AD

The SIP Proxy was specified by IP, not hostname

The config for the LDAP search was calling on the LDAP server by DNS name - trying to change this to IP address broke the LDAP Lookup however, so this theory can't be tested.

davehocking Mon, 05/09/2011 - 01:32

..just to further add, I can tell you that this issue arrived in between Firmware versions 7.4.5 and 7.4.6.

I'm specifying all servers in the configuration by IP, not DNS.  There is no NAT between any of the components in question.

terrymcrane Mon, 06/11/2012 - 23:02

Have 10 remote users with SPA303 phones running firmware 7.4.9.a. All phones are configured to use STUN. The pbx is 3CX v10 (static IP - no stun server).

Daily, all phones experience multiple random freezes that require a reboot; more often on incoming & ext. to ext. calls.

Noticed firmware 7.5.1a has been released but no reference to the freeze issue is mentioned in the release notes.

Anyone find a resolution? This is my first experience with Cisco phones and very discouraging to see a similar thread regarding the SPA504G that is still unresolved after nearly two (2) years.

Actions

Login or Register to take actions

This Discussion

Posted February 6, 2011 at 3:18 PM
Stats:
Replies:6 Avg. Rating:
Views:2412 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard