Nexus 7000 - determining the Jumbo MTU size on an interface.

Unanswered Question
Feb 7th, 2011

I am trying to determin if Jumbo frames are enabled on out Nexus 7000, and I am getting mixed info back from the swtich.

I looks like the system jumbo MTU size is 9216 by default, but the interfaces all say the MTU of the interface is 1500 bytes. According to this article, the interface MTU should read 9216 is the jumbo frames are enabled globally. Is this correct. Is there a way to verify if Jumbo frame support is turned on?

http://www.cisco.com/en/US/products/ps9670/products_configuration_example09186a0080b44116.shtml

Here is our output from sh run all | sec system

n7k1# sh run all | sec system

no system default switchport

system default switchport shutdown

system jumbomtu 9216

cdp format device-id system-name

  system-priority 4094

And the interface output:

n7k1# sh int po40

port-channel40 is up

vPC Status: vPC number: 40

  Hardware: Port-Channel, address: 0024.f71d.9813 (bia 0024.f71d.9813)

  Description: to msndc-intel-asw Access Switches

  MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  full-duplex, 10 Gb/s

  Input flow-control is off, output flow-control is off

  Switchport monitor is off

  Members in this channel: Eth1/12, Eth2/12

  Last clearing of "show interface" counters never

  30 seconds input rate 27816480 bits/sec, 5672 packets/sec

  30 seconds output rate 33896296 bits/sec, 12904 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 82.15 Mbps, 9.90 Kpps; output rate 37.58 Mbps, 17.28 Kpps

  RX

    57135287297 unicast packets  13338525 multicast packets  2206711 broadcast packets

    57150832533 input packets  69901179046421 bytes

    0 jumbo packets  0 storm suppression packets

    0 runts  0 giants  0 CRC  0 no buffer

    0 input error  0 short frame  0 overrun   0 underrun  0 ignored

    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop

    0 input with dribble  0 input discard

    0 Rx pause

  TX

    100563243159 unicast packets  661949296 multicast packets  4071877704 broadcast packets

    105297070159 output packets  27468942487440 bytes

    0 jumbo packets

    0 output error  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble

    0 Tx pause

  2 interface resets

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
nathan.eger Thu, 03/17/2011 - 09:23

Did you try looking at the physical interface?  I see the output you listed is for the vPortchannel.

alphaomegait Thu, 03/17/2011 - 15:56

After you turn jumbo frames on globally, you then have to set mtu under the interfaces.

There is a clear example of this in the command lookup for NX OS.  Just search for jumbo frames:

switch# config t

switch(config)# system jumbomtu 9216

switch(config)# show running-config

switch(config)# interface p102

switch(config-if)# switchport

switch(config-if)# mtu 9216

wmejiamendoza Mon, 04/09/2012 - 08:51

HI !

I Wil do the same configuration tomorrow. The moment that I execute this, It´s going to result in loss of service?

Thanks

Regards

onestero Mon, 04/16/2012 - 09:29

Hi Peter

Try to use

"sh queuing interface eth x/y"

since in "show interface eth x/y" correct MTU may not be visible due to cosbetic issue.

HTH,

Alex

eduardo.ramirez Thu, 09/26/2013 - 15:00

Hi Peter you have to enable this on each interface too  ,  I did with no loss of service  !!!!

Thanks

Actions

Login or Register to take actions

This Discussion

Posted February 7, 2011 at 10:44 AM
Stats:
Replies:5 Avg. Rating:5
Views:6215 Votes:0
Shares:1

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
70
69
55