CUCM integration into CTS Manager.

Unanswered Question
Feb 22nd, 2011

Hello Everyone.

My problem is, that I'm trying the integration of an Cisco TelePresence Manager into our TP network.

I read all the information on the cisco website, and did everything, what is writen there, but I get error everywhere.


At the CUCM integration, I made the user,I made the group, I added the roles as writen, but at the CTS configuration website I'm getting the following error:

Failed to establish a connection to 'XX' with the information provided.
    Code: 501000.
    Message: The system has encountered an unexpected condition (com.cisco.ts.scheduler.exception.DiscoveryException(502406,DM,CCM_AUTH_CONN_FAILURE,Unable to authenticate and connect with Unified CM 'XX' because Invalid application user credential.)).

I used a simpley user password, I downloaded the cerficate file, as writen in the documentation.


I hope, someone can help me.

Thanx.

Andras

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
gogasca Tue, 02/22/2011 - 11:49

Which version of CUCM and which version of CTs-Man

Make sure under CUCM System its configured to use an IP address, then restart CUCM and CTI manager

After that try again.

Make sure user has associated to all roles

Thanks

ratz.andras Wed, 02/23/2011 - 01:50

Hi.

The CUCM version is 8.5

The CTs-Man is the newest 1.7.1

I restarted several times the CUCM and the CTs-Man, but it don't work.

The interesting part is, if I only load the certificate and I dont fill out the server, user and pass fields, and then hit the Test button, it write out the same error message.

Can be a problem, if both systems are on VMware?

gogasca Thu, 02/24/2011 - 12:33

"Make sure under CUCM System its configured to use an IP address"

Can you confirm above (CUCM Admin | System | Server) , as if CTS-Manager is not able to resolve CUCM name, it will fail with a similar error

Once you confirmed this, make sure Roles:

Standard AXL API Access

CCMAdmin Users

CTI Enabled

RealtimeandTraceCollection

Serviceability

CUCM,CTI and AXL services must be restarted after this,

confirm password

then restart CTS-Man

Then if still doesnt work, send me the CTS-MAn logs Discovery logs set to DEBUG.

We have VMware similar setup with no issue,

Thanks

ratz.andras Wed, 04/13/2011 - 07:33

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

I checked everything what you wrote, it was good, but it is still don’t work. I attached the log file what you asked for.

The name is no problem cause I use IP address not a host name.

ptalamo Wed, 04/13/2011 - 08:57

Hello Andras,

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} Your attachment has been removed to protect your confidential information. Please proceed to open a Service Request and upload the logs to the SR for a TAC engineer to assist you. Thank you!

arunku3 Sun, 04/24/2011 - 22:14

Hi Andras,

Can you run CTSMan PreQualification Assistant Tool 1.7.1 and see if it passes the test or not ?

Thanks

Arun

ratz.andras Tue, 04/26/2011 - 00:06

Hi Arun.

I allready tried the prequalification tool, and it don't passed. It wrote out the same error.

Azrael667 Mon, 05/02/2011 - 01:31

Problem resolved here.

The error message is strange as the problem came from the certificate. I re-downloaded it from my browser on the cucm web page then uploaded it for the test connection page in ctsmanager and that works fine.

ratz.andras Mon, 05/02/2011 - 01:33

I think the certificate is the problem here too. Which certificate did you downloaded exacly?

You did nothing jus re downloaded?

Azrael667 Mon, 05/02/2011 - 01:49

Actually i logged on my cucm admin webpage then clicked on the blue part of the url (connexion secured). Then i applied these steps given by someone from cisco:

For downloading the new certificate from CUCM and then upload it to CTM

# a.open an IE browser and log in to the CUCM

#b.when security alert window pops  , click View Certificate

c.click Details at the Certificate pop up

d.click Copy to File on the bottom right corner

e.click Next, and leave the default DER encoded binary X.509(.CER),
click Next

f.pick a folder and enter ccm-cert as file name from Browse and click
Save

g.click Next, Finish, Ok

Go to the folder and find ccm-cert.cer, change it to ccm-cert.der

Then use your .der file during the connection test with your hostname/ip of cucm and app user logs.

ratz.andras Wed, 05/04/2011 - 07:59

Thanx for the tips, but sadly it's not working.

Your certificate is self signed? Or you have a public certificate?

One thing I don't get, what should be the extension? .der or .cer? or it doesn't matter?

Azrael667 Wed, 05/04/2011 - 08:06

When you get the certificate from your browser, the extension format doesnt really matter ( .crt/.cer ... ). You just need to change it to ".der" after downloading it on your computer.

The certificate is generated by the cucm so yeah it's self-signed.

Did you tried to delete/create the app user you are using for ctsman ? (and the group which is associated to this user)

gilbert.spoor Thu, 05/05/2011 - 01:58

I had the same problem.

In the documentation it doesn't say you have to enter the digest password as well, but when I did the authentication works fine.

the stupid thing is that for the prequalification assistant you don't have to enter the digest passwd for it to work..

(took me days to find this one out)

ratz.andras Thu, 05/05/2011 - 02:28

Sorry, can you explain a little what do you mean under the expression "digest password" ?

The stupid thing that whit previous version, it worked fine, but after the updates to ctsman 1.7 and the cucm it just don't work.

And the cisco documentations are very unpunctual..

THOMAS KRUEGER Fri, 05/06/2011 - 00:42

Hi Andreas,

you wrote: "it worked before" so one idea:

You did a cucm upgrade on the same machine, and you did not change ip adress etc, so you did not have to modify the CUCM settings on the CTS man, right?

If this is the case:

On the CTS- man web GUI go to "Security" see if there is the old CUCM Certificate AND the new CUCM Certificate.

Delete the old one. This will force CTS-MAN to use the new Cert for existing CUCM connection

Then go to Configure CUCM an do the connection test again.

ratz.andras Fri, 05/06/2011 - 04:47

Thomas, it was a reinstall, not an upgrade, so now I have to configurate everything again.

Gilbert, for me the prequal don't work also, but thank you for the advise, I will try that out.

gilbert.spoor Fri, 05/06/2011 - 01:12

Hi Andras,

Under the Appuser that you create in CUCM 8.5 (for CTS-man to talk to CUCM) there are two places to enter the password.

the user password and the Digest credentials

First I used the prequalification assistant and had only the "normal" password entered, and not the digest credentials --> the prequal went good.

But the CTS-MAN startup wizard failed.

when I entered the same password at digest credentials it worked fine.

ratz.andras Mon, 05/09/2011 - 01:00

Gilbert, please, can you check for me that you use the same Roles for the user in CUCM?

I use the followings:

Cisco Call Manager AXL Database - Allow to use  API

Cisco Call Manager Administration - every read and update is checked

Cisco Call Manager Serviceability - every read and update is checked

Cisco Computer Telephone Interface (CTI) - everything is checked

Standard RealtimeAndTraceCollection

Thank you for your help.

Andras

gilbert.spoor Wed, 05/11/2011 - 04:12

Hi Andras,

I have the following rights for the appuser in CUCM:

Standard AXL API Access

Standard CCM Admin Users

Standard SERVICABILITY

Standard CTI Enabled

With kind regards / Met vriendelijke groet,

Gilbert Spoor

Platform Manager VisionsConnected

ratz.andras Wed, 05/11/2011 - 06:16

Hi Gilbert,

the roles was the problem, your roles was the solution.

Thank you for all your help.

Dank u voor de hulp.

Andras

gilbert.spoor Wed, 05/11/2011 - 06:18

Graag gedaan, Andras

(you're welcome

With kind regards / Met vriendelijke groet,

Gilbert Spoor

Platform Manager VisionsConnected

Actions

Login or Register to take actions

This Discussion

Posted February 22, 2011 at 5:37 AM
Stats:
Replies:22 Avg. Rating:
Views:2389 Votes:0
Shares:0
Tags: cucm, cts-manager
+

Related Content

Discussions Leaderboard