Configurar 2 ssid -vlans- inalambricas

Unanswered Question
Feb 23rd, 2011

Buenos días a todos, solicito de su apoyo y conocimiento para hechar a andar al 100% un cisco 871W, yo creo que es muy simple mi requerimiento pero no mas no le doy ... necesito dividir mi red, una vlan de invitados (3) y otra para usuarios (1), con acceso a internet, la vlan de invitados no debe de poder ver la red de usuarios, y crear su respectivo acceso inalambrico (uno para invitados y otro para usuarios).

Mi topologia es la siguiente:

ADSL-Infinitum->871W->Catalyst500->Lan

En el switch catalyst en el puerto 1 esta conectado el cisco y este a su vez esta en modo trunk, tiene dada de alta la vlan 1 y 3.

En la red de invitados veo la red inalambrica, al intentar conectarme no me da ip; si me pongo una ip fija del mismo segmento, no alcanzo mi gateway (192.168.10.1), es la misma situacion si lo intento por ethernet en algun puerto de la vlan 3

En el caso de la red inalambrica de los usuarios, aunque ya especifique manualmente los parametros de la red inalambrica (tengo windows xp sp3 con todos los parches habidos y por haber)nada mas no me conecto (incluso lo intente con otra lap que tiene w7 y tampoco ). Si me conecto por ethernet en algun puerto de la vlan 1 me da correctamente una ip del segmento (172.16.1.X), me responde mi gateway (172.16.1.5) y navego a internet sin ningun problema.

En si el problema es con la red para invitados, no logro darles el servicio que necesitan...

Espero no haberlos enredado... les anexo mi config y ojala puedan apoyarme, gracias!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4 (1 ratings)
weterry Wed, 02/23/2011 - 21:42

Google Translator Español: Esperemos traductor de Google hará justicia. Nunca he visto a alguien poner la dirección IP directamente en la interfaz de radio. Podría estar equivocado, pero creo que la radio ha de salvar a algún tipo de interfaz Ethernet. Pruebe el siguiente configuración y ver si funciona para ti. Yo, básicamente, se trasladó la dirección IP a BVI3, y añadió un puente entre el grupo y do0.3 Int. Int. VLAN 3. Puede que tenga que hacer un pellizco a la misma.

Hopefully Google translator will do this justice. I've never seen someone put the IP Address directly on the Radio interface. I could be wrong, but I think the radio has to bridge to some kind of ethernet interface. Try the below configuration out and see if it works for you.  I basically moved the IP address to BVI3, and added a bridge-group between Int do0.3 and Int VLAN 3.  You may need to make a tweak to it.

!
interface Dot11Radio0.1
description Wireless IDIAL
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.3
description Wireless Invitados
encapsulation dot1Q 3
no cdp enable
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 spanning-disabled
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
!

interface Vlan1
description Lan Idial
no ip address
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan3
no ip address
ip nat inside
ip virtual-reassembly

ip access-group invitados-acl in
bridge-group 3
bridge-group 3 spanning-disabled


interface BVI1
ip address 172.16.1.5 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI3
ip address 192.168.10.1 255.255.255.0
ip access-group invitados-acl in
ip nat inside
ip virtual-reassembly
!

inge.miguelsalazar Thu, 02/24/2011 - 12:03

Gracias por la respuesta weterry, ya realice los cambios que me comentas, ya puedo navegar en cualquiera de las 2 vlans pero solo si me conecto directo al router a alguno de sus puertos ethernet, por inalambrico no me es posible, ni aunque me ponga ip fija del segmento alcanzo al router ... alguna otra sugerencia

Thanks for the reply weterry, I do the changes you told me, I can browse any of the 2 vlans via dhcp or static, this work only if I connect directly to the router to one of its ethernet ports, the wireless network dont work, even if I put a static ip, I cant reach my default gateway ... any other suggestions

inge.miguelsalazar Thu, 02/24/2011 - 12:39

Ya quedo!... El problema estaba en las configuracion de las vlans, le quite el nat inside en ambas vlans ya que tiene el nat inside en las BVI1y BVI3 ya funciona correctamente, tanto por inalambrico o via ethernet, pequeño detalle vdd?!

Les dejo mi configuracion final para consulta, espero les sirva a alguien, saludos!

All done! ... The problem was in the vlans config, I remove the nat inside on both vlans as it has in the BVI1y nat inside BVI3 is working properly, either by wireless or via ethernet,little detail

I leave my final configuration for consultation, I hope might help someone, cheers!

Actions

Login or Register to take actions

This Discussion

Posted February 23, 2011 at 4:31 PM
Stats:
Replies:3 Avg. Rating:4
Views:2172 Votes:0
Shares:0

Related Content

Discussions Leaderboard