Switchport bridge configuration for cisco 3750

Unanswered Question
Mar 3rd, 2011

hi,

I need to collect sniffer trace from MPLS link. Since it's directly from ISP to router ethernet.I am planning to put a cisco 3750 in between ISP and Router.

Having cisco 3750 in place, can i configure bridge port to bypass MPLS traffic and mirror the port?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 3.3 (3 ratings)
naiduccnp Thu, 03/03/2011 - 03:05

Hi,

Hope the below examples will help you.

This example shows how to create bridge group 10, to specify that the VLAN-bridge STP runs in the
bridge group, to define a port as a routed port, and to assign the port to the bridge group:

Switch(config)# bridge 10 protocol vlan-bridge
Switch(config)# interface gigabitethernet3/0/1
Switch(config-if)# no switchport
Switch(config-if)# no shutdown
Switch(config-if)# bridge-group 10


This example shows how to create bridge group 10 and to specify that the VLAN-bridge STP runs in the
bridge group. It defines a port as an SVI and assigns this port to VLAN 2 and to the bridge group:

Switch(config)# bridge 10 protocol vlan-bridge
Switch(config)# vlan 2
Switch(config-vlan)# exit
Switch(config)# interface vlan 2
Switch(config-if)# bridge-group 10
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface gigabitethernet2/0/2
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# no shutdown

Please rate the helpfull posts.
Regards,
Naidu.

ukglobecast Thu, 03/03/2011 - 03:22

Im pretty sure you could just do a normal access vlan switch ports

turn off unnecessary stuff like cdp , and put on bdpu filter so you dont see unnecessary traffic

eg...

Int gi x/x

description One end of mpls connnection

switchport

switchport mode access

switchport access vlan 500

spanning-tree portfast

spanning-tree bpdufilter enable

switchport nonegotiate

no cdp enable

Int gi x/x

description Other end of mpls connnection

switchport

switchport mode access

switchport access vlan 500

spanning-tree portfast

spanning-tree bpdufilter enable

switchport nonegotiate

no cdp enable

then do a span port on either port , doesnt matter which one

monitor session 1 source interface x

monitor session 1 destination interface x

destination interface , connect your laptop to this and run wireshark.

Actions

Login or Register to take actions

This Discussion

Posted March 3, 2011 at 2:37 AM
Stats:
Replies:2 Avg. Rating:3.25
Views:1324 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
70
69
55