Windows 7 machines not getting DHCP IP !!!!URGENT!!!!!!

Unanswered Question
Mar 7th, 2011

We are having a very strange problem , that is we have a lan with 16  vlans and all the vlans have different DHCP for each vlan in the  coreswitch (Cisco 6509) and all the clients in the 16 vlans are windows 7  clients , now the problem is that some machines  are not getting IP Addresses , but if we see the registry settings in  those machines we see that there is an ip address given by the dhcp  server  in the following key of registery

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\THE RELATED NETWORK CARD KEY

this ip is not being shown in the network settings instead  APIPA ip 169.245.*.* is shown here ,

DHCP server configuration are check and verified and they are also ok  , packets are also captured which show the whole process of DCHP  request is ok and dhcps in the core switch is replying back with the ip  address to the machines mac address and that same  ip can be seen in the above given registry value.

Kindly help as soon as possible as already alot of time is wasted in tracing this issue.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Cadet Alain Mon, 03/07/2011 - 06:17

Hi,

Can you post screenshot of ipconfig/all and tcp/ip setting of machine with the APIPA address.

also post sh ip dhcp binding for the IP it should have got on your DHCP server.

Regards.

Alain.

glen.grant Mon, 03/07/2011 - 09:51

   The 169 address is the defualt address microsoft assigns when it cannot pull an address  which you say you problem is  .  Make sure portfast is on all user ports .  Verify any trunking is working correctly. between user switches.

mohsinalizai Mon, 03/07/2011 - 23:16

hi glen.grant

yes the Trunbking is ok ,, its fine as i told u that only some pcs in the vlans are having this problem not every pc which makes trunking ok as vlans are working fine , and yes also portfast is enabled even on trunk ports and also verified that no spaning tree or other loop is being generated.

davidbranka Mon, 03/07/2011 - 10:13

Do you have the ip helper address set on each vlan interface with the dhcp server ip address?

Example:

interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.100

interface Vlan3
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.1.100

mohsinalizai Mon, 03/07/2011 - 22:21

Hi David

I have Configured DHCP server inside the cisco 6509 and all the Vlans are defind in that so no need of giving ip helper in this case.

Cadet Alain Mon, 03/07/2011 - 23:44

Hi,

Can you do a debug ip dhcp server event and debug ip dhcp server packet while renewing your lease.

At the same time can you sniff on your pc.

Attach all files here.

Regards.

Alain.

mohsinalizai Tue, 03/08/2011 - 01:40

In these files you can see that wireshark is getiing the same ip for the interface card that is present in the registry where as the tcpip settings is getting APIPA 169.*.*.* ip and in the sniffing captures you can see that dhcp server is assigning the same ip 10.10.10.38 to the request and also in the debug file result is clear that dhcp server i.e cisco 6509 is giving the ip to the mac address , strange thing is this that every setting given by the dhcp server is comming to windows 7 registry  but not to the interface card settings on TCP/IP

Cadet Alain Tue, 03/08/2011 - 02:08

Hi,

Can you reinstall the tcp/ip stack on the machine.

Regards.

Alain.

mohsinalizai Mon, 03/07/2011 - 23:48

Any Clues ??????? about this abnormal behaviour or may be any mistake that i have done unintentionaaly ???? kindly give your ideas iam really getting lot of  complaints here n my professional integrity  is at stakes

mohsinalizai Tue, 03/08/2011 - 02:47

reset the tcpip stack by

netsh int ip reset

but no change same behaviour.

Cadet Alain Tue, 03/08/2011 - 04:03

Hi,

uninstall then install not reset and tell me what it gave. Maybe you can also try another firmware for your NIC.

Regards.

Alain.

mohsinalizai Tue, 03/08/2011 - 04:05

firmware is not issue as machines having this problem have dofferent lan cards ,

Cadet Alain Tue, 03/08/2011 - 04:08

Are all the non working machines Windows 7? and are all working machines not Windows 7?

Regards.

mohsinalizai Tue, 03/08/2011 - 04:34

yes all non working ,, are win 7 .. you cant say non working because some win7 machines are working fine ,, but non win 7 machines never have this issue

Cadet Alain Tue, 03/08/2011 - 05:09

Is there a difference between the working and non working windows 7 machines: 64 vs 32, release version, updates  ?

Regards.

mohsinalizai Tue, 03/08/2011 - 05:14

no not standard win7 non working machines hav variable specs , some 32 some 64 some updated some not .

mohsinalizai Tue, 03/08/2011 - 06:19

MAG-CORESW#sh ip dhcp bind
MAG-CORESW#sh ip dhcp binding | in 01b8.ac6f
10.10.10.32      01b8.ac6f.1c1e.b7       Mar 08 2011 05:06 PM    Automatic
10.10.10.65      01b8.ac6f.246c.e0       Mar 08 2011 04:47 PM    Automatic
10.10.40.47      01b8.ac6f.1c29.13       Mar 08 2011 02:58 PM    Automatic
10.10.41.63      01b8.ac6f.1ba2.be       Mar 08 2011 05:47 PM    Automatic
10.10.161.78     01b8.ac6f.1bd9.39       Mar 08 2011 06:09 PM    Automatic

Cadet Alain Tue, 03/08/2011 - 06:41

10.10.10.65      01b8.ac6f.246c.e0       Mar 08 2011 04:47 PM    Automatic

Isn't this one of the weird windows 7? Can you ping this IP from your dhcp server ? if yes check arp cache on dhcp server.

If I remember well this is the interface which kept requesting 10.10.10.38 and which didn't get it?

Regards.

thiagomh25 Tue, 03/08/2011 - 06:06

Can you reload the switch?? How long does this switch hasve been up??1 year??few days??months??save your config and do a reload and check.

Regards,

Cadet Alain Tue, 03/08/2011 - 06:35

just yesterday i reloded when my ideas regarding this problem ended

What do you  mean?

Regards.

DuncanM2008 Tue, 03/08/2011 - 08:46

Have you tried disabling any unecessary network adapters on the Win7 Clients, i.e. TAPI Adapters, VPN Adapters, VMWare Bridging Adapters.

I noticed on your ipconfig output you had a VMNet1 interface which is normally the product of VMWare Workstation or are your Windows 7 machines VM's?

Have you tried disabling IPv6 if it's not in use? I have seen issues with Win7 when IPv6 has been enabled and only IPv4 is in use but it's not likely...

lucentmoon Tue, 03/08/2011 - 10:15

Sounds like Duncan is on the right track, You could also update the NIC drivers.

Can the workstations ping 127.0.0.1?  Another way to verify the ip stack on the win7 boxes is to statically assign IP addresses corresponding to the appropriate vlans of course and then attempt pings to the core.

Since you stated the win7 boxes effected are a mixed bag i look into a software conflict, i.e. vmware trying to share the same NIC.

davidagudogarcia Thu, 03/10/2011 - 04:42

Try the next solution for this problem:

1.- Reset the socket. From a DOS terminal (Run cmd.exe):

     netsh winsock reset

2.- Open a Devices Manager (Run devmgmt.msc):

3.- Expands the 'Networks Adapters' 'section. Right click on adapter in use and select 'Unistall' option.

4.- Reboot the system. Now, Windows detects and reinstalls the adapter.

I hope it works out for you.

wesiewert Fri, 05/06/2011 - 07:01

ok, I'm not shure if this is still hot, but I'm actualy experiencing with dhcp problems on Windows 7 too and I found this one:

http://social.technet.microsoft.com/Forums/en-US/winserverNIS/thread/b3d047fa-7843-4fb6-ba99-7531c45e0d68/

after disabeling the Windows Firewall the client gets IP Address from DHCP Server, but however - this cannot be the solution...

So the problem seems to be that the dhcp relay agent sends the dhcp packets as unicast and the Windows 7 machine expects and only accepts dhcp broadcast packets... Is there any way to make the dhcp relay agent sending the dhcp packets as broadcast and not as unicast???

If there is any solution for this one - any help is highly appreciated...

werner

a_goncalves Fri, 05/06/2011 - 07:25

first is the windows PC in different network segment?

example DHCP server is in 10.0.1.0 and the PC is in 10.0.2.0

If this is the case you need enable the DHCP Helper on router where the PC is installed and set the helper with address of the DHCP server.

muhammad.umair Fri, 05/06/2011 - 22:12

this is a problem of your system side there is no configuration issues, so to verify kindly plug another PCs or laptop on same port in same vlan

thanks

wesiewert Sun, 05/08/2011 - 03:10

only the Windows 7 machines which are not in same network segment as the DHCP Server do have this Problem...

in other words: Only Win7 machines which do not have L2 connectivity to DHCP Server have this Problem!

When I disable the Win7 Firewall everything works fine, the machine gets and accepts IP Address from DHCP Server...

Win7 machines in the same Network segment as DHCP Server (L2 connectivity) work fine even with Win7 Firewall enabled!

XP machines do not have any problem, they work fine in both network segments...

ip-helper address is configured, as stated bofore XP machines work fine, so the general dhcp config seems to be ok...

Aso with wireshark I see the dhcp offers the win7 machine definitly gets from dhcp Server, but the machine does not accept this offer from dhcp Server - only when I disable the win7 Firewall everything works perfekt!

With Win7 Firewall enabled I also can see the DENIED dhcp offers in the Win7 Firewall logfile!

Any ideas???

werner

a_goncalves Mon, 05/09/2011 - 05:00

I am not familiar yet with windows 7 but we are installing those in our environment, and we did have the same problem with one or two of those, but after we did the command "Ip config /release" and and then "IP config /renew" the PC got the right IP address. Also since I do not know your network environment. I suggest that you open the port on PC firewalls for the DHCP server by adding the IP of it and the port. Other problem may occurred form IPV6 Windows 7 supports IPV6 and the PC may try to get the IPV6 if you have older switch and routers that does not support and that may cause the problem. If all equipment working fine with windows older version then looks like it is a PC network configuration.

If you have switches in that subnet I also suggest clearing the ARP table and the MAC-address dynamic table. With slow networks the time to keep alive of this tables is in order of hours sometime.

Final contact your WAN service provider and findout if they are blocking any traffic. Reviewing the description of the problem it looks like it is a routing issue.

wesiewert Wed, 05/11/2011 - 04:09

On our vlan interfaces we had configured ip broadcast address "subnet.255". Now I changed the ip broadcast address on vlan interface to 255.255.255.255 and now the win7 clients get their ip addresses via dhcp...

But there seems to be a problem too, because from time to time some of the win7 clients claim that there is an ip address conflicct with ip 0.0.0.0 and hardware address 00-0a-b8-ad-7d-38, and this mac-address is the mac from the interface (of cisco switch) to which the win7 client is connected...

I have checked the dhcp server but everything looks fine... I have no idea why there should be an address conflict with this interface???

werner

esomarriba Wed, 05/11/2011 - 06:46

Hi Muhammad,

At this point I would recommend opening a SEV 1 Cisco TAC case and a SEV 1 with Microsoft, they should have an answer for you.- It seems you have done a complete TSHOOT session.

Cisco TAC will usually request a WebEx Session to share your desktop.

HTH,

Elyinn.-

Actions

Login or Register to take actions

This Discussion

Posted March 7, 2011 at 6:09 AM
Stats:
Replies:35 Avg. Rating:
Views:22300 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 14,997
2 8,150
3 7,720
4 7,078
5 6,710
Rank Username Points
200
80
59
57
57