Cisco 2811 PPPOE Configuration Help

Unanswered Question
Mar 24th, 2011

Hi everyone,

I own a Cisco 2811 with 2 ethernet interfaces and 1 Hwic ADSL. Until last month it was configurated in PPPOA, but my ISP has recently swithced my conection on a new PPPOE multiplexer. I tried different PPPOE configurations i found onlinet, but i can't connect the router in internet.

My PPPOA configuration is:

interface ATM0/0/0
no ip address
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username aliceadsl password 7 060703284F4B081D161B
ppp multilink
no cdp enable  

The best PPPOE configuration i tried is (i can see the int dialer0 up):

interface ATM0/0/0
no ip address
no atm ilmi-keepalive
hold-queue 224 in
!
interface ATM0/0/0.1 point-to-point
pvc 8/35
  pppoe-client dial-pool-number 1
!
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username aliceadsl password 7 060703284F4B081D161B
ppp multilink
no cdp enable

Can you help me? I really don't know what i have to change in my configuration.

Thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Muhammed Marakk... Thu, 03/24/2011 - 21:48

Hi Fabio,

I modified your config as it look like some of them are not needed and some of the line need to be added to it.

+++ This below commands are required if you are using old version of IOS

vpdn enable
no vpdn logging
vpdn−group pppoe
request−dialin
protocol pppoe

++++++

interface ATM0/0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
pvc 8/35
  pppoe-client dial-pool-number 1
!
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username aliceadsl password 7 060703284F4B081D161B
no cdp enable

++ Please get the output of show ip int brief, debupg ppp events, debut ppp authentication from the router after connecting to the ISP.

Also please verify with ISP about the your configured VPI/VCI values ( now configured for 8/35).

Useful link :http://www.cisco.com/en/US/tech/tk175/tk15/tech_configuration_examples_list.html

regards

Muhammed M

iceman_780 Fri, 03/25/2011 - 03:38

Thanks for the config, i'll try it when i'm back from the office.

Have a nice day

Actions

This Discussion

Related Content