NTP with Windows Time Server

Unanswered Question
Apr 7th, 2011
User Badges:

Hi,


We have some routers which are not able to sync with the Windows NTP server.


Some of them are able to, wondering if its to do with some ios issue or what.

When I do a debug I get this information from NTP.


#
Apr  6 18:04:23.011: NTP message sent to 10.240.5.77, from interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:04:23.011: NTP message received from 10.240.5.77 on interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:04:23.011: NTP Core(DEBUG): ntp_receive: message received
Apr  6 18:04:23.011: NTP Core(DEBUG): ntp_receive: peer is 0x00000000, next action is 4.
Apr  6 18:04:23.011: NTP Core(NOTICE): ntp_receive: dropping message: manycast peer not enabled.
Apr  6 18:05:27.011: NTP message sent to 10.240.5.77, from interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:05:27.011: NTP message received from 10.240.5.77 on interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:05:27.011: NTP Core(DEBUG): ntp_receive: message received
Apr  6 18:05:27.011: NTP Core(DEBUG): ntp_receive: peer is 0x00000000, next action is 4.
Apr  6 18:05:27.011: NTP Core(NOTICE): ntp_receive: dropping message: manycast peer not enabled.
Apr  6 18:06:32.011: NTP message sent to 10.240.5.77, from interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:06:32.011: NTP message received from 10.240.5.77 on interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:06:32.011: NTP Core(DEBUG): ntp_receive: message received
Apr  6 18:06:32.011: NTP Core(DEBUG): ntp_receive: peer is 0x00000000, next action is 4.
Apr  6 18:06:32.011: NTP Core(NOTICE): ntp_receive: dropping message: manycast peer not enabled.
Apr  6 18:07:35.011: NTP message sent to 10.240.5.77, from interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:07:35.011: NTP message received from 10.240.5.77 on interface 'GigabitEthernet0/1' (10.240.253.3).
Apr  6 18:07:35.011: NTP Core(DEBUG): ntp_receive: message received
Apr  6 18:07:35.011: NTP Core(DEBUG): ntp_receive: peer is 0x00000000, next action is 4.
Apr  6 18:07:35.011: NTP Core(NOTICE): ntp_receive: dropping message: manycast peer not enabled.
Kindly advise,
Rgds,

Tauseef
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cadet alain Thu, 04/07/2011 - 02:01
User Badges:
  • Purple, 4500 points or more

Hi,


Can you post output of sh run | s ntp for these routers and compare with one that is working.


Regards.


Alain.

tad.190804 Fri, 04/08/2011 - 10:55
User Badges:

Hi,


Show compare, is like the basic stuff. All done, then is when I posted this query. In fact, the router which gave this debug, is working fine when I configure it to another router in the network as an NTP server. But fails and gives these errors with the Windows NTP.

Leo Laohoo Thu, 04/07/2011 - 16:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Preston Chilcote Fri, 04/08/2011 - 08:57
User Badges:
  • Cisco Employee,

Starting with 12.4(20)T IOS will default to NTPv4.  If your server only supports v3 you will get the error you see in the debugs.   You can move to a server that supports v4, or manually change the  router to use v3, for example:


"ntp server 10.10.10.10 version 3". 

Let us know if that works.  If it doesn't, a show version and show run would be helpful.
tad.190804 Fri, 04/08/2011 - 10:58
User Badges:

Hi  Preston,


Seems like the most logical answer that I have observed till date.

Have to try it once I work on this in the coming week at the client side.

Will keep you posted on this update Preston.


Rgds,


Tauseef

tad.190804 Fri, 04/08/2011 - 10:56
User Badges:

Far away from what i was looking for. I guess its not clear on what I asked. Its okay, thanks for your input

any ways.

Actions

This Discussion