Bandwidth control

Unanswered Question
Apr 29th, 2011

Hello,

  I am needing to set up a 2801 router as a bandwidth controller.

My intention is only bandwidth control over IP address, no specific traffic. Until now I had some success but I'd like to know what is the  better way to do that.

Thats my configurations:

class-map match-any PQT

match access-group name Controla_banda

class-map match-any Cliente01

match access-group name cliente_teste

policy-map QoS

class PQT

   police rate 800000

interface FastEthernet0/1

description $ES_LAN$

ip address 172.16.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

service-policy output QoS

ip access-list extended Controla_banda

permit ip host 172.16.0.3 any

permit ip any host 172.16.0.3

ip access-list extended cliente_teste

permit ip host 172.16.0.4 any

permit ip any host 172.16.0.4

Any guidance will be very apreciated!

Thanks in advanced!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Andre Albuquerque Fri, 04/29/2011 - 13:03

It seems like you want to rate limit (police) the traffic from and to 172.16.0.3 to 800Kbps, on each direction, correct?

All other traffic will remain untouched (not limited).

If this is the objective, I would write the policy differently:

ip access-list extended TO_HOST1

permit ip any host 172.16.0.3

ip access-list extended FROM_HOST1

permit ip host 172.16.0.3 any

!

class-map TO_HOST1

match access-group name TO_HOST1

class-map FROM_HOST1

match access-group name FROM_HOST1

!

policy-map OUT_QOS

class TO_HOST1

police 800000

!

policy-map IN_QOS

class FROM_HOST1

police 800000

!

int fa0/1

service-policy input IN_QOS

service-policy output OUT_QOS

Your configuration is limiting the traffic in only one direction (directed to 172.16.0.3).

HTH, Gustavo

FlavioRoberto Fri, 04/29/2011 - 20:39

Hi Andre,

  Thanks for your help ! I saw you are brasilian too, but let me keep writing in english for practice...I am needing!

About the post, one more questions. I have the intention of garantee 10 % of the traffic for each class-map...I mean...I have 1 Mb full and I'd like to divide it for "n" users and each one will have at least 10% available.

How can I perform it using the Policy ?

Thanks again and congratulations !!

Andre Albuquerque Mon, 05/02/2011 - 06:22

You can guarantee bandwith with the command "bandwidth" on each class of a policy-map, specifying the amount of bandwidth to reserve in kbps.

You cannot configure bandwidth guarantees and policing in the same class though.

If you don't mind, I'd recommend you to read documentation and some books to better understand QoS theory.

There are some good documents on CCO:

- http://www.cisco.com/univercd/cc/td/doc/solution/esm/qossrnd.pdf

- http://www.cisco.com/en/US/docs/voice_ip_comm/cvd/G2srlgbrnt/FeatServ.html#wp1013051

- http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/12_4/qos_12_4_book.html

And some books:

- http://www.ciscopress.com/bookstore/product.asp?isbn=1587051761

- http://www.amazon.com/Deploying-MPLS-QoS-Multiservice-Networks/dp/0123705495

Cheers, Gustavo

Actions

Login or Register to take actions

This Discussion

Posted April 29, 2011 at 12:35 PM
Stats:
Replies:4 Avg. Rating:
Views:335 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard