Extension Mobility / CAD issue : "You cannot log in because the phone is IPV6-enabled"...help plz.

Answered Question
Feb 7th, 2011

Hi all,

I am having an issue with extension mobility and CAD.

UCCX 8.0.2.10000-41

CUCM 8.0.2.40000-1

CAD 8.0(2)

Phone: 7945G (configured as per other non 'contact centre' phones in the company, but no 'Line' assigned - want them to be purely for Contact Centre users to log into on their shifts)

When the user logs into the phone itself, there is no issue at this stage.

When the user goes to sign into CAD, they are presented with the following error:

     "You cannot log in because the phone is IPV6-enabled. IPV6-enabled phones are not compatible with CAD."

Workaround is to unlock (Settings > **#) Network Configuration on the physical phone and remove IPV6 config.

     Settings > **# > 2 (Network Configuration) > 2 (IPv6 Configuration) > 'more' button > 'Erase' button > it presents "Erasing IPv6 Network Settings".

User is then able to successfully login to CAD.

The issue is that after their shift, the user logs out of the phone, then when they login again, the issue is presented again and the 'workaround' of manually removing the IPv6 config off the phone has to be carried out all over again (and everytime after that too). Arrrrg.

I also noted that In CUCM > Devices > Device Settings > Commond Device Configuration > Find > my CDC > the IP Addressing Mode setting WAS set to 'IPV4 and IPV6'.

As a test, I changed this to 'IPV4 Only'.

Logged user out of phone, rebooted phone, logged user back in, attempted to login to CAD, same issue. No change! Arrrg some more!

Finally I discovered another workaround (to avoid the previous workaround and issue)... In CUCM, I set Devices > Phone > Find > Select > ('Phone Configuration') 'Extension Information' sub-heading > 'Log Out Profile' to the users mobility profile and then we do NOT have the issue. Rebooted phone, logged in, didn't log in, tried all different states - all works fine now.

I also found that by configuring a 'Line' on the device - the issue is also resolved.

HOWEVER, I don't really want to specify a specific user mobility profile or line configured for the individual phones if possible.


Is it possible to avoid this? What am I missing to avoid specifying a profile or line on the phone?

Cheers,

Brett

Message was edited by: Brett Hanson (In the original post I only specified 8.0.2 as the version - To make this discussion more relevant, I've just put in the full version details of the versions we were running when the issue was present. CAD excepted as I can't recall what version it was then.)

I have this problem too.
0 votes
Correct Answer by mark-baker about 3 years 9 hours ago

Brett,

This is a bug as identified in the following thread. https://supportforums.cisco.com/message/3271578#3271578

Please rate the provider of the information, Hoai Huynh, at the above link if it helps.

Hope this helps,

Mark

Correct Answer by bgc-tls-jlopez about 3 years 2 months ago

Hi Brett,

I have seen something similar once I installed UCCX 8.x at a customer.

The workaround there was to have a SU installed on the UCCX.

If this can help,

Kind regards,

Juan

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (3 ratings)
Correct Answer
bgc-tls-jlopez Tue, 02/08/2011 - 00:17

Hi Brett,

I have seen something similar once I installed UCCX 8.x at a customer.

The workaround there was to have a SU installed on the UCCX.

If this can help,

Kind regards,

Juan

brett.hanson@of... Tue, 02/08/2011 - 01:10

Hi Juan,


Thanks for the info and quick reply - just some clarity if possible?


Can you please explain what you mean by SU? SuperUser? ServiceUpdate? Some sort of add-on?

I've been out working on other projects for 6 months, come back into networks and our company had deployed UCCX, CUCM, etc. on me while I was away - so I was out of the loop a bit, thrown in on the deep end, and waiting on training (a couple of weeks away still).

Your help is much appreciated.

Cheers,

Brett

bgc-tls-jlopez Tue, 02/08/2011 - 01:37

Hi Brett,

I have been searching for mails about this as it's been a long time, without success.

I doubt if I had to install a service update to the UCM or to UCCX, not sure anymore though.

I am thinking it was to UCM however, it was something to do with jtapi. So easiest way forward may be to upgrade the UCM and UCCX and see if it resolved your issue (it did for me - and it was a simple service update)

hope this helps,

Juan

brett.hanson@of... Tue, 02/08/2011 - 01:44

I suppose I could try upgrading - but would like to avoid that for now if possible (have way too many Change Requests at the moment and a Data Centre move around the bend )

On a positive note...

I've found a sort of 'better' workaround... I've created a  kind of 'dummy' Device Profile with no line (Devices > Device Settings > Device  Profile), then assigned it to the 'Log Out Profile' of the devices I want to use mobility extension on.


Now when the phone is logged out - the default profile that is there is useless (can't make calls, receive calls, etc.).

The IPv6 issue is also gone with this setup, per my original post.

Sort of solved.

If we upgrade in future, will test again without the dummy device profile and post results to the forum.

Thanks again Juan, for your help.

brett.hanson@of... Mon, 04/11/2011 - 02:19

Still no updates on this unfortunately.

Have not updated CUCM and not intending to any time soon.


Will be sure to post if we do though.

brett.hanson@of... Tue, 05/03/2011 - 04:06

Hi Mark,

Thanks for advising of the bug ID.

Recently we updated our UCCX to SU3 which moved out UCCX version

From:     8.0.2.10000-41

To:          8.0.2.11004-12

Our CUCM System version remained at 8.0.2.40000-1

I just configured a phone back into the config I was having the trouble with (to replicate the fault again) - and it just won't happen.

No default profile configured - device not associated to anyone - no issue.

Just to be sure I hadn't messed up - I grabbed a new (never used) phone and configured it for extension mobility - did NOT associate in any way with anyone or anything (apart from JTAPI RMCM application user (which was done when I had the trouble before) - tested - worked (no issue).

Unfortunately I'm now unable to test the workaround for the version I was on and it is working now.


It appears as though it was a bug in the version - which is gone now due to update to SU3.

TBH though - I think I preferred my workaround over the Bug workaround anyway (created a device profile with no line and applied it as Default 'logged out' profile to all phones with Extension Mobility enabled).

At least I now know it was a bug and it seems to be no more after the update.

Will give you the credit as it appears to be a bug in that version and you drew my attention to the bug.

Thanks for the input.

brett.hanson@of... Tue, 05/03/2011 - 04:07

PS. gave Hoai a rating on the linked you posted.

The bug ID referenced by Hoai is CSCti18636

The details of the bug are as follows (note the workaround - but Service Update 3 installed on UCCX appears to resolve the issue)...

CSCti18636            Bug Details

Extension Mobility user can't login as UCCX CAD Agent
Symptom:
CAD users can't login to CAD agent software with error message can't login because IPV6 enabled which is not supported by CAD

Conditions:
If those user phone using Extension mobility

Workaround:
Associate  the IP phone's MAC address with the end user from the Call Manager's  end user configuration page under controlled devices.

Related Bug Information

CAD agent can't login error phone is IPV6-enabled not compatible 4 cad
Symptom: You cannot log in because the phone is IPV6-enabled phones are not compatibale with CAD  Conditions: when Extension mobility enabled on the phone and no non-ACD DN shared   Workaround: none
Roman Rodichev Tue, 05/10/2011 - 14:30

FYI, I have just ran into the same issue with 8.5.1.10000-37 but there's no SU updates for it available yet.

brett.hanson@of... Mon, 05/30/2011 - 03:12

Hmmm... that is strange Roman - seeing as your version is definitely a newer one than mine.

For some reason my issue is gone but per my above notes, I can't really explain why if your version is having the issue.


PS. You could try what I did - creating a dummy profile or try the Bug 'workaround' suggestion.

Workaround:
Associate  the IP phone's MAC  address with the end user from the Call Manager's  end user  configuration page under controlled devices.

(In CUCM > User Management > End User > find the user > next to the 'controlled devices' box, click on 'Device Associations', locate the phone by whichever means, check the box next to the device, click 'Save Selected/Changes'. No need to have the phone actually logged in as a person, but associate it from what I gather from their notes).

Thing is in my config for my phone - I have my end user settings with no associated devices.

I only have an associated device profile for CTI controlled devices.

I also have my profile in the extension mobility section of end user config set to my profile in 'Controlled Profiles' and 'Default Profile' as my profile, and 'SUBSCRIBE Calling Search Space' set to my CSS.

Hope this helps.


PSS. Please post back if you find a solution!

Roman Rodichev Mon, 05/30/2011 - 11:32

My issue turned out to be user related. The Windows XP was running inside a VM on Parallels on a MAC. Parallels automatically has NAT, IPv4 and IPv6 enabled. This caused the issue. I disabbled IPv6 for the VM (not in WinXP) and it fixed it.

brett.hanson@of... Fri, 07/22/2011 - 21:27

I wonder if disabling IPv6 in Windows would resolve the issue.

I'm not having the issue anymore & can't determine definitively why.

As I understand, IPv6 is enabled by default in Windows Vista and upwards.

So shouldn't be an issue for XP folk - short of Roman's scenario where XP was running on a VM - where the VM settings had IPv6 enabled at the VM server level rather than the guest OS level.

If anyone else comes past here with this issue - please try disabling IPv6 on the host running CAD.

If you already have IPv6 disabled on your host, then re-enable it and try again.

To disable IPv6 perm. see this article (Win 7)

http://www.addictivetips.com/windows-tips/how-to-disable-ipv6-in-windows-7/

*** disclaimer *** Be sure to backup your registry before doing this and if you decide to modify the registry, you do so at your own risk. Also - I am not aware of your specific network requirements and you could quite possibly require IPv6 in your environment - so please check with your IT Support / Admin team before following any advice here.

Please then post back with the outcome so we can see if this is the cause and finally close the discussion.

bvanbenschoten Wed, 01/18/2012 - 07:37

I had the issue on multiple 32-bit XP machines as well.

CUCM 8.6(2)

UCCX 8.5(1) SU2 + COP2

rcarricato Tue, 11/08/2011 - 10:53

I was receiving the same error and this resolved it for me:

CUCM > Devices > Device Settings > Common Device Configuration > Find > my CDC > the IP Addressing Mode setting WAS set to 'IPV4 and IPV6'.

I changed this to 'IPV4 Only'.

cogden Tue, 11/08/2011 - 12:16

I concur with the post above.

In my case the versions are:

The version of CUCM is 8.6.2.20000-2

UCCX System version: 8.5.1.11002-22

I changed the Common Device Configuration IP Addressing Mode parameter to 'IPV4 Only'. Saved. Reset the registered phones and I was able to login with One Button Login (IPPA) using an extension mobility profile for an agent and also CAD (Cisco Agent Desktop). Works with CIPC now as well.

Phew, now we can move on.

nickkassel Mon, 12/12/2011 - 07:42

I'm also running CUCM 8.6.2.20000-2 and UCCX 8.5.1.11002-22, I have changed the CDC setting to IPV4 only and I am still getting the message saying that IPV6 is enabled.

I have tried this on 7945 and IP Communicator, anyone got any further suggestions?

silversnc Thu, 12/29/2011 - 17:20

So, I ran into this issue today and the tried the above suggestions first but the thing that seemed to fix it, is associating the User to the phone, so on the phone configuration set the owner user id, i was not using Mobility on any of the phones just phones with two extensions one personal and one is the agent line, so not only is the device associated to the user under the user configuration but the user is associated with the device under the device configuration.

Good luck!

brett.hanson@of... Thu, 12/29/2011 - 18:18

As the issue we were experiencing was when using Extension Mobility (EM) with phones configured with no DN, I believe the "owner user id" setting becomes obsolete.

I just did some checking and the setting is definitely grayed out when EM is enabled.

Interestingly, it did allow me to change/set the user id even though it is grayed out.

I suspect this field becomes deadweight once EM is enabled....but maybe not (can anyone confirm).

I would prefer to leave the phones unassociated as they're shared Service Desk phones, but it may be a suitable workaround if it works.

EM enabled (grayed out):

EM NOT enabled (not grayed out):

Thanks for your input - as this could help someone with the same error but with non-EM phones....or potentially a workaround for those who do use EM, if the setting still has an impact even though grayed out.

brett.hanson@of... Thu, 12/29/2011 - 01:07

RE: "CUCM > Devices > Device Settings > Common Device Configuration > Find > my CDC > the IP Addressing Mode setting WAS set to 'IPV4 and IPV6'.I changed this to 'IPV4 Only'."

Resolving some people's issues...

Strange... it was one of the first things I tried (per my first post) when the issue came about - didn't resolve it for me then.

If it works for others - that's great, thanks for adding to the discussion and letting us know it worked for you.

bvanbenschoten Wed, 01/18/2012 - 07:20

I opened a TAC case and the CDC solution worked for me.  None of the other work around's with EM or associating the user worked for me before this.

Is the cause of this a CUCM issue or a UCCX issue ?  Any idea of when it will be patched ?

Resolution:

  • Go to CUCM Administration > Device > Phone and click the phone which has the issue
  • Check the configuration of “Common Device Configuration”, e.g. it is configured as “CDC”
  • Go to Device > Device Settings > Common Device Configuration and click “CDC”
  • Change the “IP Addressing Mode” to “IPv4 only”
  • Reset the phone from CUCM phone configuration page
  • Login again

-          Go to CUCM Administration > Device > Phone andclick the phone which has the issue

-          Check the configuration of “Common DeviceConfiguration”, e.g. it is configured as “CDC”

-          Go to Device > Device Settings > Common DeviceConfiguration and click “CDC”

-          Change the “IP Addressing Mode” to “IPv4 only”

-          Reset the phone from CUCM phone configuration page

-          Login again

Yorick Petey Mon, 01/30/2012 - 00:35

Hello Chris,

I have the exact same problem with the same versions  of CUCM and UCCX.

CUCM: 8.6.2.20000-2

UCCX: 8.5.1.11002-22

We did not have the problem when we ran CUCM 8.0 and UCCX 8.0.

We are not using extension mobility for the agents  (the phones are however enabled for EM).

We receive the ipv6  error message on CAD. When we force the phones to use IPv4 only (from  the common configuration profile) and reset them, it works back.

At this time, we don't have phones where this workaround does not work.

The  workaround for the bugID CSCtk00173 is inefficient because the CRS  Engine was already restarted several times after the upgrade from 8.0.

Both bugs seem fixed in the current versions we are running, is there another root cause?

Actions

Login or Register to take actions

This Discussion

Posted February 7, 2011 at 7:50 PM
Stats:
Replies:21 Avg. Rating:5
Views:9220 Votes:0
Shares:0

Related Content

Discussions Leaderboard