Nexus vPC load-balancing

Unanswered Question
May 4th, 2011

We are having some issues with vPC load-balancing on our Nexus 5000 switches. The vPC consists of 1 interface on each 5000, but we are only seeing traffic sourced from nexus on one of the interfaces

Return traffic from our blade switches are utilizing both links.

part of running-config:


port-channel load-balance ethernet source-dest-ip invalid-hash

vpc domain 1

     peer-kepalive destination <snip>


interface port-channel 1

     switchport mode trunk

     vpc peer-link

     switchport trunk allowed vlan 1-90,92-4093

     spanning-tree port type network


interface port-channel 2

     switchport mode trunk

     vpc 2

    

we have 1 interface assigned to each channel-group. we have tested both lacp and static mode. Anyone else seen this type of behaviour?

-Jeppe

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
marcel.zehnder Thu, 05/05/2011 - 05:23

Hello

Could you post some kind of network diagram? If I get you right the problem only occurs in the direction N5k --> Blade Switches: Maybe there's a problem one layer above (rest of LAN ---> N5k), like traffic is arriving only on one of your two N5k's?

-Marcel

Actions

Login or Register to take actions

This Discussion

Posted May 4, 2011 at 6:52 AM
Stats:
Replies:1 Avg. Rating:
Views:1160 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,730
4 7,083
5 6,742
Rank Username Points
160
77
70
69
50