Configuration Professional (CP) with Windows 7 64bits and Internet Explorer (IE) 9

Unanswered Question
May 4th, 2011

Hello!

I have installed the last version of Cisco CP (v2.5) on a Windows 7 64 bits laptop with Internet Explorer 9 and when i execute the software (for the first time or not), i have an error like this : "Access to C:\Program Files (x86)\Cisco Systems\CiscoCP\bin\_uiDefaultLoadComplete was denied."

The software don't work anymore and i get only a blank screen and this error. I've tried rebooting and i have all requirements for the software if i read the documentation (java for example).

Please help me with this problem... It's urgent!

Thank you very much.

Simon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.2 (7 ratings)
Vinod Arya Thu, 05/05/2011 - 01:32

Hello Simon,

It seems that you have some security issues and hence the permission is being deinied while launching the software.

Please check and try to add more permissions to the CP install directory. Try to add full control to "Users" or if not available add "Users" and give full permission to it.

For that goto the install root (C:\Program Files (x86)\Cisco Systems\) and do right click > properties > Security > add/modify Users to add Full Control.

Then try to lauch the software and see if it helps.

-Thanks

Vinod

cybertechmedia Thu, 05/05/2011 - 06:19

Hello Vinod,

Thank you for your answer, i will try this today and give you the result.

Simon

cybertechmedia Sat, 05/07/2011 - 11:51

Vinod,

I have do the changes suggested and i don't have anymore the error message , but the software don't want to execute anyway. It freeze to the internet explorer window. I have fixed the problem with these two other changes :

- Start the software explicitely as administrator (right click on icon);

- Autorize Flash plugin ActiveX in the Internet explorer 9 browser for the local address of Cisco CP.

If it can help any others. The Windows 7 and Internet Explorer 9 security settings seem to cause some locking by default.

Thanks!

Simon

Vinod Arya Mon, 05/09/2011 - 22:58

The main reason behind the issue seems to be the installation on the machine using a Domain controller account and not a local administrator account.

Usually some of these softwares requires a rwx permissions with local admin account, or atleast you should install such app using a local account on machine having admin priveldges, if administrators account is n not an avaialble option.

the IE security and some other issues still may remain there, as that is in the OS side.

-Thanks

Vinod

cybertechmedia Tue, 05/10/2011 - 06:55

Hello,

The version of Windows 7 is Home Premium and the computer is not member of a Windows domain (only workgroup). My account is a local administrator user on the computer and i've doing the installation of Cisco CP with this account. The UAC settings is by default and i need to run the software as administrator (as an administrator account don't really run in admin context by default on Windows 7) to make it work.

For IE, this is also a security problem and i need to manually autorize Cisco CP to execute Flash content in the browser.

Really strange probleme, do you have a complete procedure for installation requirements on Windows 7 with IE 9?

Thanks.

Simon

Vinod Arya Thu, 05/26/2011 - 03:15

Hi simon,

You can see the Install and Upgrade Guides for detailed information.

Though in Cisco Configuration Professional Quick Start Guide it is clearly mentioned for Win7 as:

Note If you are installing Cisco CP on a PC that uses the Microsoft Windows Vista Business Edition operating system or the Microsoft Windows 7 operating system, be sure to install while using Microsoft Windows Vista Business Edition or Microsoft Windows 7 in administrator mode. You can do this by following the Microsoft Windows instructions to create an administrative account, and then logging on to the PC using that account name and password before installing Cisco CP. Failure to do this will require you to right-click on the Cisco CP icon or menu item, and choose Run as administrator each time you want to run Cisco CP.

Please check.

-Thanks

Vinod

chaitram Thu, 05/26/2011 - 02:41

Hi Simon,

   If you have all the requirements met(Java and Flash player for IE), and if Run as admin does not solve the launch problem, pls try the following:

1. Close the CCP Application

2. Clear the Java Cache from:

Start -> Control Panel -> Java 32 -> General Tab -> Settings (Under Temporary Internet Files). Click Delete.

3. Clear the IE Cache from:

On a browserwindow, clear  the cache from Internet Options Menu -> General Tab ->Delete. (Delete the Temporary internet files, cache, cookies).

4. Launch CCP with Right click-> Run as Admin,

Let me know if this works for you.

Thanks

Chaitra

walter baziuk Sat, 10/15/2011 - 20:09

CCP 2.5 no longer will run in win 7

Right after MS patch Tuesday this week, i can't run CCP2.5 anymore on my Win7 laptop, it worked before (;

when it starts, CCP complains that the flash player is not installed,.

I checked and the flash player is installed.

I have tried to uninstall flash 11 and reinstall 11, same issue.

I have tried to uninstall flash 11 and install flash 10; flash won't let me as it complains that their is a newer version. I can't find a complete flash 10 d/l , just ones that go to the web to d/l (;

i am running win 7 ultimate, ie 9 is on this machine.

i am trying to find ie 8 for win 7 to see if IE is the issue. but ie 8 can't be install on win7(; only ie 9

has anyone run into this latest CCP issue. please advise before i open a TC case

I wish that Cisco would stop using flash, i find it buggy

help on this issue would be useful

arungreig Sat, 10/20/2012 - 23:39

Hi Douglas,

Thank you very much...

After installing flashplayer_10_ax_debug, CCP is running on my machine.

ENOCK2012 Thu, 04/18/2013 - 11:14

Hi Douglas,

Am really greatful for the solution you suggested.I was so frrustrated but now am happy.My CCP is running very well after installing flashplayer_10_ax_debug.

steve.bowen Tue, 04/30/2013 - 16:19

Configuration Professional (CP) with Windows 7 64bits and Internet Explorer (IE) 10

I first turned on compatibility mode for site 127.0.0.1

then Right-click CCP and "run as administrator"

Works perfectly!

cartam962 Sat, 06/22/2013 - 09:30

Hi,

I've this problem with CCP: when it starts it uses only 1/4th of the whole ie10 window, yes I can use the V & H scrollbars but it's boring. I attached a print screen of what I get. I tried all it's suggested in the posts above and in others threads but with no avail.

Thanks for helping. Mike.

joshdave300988 Mon, 07/08/2013 - 11:24

Hi Guys,

I had the same problem, all did was the following steps,

--->Changing permission for the Cisco system folder

--->Then running it in admin mode

--->For Mike, I have good tip, here it goes,

  • Open IE 10
  • enable menu bar (right click of address bar)
  • go to Tools (Ger. Extra)
  • choose Compatibility View (Ger. Kompatibilitätsansicht)
  • add the 127.0.0.1 in the list

It all works fine now, thanks a lots guys

  points

souguinour Thu, 09/12/2013 - 08:26

Hi Joshua. I would like to thank those who brought up this issue and particular thanks to you. I followed as you mentionned and it worked for me. Thanks. Sougui

ajinks800 Tue, 02/04/2014 - 10:24

This has been such a pain... Ok so I finally got it running (CCP 2.6) on Win7 64-bit with the following:

- IE11

- Java (both are checked in Java settings):

1.6.0_7 (-Xmx256m)

and 1.6.0_17 (-Xmx256m -Dsun.java2d.d3d=false)

I've unchecked the next-gen Java plugin feature

- Run as Administrator (sucks but it works, I just need to remind myself everytime)

The program opens and it seems EVERYTHING runs EXCEPT the one thing I need to get to, which is the Firewall settings.

In CCP, when I click Security > Firewall > Firewall then select the 'Basic' or 'Advanced' options, then click "Launch the selected task" button, nothing happens.

Am I missing something here?  Is there something I need to set first to enable this feature?  I'm using a 2911 with the following IOS:

ROM: System Bootstrap, Version 15.0(1r)M15  It was hard to get even this far but this is what I have been trying to get to!  Help!  Any suggestions??

Actions

Login or Register to take actions

This Discussion

Posted May 4, 2011 at 5:28 PM
Stats:
Replies:16 Avg. Rating:4.2
Views:25379 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,483
2 1,624
3 1,445
4 861
5 578